1 2 Previous Next 23 Replies Latest reply: Nov 26, 2012 6:21 AM by vikovic
bugoyboy Level 1 Level 1 (0 points)

Just recently upgraded my Mac OS X to Mountain Lion.  Did notice though that all-day events in my Calendar now have alerts.  Was able to remove them from Calendar in my MacBook, but noticed that they're still there in my iPhone and iPad even after synchronizing these with my MacBook.  Any suggestions on how to remove the alerts from all the all-day events without resorting to manually removing them one by one?


MacBook Air, Mac OS X (10.7.1)
  • 1. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Ferd II Level 7 Level 7 (23,430 points)

    bugoyboy,

     

    Have you selected your desired alert preferences in Calendar>Preferences...>Alerts?

    Screen Shot 2012-07-28 at  Jul 28, 2012 20.44.15 .png

    /___sbsstatic___/migration-images/190/19076559-1.png

  • 2. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    bugoyboy Level 1 Level 1 (0 points)

    Yes, all alert preferences have been set to "none", both in the MacBook Air, iPhone and iPad, but still getting alerts left and right.  But the box for "Use these default alerts on only this computer" is checked and there seems to be no way to uncheck it in my MacBook Air.  Any thoughts?

  • 3. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    nukethwhls Level 1 Level 1 (0 points)

    I'm running into the same issue; my defaults for Calendar on Mountain Lion are for no alerts, but once iCloud pushes my calendar events to my iPad, an alert for 12 AM is added for an all-day event on my iPad, and at the time of the event for a regular event.

     

    "Use these default alerts on only this computer" is unchecked for me.

  • 4. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Primo.TM Level 1 Level 1 (0 points)

    Same here. On Mac Calendar all alert are set to None, but when it syncs all day events with my iPhone I get an alert for 00:00.

  • 5. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    kscneev Level 1 Level 1 (0 points)

    I`ve got this problem too.

    When I add an event in calendar (ML) and push it into iCloud on iPad2 I see an alert set up at midnight but when I look at this event on icloud.com there is no alert added.

    But if I add an event through web interface and sync in - no alert is added in Mac and IPad.

    All the settings an iPad and Mac are the same - all automatic alerts disabled.

     

    So I think that the problim is with Calendar.app.

     

     

    P.S. Sorry for my English.

  • 6. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Lolocito Level 1 Level 1 (0 points)

    Hi,

    I have exactly the same problem with my iphone. On my Mac I see no alerts, but they appear on my iphone. I have tried to remove icloud connection and restore it, and even delete a calendar and re-import events, nothing solved.

    I had made an automator app to cancel all alarms for my wife's calendar, and even after running it, alarms are still on my iphone.

    If someone has a solution, it would be great!

    And please, if someone from Apple is coming here, try to convince your developers to enable "ignore alerts" for a calendar on the iphone (like in calendar).

  • 7. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    bugoyboy Level 1 Level 1 (0 points)

    Still haven't found out why Mountain Lion adds alerts to events that don't have alerts on my MacBook, but have found a workaround for those who find the alerts annoying.

     

    Go to Settings > Notifications > Select Calendar from "In Notification Center". For Alert Style, select "None", change Badge App Icon to "Off" and change View in Lock Screen to "Off". 

     

    Then go to Settings > Sounds.  Set Calendar Alerts to "None" and Reminder Alerts to "None".

     

    This will not remove the alerts from the events, but will at least stop the annoying sounds and notifications that keep popping up on your screens.

     

    Hope this works for you guys. :-)

  • 8. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Lolocito Level 1 Level 1 (0 points)

    Thaks for this tip bugoyboy, but it doesn't help, as I still want all the alarms of my other calendars

  • 9. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Jeroen Kuper Level 1 Level 1 (0 points)

    I have the same issue here...

     

    Event not only for all-day event, but for all events which are created of updated via the Calendar app on one of my Macs.

    The strange thing is that the alert does not show-up back on my Macs after iCloud has added a default alert on the new/changed event on all the synced iOS devices. Also, the alert does not go off on the iOS devices when the event should occur. So it looks like it is only a label with no function in my case, which does not mean that it is not frustrating me!

     

    Apple please help!

  • 10. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    IrenaB Level 1 Level 1 (0 points)

    The same problem to me. I have a namesday calendar with all day events every day (names, repeating year by year), and now I get an alert every day 9:00, though alerts are set to "none". This appears only for that specific calendar with all-day events, no other calendars affected. I have synced this calendar on my iPad and iPhone, and now also on them have got those undesired alerts, since Mountain Lion installation. Before, with Snow Leopard and Lion there was no such problem.
    What is interesting, the all-day events that come from Google calendar, have not got the undesired alerts, only the calendar "On my Mac" has got.

  • 11. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    josear1978 Level 1 Level 1 (0 points)

    Any one find a solution ye?

  • 12. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    Jade Benedict Level 1 Level 1 (0 points)

    I had the same problem as well. I created an all day event on mountain lion but after it sync with my iPhone, it added an alert "on day of event 12am"

     

    I notice that it does not alert me on my phone as well as my macbook pro eventhough its showing that is has an "alert"

  • 13. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    jim_bass Level 1 Level 1 (0 points)

    re: Mountain Lion adding default alerts that you can't get off you iPhone/iPad

     

    Found a workaround that fixed the problem for me.  All posts and other help did not work on my MacBook Pro/iPhone 4s/iPad 3....Here's what I did.  First, exported each individual calendar to a .ics file on my desktop.  Then removed all calendars.  Then went to Calendar->Preferences->Alerts and selected "None, None, None".  The check box for "use these default settings only on this computer" is checked and grayed out, so I could not change it.  Then went to System Preferences->iCloud and unchecked Calendars and Reminders, and Documents and Data.  Got the warning that it would delete data on MacBook but that's the only option, so I did it and did not seem to lose any data.  Then opened iCal and imported each .ics file from the desktop.  After that was done, I checked Calendar->Preferences->Alerts again and it had changed back to default alert at 9:00am, so I changed again to "None" .  Then I went to iPhone and iPad and in Settings->Mail, Contacts, Calendars, changed Calendars->Default Alert Times-> to "None, None, None". Then on iPhone and iPad went to Settings->iCloud deselected same Calendars and Reminders, and Documents and Data.  Restarted all...sync'd to iTunes, first time checking replace calendar data on iPhone and iPad (Bottom of "Info" tab)...Then sync'd again and all alerts are gone now on all devices and everything is working like it was using Snow Leopard.  Takes a few steps and a little time, but this worked great for me and no issues since.

     

    One thing to mention is that I tried all these steps without deselecting "Documents and Data" in iCloud settings, and it didn't work.  Had to do each step in above order to get things the way they were before Mountain Lion.

  • 14. Re: How do I remove calendar alerts on my iPhone that were added when I installed Mountain Lion
    TheWaynedear Level 1 Level 1 (10 points)

    I'm having that same issue, and have over 100 all-day Calendar events (is it just all-day events).  Why on earth would Apple design the Mountain Lion upgrade to just go in an create calendar alerts and activate them?!  This is driving me crazy.  If I would have known this was going to screw up my Calendar on my Mac and iPhone again (previous issues caused by .Mac and MobileMe sync duplicating problems), I wouldn't have upgraded to Mountain Lion, although I like Pages and Numbers documents finally syncing.   

     

    I appreciate Jim's work-around solution, but I can't delve into something like that right now. 

     

    Would like Apple to issue a true fix!

1 2 Previous Next