Skip navigation

"Mouse Over" issues in Logic Pro - Mountain Lion

2464 Views 17 Replies Latest reply: Dec 20, 2013 7:05 AM by Bakmaind RSS
1 2 Previous Next
Vlvl Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 26, 2012 3:46 AM

Hi,

 

Since I upgraded to Mountain Lion, I spotted an issue with Logic Pro (Logic 9).

 

In the Arrange window, when pointing the mouse at the end of a region, the pointer icon doesn't change to the looping (upper right corner of the region) or resize (lower right corner) icon.

As a result, those functionalities (looping and resizing regions) are gone.

 

Anyone having the same issue?

Is there a way to solve this or do we need to wait for a Logic Pro update to get these back?

 

Thanks in advance,

A nice day everyone,

 

Vince

MacBook Pro 15'' Intel Core 2 Duo 2.2 GHz 2 GB RAM, Mac OS X (10.5.3)
  • Ivan Clarke1 Level 2 Level 2 (315 points)
    Currently Being Moderated
    Jul 26, 2012 4:14 AM (in response to Vlvl)

    Okay, do you have time machine?

     

    Here is a golden rule for you. if you are a muscian or anyone that uses Prosumer software like Logic Pro you do NOT upgrade your operating system to the new version for at lerast three months.

     

    There are always issues with new upgrades and the Prosumer software and hardware drivers. These do nothing but get in the way of your creativity!

     

    my advice would be to wind back the clock.

  • P1nk D3ath Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2012 9:41 PM (in response to Vlvl)

    I have the same exact issue. Also when I push esc on the keyboard and change to the pencil or eraser tool the icon does not always change to the appropriate icon, which is annoying. I did not upgrade to mtn. lion but burned the DMG to a disk and clean installed it onto my hard drive with Logic 9.1.7. I am assuming an Logic Update will be released “Soon-ish” hopefull it does not take too long

  • Ivan Clarke1 Level 2 Level 2 (315 points)
    Currently Being Moderated
    Jul 31, 2012 2:04 AM (in response to Vlvl)

    Vlvl wrote:

     

    As it's the only problem I have noticed since the upgrade, and as I mentioned in my last post, looking like a minor problem to me, I will keep Mountain Lion.

     

    But anyway, thanks for the advice, Ivan.

     

    Vince

    No problem, as a professional musician using Logic I learned that lesson the hard way first time around. Hard as it was to not have the toys I soon learned that stability ruled the day....

  • gc132 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 7:58 AM (in response to Vlvl)

    OP: Same problem here. I don't accept the delayed upgrade argument. Half the reason I have a mac running OS X + Logic is because they are both programmed by employees of Apple.

     

    It doesn't seem right that they wouldn't test their own apps for compatability in their own upcoming OS's as they expect third party developers to (developer preview anyone?). They are getting undeniably lazy with their pro support.

  • Dylan Winslow Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 19, 2012 3:54 PM (in response to Vlvl)

    I've had this problem since upgrading to Mountain Lion as well. Having a look around the web, I found one interesting observation which I have tested and found to be true on my own machine: the cursor works fine and as expected if Logic is open in desktop 1 and not in fullscreen mode.

     

    They still need to fix it, as well as the ugly mix of prokit/Aqua elements in Logic's file dialogs (I assume I'm not the only person getting this).

  • Promiceus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 6:34 AM (in response to Vlvl)

    For me CMD doesn't work exactly as a cure. It switches only with CMD pressed. But if you let go CMD it just stays in the form it is at the moment. So you can have any cursor: let CMD go off above left or right 'middle' of the region and cursor is always 'loop'. Or let CMD go off on bottom left or right to get 'resize' cursor.

     

    10.8 > 10.8.1 > 10.8.2, Logic 9.1.7

  • Beger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 1:52 PM (in response to Promiceus)

    Getting the exact same results with Logic Express 9. I keep checking for software updates everytime I open logic just praying they'll fix this annoying glitch...but still nothing as of yet.

  • tote Level 1 Level 1 (0 points)

    I've been puling my hair out on this issue, but this solved it. So now I've set up the Dock to open Logic in Desktop 1.

     

    Thanks!

  • zahkman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2013 9:06 AM (in response to Vlvl)

    Yeah I had the exact same issue, but opening in Desktop 1 does fix it, but it's still should be fixed. Thanks for the help guys.

  • ljubo144 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 2, 2013 9:33 AM (in response to Vlvl)

    Opening in Desktop 1 fixed for me. Thanks for posting the solution - it was driving me nuts. I hope an update fixes this.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.