Skip navigation

Constant beachballing after sleep when WiFi enabled

2123 Views 10 Replies Latest reply: Jul 31, 2012 4:55 PM by pcarlson RSS
Dr_David Level 1 Level 1 (10 points)
Currently Being Moderated
Jul 26, 2012 10:32 AM

Ever since upgrading to Mountain Lion, I'm having an issue where after the computer wakes from sleep, I get constant beachballing, but ONLY if the wifi is enabled. If I disable wifi, the computer will perform flawlessly. For the sake of completeness, I also have a wired ethernet connection plugged into the computer at the same time that my airport is enabled. This has never (and should never) create an issue. Network priority is given to the ethernet.

 

You can see a video of what it does here:  http://www.youtube.com/watch?v=ts0jRvlfBX0

 

What's odd is that it doesn't actually cause the entire machine to completely freeze, it causes it to freeze one app at a time. And, there's absolutely no way to fix it that I can find, other than by doing a cold restart.

 

I've deleted the airport plist file at /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist and reset the PRAM.

 

I know there were discussions about this before ML was released, and I've filed a radr on it as well; but, I haven't heard anything back from Apple.

 

Does anyone have any insight as to what could be happening and how to resolve this (apart from just leaving my wifi disabled).

MacBook Pro, OS X Mountain Lion
  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Jul 26, 2012 12:29 PM (in response to Dr_David)
    27" i7 iMac 10.6.8, Mac OS X (10.7.4), G4 450 MP w/Leopard, 9.2.2
  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 2:19 PM (in response to baltwo)

    How is this helpful to the issue at hand?

  • baltwo Level 9 Level 9 (59,150 points)

    OP claimed:  I'm having an issue where after the computer wakes from sleep, I get constant beachballing.

     

    The response deals with that issue, which is step one. BTW, where's your sage advice?

    27" i7 iMac 10.6.8, OS X Mountain Lion, G4 450 MP w/Leopard, 9.2.2
  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 2:42 PM (in response to baltwo)

    Just seems that we all understand what the beachball is representing, yet nothing in the link refers to wifi issues, which is the problem. As well, it seems that he has already gone through several steps. There are many of us with this or a very similar issue and real solutions are not being found. I apologize for seeming seeming terse, but it seemed that the OP understood what the beachball represented.

     

    FYI here is the crossed referenced thread that brought me to this one. Maybe you have some input on this problem?

  • baltwo Level 9 Level 9 (59,150 points)

    No, can't offer anything else, since i never sleep desktops, don't do wifi, and it's not covered in the SBBOD link.

    27" i7 iMac 10.6.8, OS X Mountain Lion, G4 450 MP w/Leopard, 9.2.2
  • pcarlson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2012 11:11 AM (in response to Dr_David)

    I was having the same problem after installing the upgrade to Mountain Lion and tried every fix I could find online, none of which worked more than a few minutes.  I called Apple support yesterday, even though this iMac is about 18 months old, asking for a waiver on the support fee because I wasn't having the problem before the upgrade.  They granted me the waiver. 

     

    After walking me through most of what I'd already tried, although I hadn't deleted the plist files yet, we got down to the nitty-gritty of the problem.  I was using WEP encryption on our wifi router.  I was told that I would keep having the wifi connectivity problem unless I changed to WPA encryption, and that I should have been having similar problems under Lion, which I wasn't

     

    After hanging up, I changed my wifi encryption to WPA on my PC upstairs, went downstairs to the iMac and relinked to the network, did the same with the iPhones and iPad as well as the Bluray player.  Mind you, I was having no problems with any of those except the Mac.  We are now at 24 hours without a wifi drop.  It was the simplest fix I'd tried.  So if your router is using WEP, try changing it to WPA encryption. I thought I'd have problems with my old HP printer using wifi with my PC upstairs, but it didn't even blink in connecting to the router.  The most difficult to connect - or slowest - was the Bluray player in the family room.

  • pcarlson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2012 4:55 PM (in response to Dr_David)

    Perhaps it shouldn't, but my Mac has not dropped its wifi connection since I made this change.  And I do understand all the issues with WEP but was afraid that my old HP printer would not be able to connect to my desktop using WPA or WPA2, because I'd tried it while setting it up, and it hiccupped and would not connect.  Yesterday it connected easily, for whatever reason.

     

    What I was told is that if I continued to use WEP encryption, the Mac would keep dropping the connection.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.