1 2 3 Previous Next 85 Replies Latest reply: Jun 16, 2014 5:15 PM by Jon Walker
JSBillian Level 1 Level 1 (0 points)

Hello,

 

I have Perian as my AC3 Dolby Codec and it was working fine until I upgraded to Mountain Lion. Does anyone have advice on what can be done? It seems as if there arent any Dolby AC3 codecs compatible with Mountain Lion. If anyone can help, I greatly appreciate it.

 

Thanks!


MacBook, Mac OS X (10.7.3)
  • 1. Re: My AC3 Codec is not working. Help!
    Gary Scotland Level 6 Level 6 (8,185 points)

    why do you use AC3 files, are you authoring DVD?

     

    If you have an authoring application or an encoding application on your Mac, you will have an AC3 codec on your machine.

     

    The Apple AC3 codec used with Compressor  and DVDS Pro works fine in ML

  • 2. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    I have the same problem, I tried to open some avi movies and there's no sound since I've installed ML... I read that Perian will stop developing updates so I think this problem will continue unless apple provides a codec for quicktime playing avi files with sound...

  • 3. Re: My AC3 Codec is not working. Help!
    Jon Walker Level 6 Level 6 (17,620 points)

    I have Perian as my AC3 Dolby Codec and it was working fine until I upgraded to Mountain Lion. Does anyone have advice on what can be done? It seems as if there arent any Dolby AC3 codecs compatible with Mountain Lion. If anyone can help, I greatly appreciate it.

    Can you be more specific regarding your problem? Which player are you using? What kind of files/content are you trying to play? Are trying a passthrough of the AC3 5.1 data or play it as "mixdown" stereo, DD PL, or DD PL II audio?

     

    On my Mountain Lion system I am assuming the QT X player is still using QT X native AC3 playback support while the QT 7 Player is still using Perian AC3 playback support. However, I had noted the following items of possible interest for my H.264/AAC/AC3 files in M4V file containers:

     

    1) The QT X Player appears to list the "English" Language tracks in their proper order (AAC followed by AC3) and I am able to switch between tracks using the View menu "Language" option but the "Inspector" window does not update reflecting the change.

     

    2) The QT 7 Player seems to list the "English" Language tracks in their reverse order (AC3 followed by AAC) and I am unable to switch between tracks using the View menu "Language" option. However, I can switch between the Language tracks manually using the "Properties" window and the "Inspector" window is immediately updated to reflect the audio track compression format being played.

     

    3) The AC3 DD5.1 default (L C  R Ls Rs LFE) speaker assignment for my M4V files appears to play correctly in both the QT X and QT 7 players.

     

    4) An AC3 audio file containing AC3 DD5.1 default (L C R Ls Rs LFE) speaker assighment only appears to play correctly in the QT X Player.

     

    5) An AC3 audio file containing AC3 DD5.1 Perian recommended (L R C LFE Ls Rs) speaker assignment only appears to play correctly in the QT 7 Player.

     

    6) The QT X player will only open/play an AC3 audio file in an AC3 file container while the QT 7 Player will open/play an AC3 audio file in either an AC3 or MOV file container.

     

    7) Not sure if this is new or not, but I changed the extension on a VOB file containing AC3 DD5.1 English, AC3 stereo Spanish, and AC3 stereo French audio to an MPEG extension and the file plays the video and all three audio tracks simultaneously but QT 7, as is normal, recognized none of the "muxed" AC3 audio streams. (Don't normally keep multiple language VOB files on my system so I don't know if this is different from Lion OS.)

     

    SJAUG.png

  • 4. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    Hi Jon, thank you for answering.

    I'm trying to use both QT7 and QTX but both plays avi file without sound.

    Here's an info for the avi file:

     

    General

    Complete name                            : /Users/MARCO/Desktop/Filmes/Extremely.Loud.Incredibly.Close.DVDRip.XviD-NeDiVx CD1.avi

    Format                                   : AVI

    Format/Info                              : Audio Video Interleave

    File size                                : 699 MiB

    Duration                                 : 1h 5mn

    Overall bit rate                         : 1 496 Kbps

    Writing application                      : VirtualDubMod 1.5.10.2 (build 2540/release)

    Writing library                          : VirtualDubMod build 2540/release

     

    Video

    ID                                       : 0

    Format                                   : MPEG-4 Visual

    Format profile                           : Advanced Simple@L5

    Format settings, BVOP                    : 2

    Format settings, QPel                    : No

    Format settings, GMC                     : No warppoints

    Format settings, Matrix                  : Default (MPEG)

    Muxing mode                              : Packed bitstream

    Codec ID                                 : XVID

    Codec ID/Hint                            : XviD

    Duration                                 : 1h 5mn

    Bit rate                                 : 1 103 Kbps

    Width                                    : 640 pixels

    Height                                   : 272 pixels

    Display aspect ratio                     : 2.35:1

    Frame rate                               : 23.976 fps

    Color space                              : YUV

    Chroma subsampling                       : 4:2:0

    Bit depth                                : 8 bits

    Scan type                                : Progressive

    Compression mode                         : Lossy

    Bits/(Pixel*Frame)                       : 0.264

    Stream size                              : 515 MiB (74%)

    Writing library                          : XviD 64

     

    Audio

    ID                                       : 1

    Format                                   : AC-3

    Format/Info                              : Audio Coding 3

    Mode extension                           : CM (complete main)

    Codec ID                                 : 2000

    Duration                                 : 1h 5mn

    Bit rate mode                            : Constant

    Bit rate                                 : 384 Kbps

    Channel(s)                               : 6 channels

    Channel positions                        : Front: L C R, Side: L R, LFE

    Sampling rate                            : 48.0 KHz

    Bit depth                                : 16 bits

    Compression mode                         : Lossy

    Stream size                              : 179 MiB (26%)

    Alignment                                : Split accross interleaves

    Interleave, duration                     : 42 ms (1.00 video frame)

    Interleave, preload duration             : 500 ms

     

    I also have another file but the problem is not the same.

    I can play it with QT7 (I have sound) but I can't even open on QTX, video doesn't start...

    Here's the info:

     

    General

    Complete name                            : /Users/MARCO/Desktop/Filmes/Trishna - BRRip - XviD - 1CDRip - [DDR].avi

    Format                                   : AVI

    Format/Info                              : Audio Video Interleave

    File size                                : 698 MiB

    Duration                                 : 1h 53mn

    Overall bit rate                         : 862 Kbps

    Writing application                      : VirtualDubMod 1.5.10.2 (build 2540/release)

    Writing library                          : VirtualDubMod build 2540/release

     

    Video

    ID                                       : 0

    Format                                   : MPEG-4 Visual

    Format profile                           : Advanced Simple@L5

    Format settings, BVOP                    : 1

    Format settings, QPel                    : No

    Format settings, GMC                     : No warppoints

    Format settings, Matrix                  : Custom

    Codec ID                                 : XVID

    Codec ID/Hint                            : XviD

    Duration                                 : 1h 53mn

    Bit rate                                 : 768 Kbps

    Width                                    : 672 pixels

    Height                                   : 288 pixels

    Display aspect ratio                     : 2.35:1

    Frame rate                               : 24.000 fps

    Color space                              : YUV

    Chroma subsampling                       : 4:2:0

    Bit depth                                : 8 bits

    Scan type                                : Progressive

    Compression mode                         : Lossy

    Bits/(Pixel*Frame)                       : 0.165

    Stream size                              : 621 MiB (89%)

    Writing library                          : XviD 1.2.1 (UTC 2008-12-04)

     

    Audio

    ID                                       : 1

    Format                                   : MPEG Audio

    Format version                           : Version 1

    Format profile                           : Layer 3

    Mode                                     : Joint stereo

    Mode extension                           : MS Stereo

    Codec ID                                 : 55

    Codec ID/Hint                            : MP3

    Duration                                 : 1h 53mn

    Bit rate mode                            : Variable

    Bit rate                                 : 84.9 Kbps

    Nominal bit rate                         : 90.0 Kbps

    Channel(s)                               : 2 channels

    Sampling rate                            : 32.0 KHz

    Compression mode                         : Lossy

    Stream size                              : 68.7 MiB (10%)

    Alignment                                : Aligned on interleaves

    Interleave, duration                     : 36 ms (0.86 video frame)

    Interleave, preload duration             : 526 ms

    Writing library                          : LAME3.98r

    Encoding settings                        : -m j -V 4 -q 2 -lowpass 15.1 --abr 90

     

     

    I hope you can reach a conclusion with this information.

     

    I just want to inform that when I try to open the first file on divx player I get the pop message saying that this file contains a track in the dolby ac3 codec (code 8192) format. I need to install QT component.

     

    I presume it's because perian needs to update the ac3 codec...

     

    Will wait for more conclusions...

  • 5. Re: My AC3 Codec is not working. Help!
    Jon Walker Level 6 Level 6 (17,620 points)

    Hi Jon, thank you for answering.

    Was actually directing my response to the OP. However, ...

     

     

    Here's an info for the avi file: ...

    As I understand it you have an AVI file container with XviD/AC3 content which plays the video but no audio in both QT X and QT 7 players and a second AVI file container with XviD/MP3 content which plays audio and video in QT 7 but has an unspecified playvback problem using the QT X Player. (Assume you may not have audio using QT X Player.)

     

    1) I don't use the AVI file type because it was replaced by Microsoft about 11 years ago and has not been officially supported since that time by its originator.

     

    2) I don't know if the "DivX Player" you referred to above means that you have the DivX codec software also installed on your system or not. However, if true, then there is a possibility of a codec conflict problem on your system if the Perian codec component package is also simultaneously installed. In my case, I use the Perian package v1.2.3 to handle both XviD and DviX video content and have no DivX software installed. (But then my work flow is directed toward the use H.264/AAC/AC3 content in M4V file containers for maximum OS/IOS device compatibility.)

     

    3) This Perian package (v1.2.3) also installed the v1.8 Core Audio A/52 and AC3 Codec Component in my "Audio/Plug-Ins/Component" folder which is what I assume is currently handlng QT 7 AC3 content if not both QT 7 and QT X.

     

    4) Since the Perian codec component package runs in the 32-bit mode, I do not usually try to watch AVI content in the 64-bit QT X Player which seems less compatible with many AVI "legacy" codecs than the QT 7 Player.

     

    5) Since you did not indicate if you had modified app handling of AC3 audio via "passthrough" to an external decoder, I do not know if you have been messing in your system with the Terminal app or not. In my case, the content is handled as DD Pro Logic II optical output to a decoder attached to my iMac (i.e., I did not make system chages which may or may not be compatible with any particular decoder) and as AC3 DD5.1 "Passthrough" output from all TV devices in my home while I let iTunes distribute the same file to iPhone, iPod, and iPad devices which themselves only support stereo but which can also Air Play 5.1 audio remotely through the TV devices.

     

    At this point all I can say is that it seems I can play AC3 and AAC audio via both the QT X and QT 7 players on my Mountain Lion system but cannot confirm whether or not this is also true for XviD/AC3 and/or XviD/MP3 AVI content since these are not file formats I normally use. And when I do use AVI files, the content is normally compressed as DivX5/MP3 content. Further, I am still using the same Perian codec component support installed in July of last year so, at least for me, there does not seem to be a current need to update AC3 playback support. My recommendation at this point might be to remove/reinstall the Perian software in case the upgrade to Mountain Lion broke the connection between your players and codec components as happened for may users during the Leopard to Snow Leopard upgrade.

     

    SJAUG.png

  • 6. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    Hi Jon, sorry for the confusion. I've said thank you because you were the only person who brought some explanation to the post and I just wanted to be kind for that...

     

    Now the codecs: I didn't change anything in the original install for the codecs mentioned. I've also tried to uninstall all them and just use Perian (same version as you 1.2.3), same problem, same situation for file 1 and 2. What I think is that quiacktime stop playing movies (avi files using ac3 codec) with sound with the ML upgrade as I've been using without problems with Lion and before with SL...

     

    You should get a file like those and test for yourself, I understand you have no need for that and you'd probably waste your time but it'd be the only way to check what's happening.

     

    Thank you for your time.

     

    Best Regards,

     

    Marco

  • 7. Re: My AC3 Codec is not working. Help!
    Jon Walker Level 6 Level 6 (17,620 points)

    You should get a file like those and test for yourself, I understand you have no need for that and you'd probably waste your time but it'd be the only way to check what's happening.

    Agreed. Best approach would be to test a file (or short snippet thereof) known to not be working on your system. Do you have anything suitable available that can be posted or emailed?

     

    SJAUG.png

  • 8. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    I'll try to get something, for now just have both movies about 650mb...

    I'll inform if I can get a small file with same problems

    Thank you

  • 9. Re: My AC3 Codec is not working. Help!
    Jon Walker Level 6 Level 6 (17,620 points)

    I'll try to get something, for now just have both movies about 650mb...

    I'll inform if I can get a small file with same problems

    You could try trimming a 10-30 second segment from start or end of your files and see if they have same playback problems. See my profile for email address.

     

    SJAUG.png

  • 10. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    Hi Jon I have the short video prepared to send but I can't find your email on your profile. Please send a message to marco9774@me.com and I'll reply with the file.

  • 11. Re: My AC3 Codec is not working. Help!
    Jon Walker Level 6 Level 6 (17,620 points)

    Hi Jon I have the short video prepared to send but I can't find your email on your profile.

    File received. For the benefit of other readers, here is what I found. Test XviD/AC3 file played audio and video using QT 7, MPEG Streamclip, and VLC media players under Mountain Lion. QT X Player only played the video portion of the file data. Problem may be associated with the interpretion of the samling rate by the QT X Player which thinks the sampling rate is only 32.0 KHz instead of the more standard 48.0 KHz AC3 DD5.1 sampling rate. (I.e., both QT 7 and VLC read the file as having a 48.0 KHz sampling rate and MPEG Streamclip did not correctly indicate the AC3 codec and thought the sampling rate was 0.001 KHz but played the audio anyway. Not sure if the problem is in the file's audio data header (more likely since both QT X and MPEG Streamclip had problems reading it) or the QT X player itself. In any case, QT apps are very "standards based" and if the QT X Player considers the audio to have been encoded with what it considers non-standard settings, may simply refuse to try and play the audio data whether encoded correctly or not.

     

    SJAUG.png

  • 12. Re: My AC3 Codec is not working. Help!
    R08 Level 1 Level 1 (0 points)

    AC3 should still play under Mountain Lion in QT X so I'm assuming your problem is with QT 7 and file formats not supported by QT X.

     

    For me this was happening with .mkv files containing AC3 audio played through QT 7 using Perian (which as I understand it is only getting one more release which may or may not fix this issue).

     

    Thankfully like all things it's easy when you know how, this is what worked for me.

     

    Download and extract the A52Codec.component file and replace the one in your Mac's /Library/Audio/Plug-Ins/Components/ directory with it.

     

    Go to System Preferences > Perian and in the drop down box next to Audio Output: choose Multi-Channel Output, ignoring the warning which will be displayed.

     

    Close System Preferences.

     

    This fixed the problem for me in that I can now play my files (H.264 video & AC3 audio in the .mkv container) using QT7 and also export them with the video passed through as is and the audio transcoded to AAC for my Apple TV.

     

    Hope this helps...

  • 13. Re: My AC3 Codec is not working. Help!
    ryandee Level 1 Level 1 (0 points)

    I fixed this same problem on my laptop running Mountain Lion (10.8) by installing the "A52" Codec which appears to include support for AC3.

     

    http://www.macupdate.com/app/mac/21875/a52codec

     

    There are instructions once you load the .dmg (Read Me.rtf)

     

    "Install:

    Copy A52Codec.component into:

    /Library/Audio/Plug-Ins/Components          or          ~/Library/Audio/Plug-Ins/Components

    and copying AC3MovieImport.compontent into:

    /Library/QuickTime                                        or ~/Library/QuickTime

    The A52Preferences application can change the prefs for the codec but is not necessary with version 1.0 or greater of Perian.

    Be sure to remove any instances of AC3Codec in both /Library/QuickTime and ~/Library/QuickTime.  It causes problems and is completely supplanted by this codec.

  • 14. Re: My AC3 Codec is not working. Help!
    Marco9774 Level 1 Level 1 (0 points)

    I have a more recent version from the A52 codec but it doesn't solve the problem

1 2 3 Previous Next