Skip navigation

Import video to Aperture library on Mountain Lion

18889 Views 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman RSS Branched to a new discussion.
  • Gerhard Bergmann Calculating status...

    So it comes to






    google chrome




    that the three of us  have installed.


    But I do have Adobe Photoshop Elements 10.

  • Gerhard Bergmann Level 1 Level 1 (60 points)
    Currently Being Moderated
    Aug 3, 2012 8:00 AM (in response to in2om)

    Bildschirmfoto 2012-08-03 um 16.56.11.png

    Maybe you can also use the "Feedback" within Aperture, and maybe you will also be asked for your System Reports, and maybe they can figure out, what the three of us have in common.


    Lots of "maybe"s....

  • pmack1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 5:15 AM (in response to in2om)

    I have the same problem but I am running Lion 10.7.4. with Aperture 3.3.2  I've discovered my.MOV videos won't play but my MP4 videos will play ok. Both formats played fine before. Also .MOV files display like a photo but don't display video icons(play, stop, etc) in Aperture but they do display a video camera icon in the bottom right of the thumbnail preview. I've also reported this to Aperture support. I reckon we'll just have to wait for an Aperture update.

  • pmack1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 6:42 AM (in response to in2om)

    I've also just noticed Aperture will play newly imported .MOV files. This problem appears to only affect .MOV files imported prior to update. Not sure is this due to Aperture update or Lion update.

  • pmack1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 7:53 AM (in response to in2om)

    I'd like to correct my previous comment:

              #"This problem appears to only affect .MOV files imported prior to update. "#


    I have discovered other .MOV files that were imported prior to update and they play ok.

    As it stands:

    I can play some MP4 videos and some .MOV videos regardless of when they were imported.


    Possible Solution:

    I always save copies of my Aperture Projects in my Pictures folder so I tried re-importing one of the .MOV and .MP4 videos that wasn't working, from my Pictures folder and this worked for me.

    If you are trying to import new videos then try this

    1. Import your video to your desktop?
    2. Click Import in Aperture.
    3. Click on your Macbook Library
    4. Click on Desktop and select your video.

    Not ideal but fingers crossed.

    I also discovered if you drag and drop a video onto the Aperture icon that it saves it in the iPhoto Library even though I have it set to Aperture.

    Good Luck!

  • pmack1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 9:33 AM (in response to in2om)

    Sorry in2om, I see what you mean.

    I think this is most likely an Aperture or Mountain Lion bug.

    However I used this site last year to check that all my apps were fully compatable with Lion. It will give you the status on all apps compatability with Mountain Lion as well.

  • AJL. Calculating status...
    Currently Being Moderated
    Aug 7, 2012 6:16 AM (in response to in2om)

    Dear in2om,


    Thanks for posting - firstly, my issues after a clean install of ML and my favorite apps on my 2011 iMac are:

    1. Unable to import new .MOV files from EOS 5D Mk II
    2. Unable to play previously successfully imported files from the same camera


    I haven't installed iPhoto and tested it.


    I noticed the issue after a message popped up asking me some crap about unsupported files, which I foolishly dismissed a few times before it hit me... I was trashing footage that I now cannot get back ... so I searched and found your post (after updating my import procedures to a more distrustful state...).


    I am not experiencing the same issue on my mid 2009 MacBook Pro after a clean install of ML with less apps, so your thinking about there being a conflict with another app is also my opinion.


    Thus far I have performed the following steps (if I haven't listed a step here, it has not happened):

    1. Install ML from recovery partition on 2TB drive after clean format - Mac OS Extended (Journaled)
    2. Install Aperture from App Store
    3. Restore Aperture Library in question
    4. Test video playback (success)
    5. Test import (success)
    6. Previously imported videos generated their thumbs


    So, a clean install of ML and Aperture fixed the issue. I'll post again when I find the app that breaks it for me (it's been a long night)...




  • AJL. Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 8, 2012 1:41 AM (in response to in2om)

    I have installed and run a host of applications and have not been able to break Aperture again.

    The only apps I haven't tested from other posts are Chrome, AppCleaner and PS Elements.


    I have resolved the issue for myself following the steps in my earlier post.

    I will be sure to post the cause back if it breaks again but for now I'm sorted.


    Note - this was a clean build - no import tools were used and all prefs were set up again from scratch.


    Time for a fresh start .




  • TheWrongStuff Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 8, 2012 1:45 AM (in response to AJL.)

    Have exactly the same problem. Can't import any videos. AVCHD videos that worked previously can no longer be imported. They don't even show in the import screen anymore.

1 2 3 4 ... 7 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.