Skip navigation

Serious issues with the Automatic MTU size (1500) with Mountain Lion 10.8

5983 Views 4 Replies Latest reply: Jan 17, 2013 9:51 PM by Etra2 RSS
@reumerd Calculating status...
Currently Being Moderated
Aug 4, 2012 1:56 AM

Many users are suffering the same issue currently with OSX 10.8 Mountain Lion, where it seems there has been a change in the network stack that leads to problems when leaving the MTU size to standard.

 

It mainly leads to issues where the remote websites are using HTTPS, resulting in unpredictable behaviour.

 

At first it looks like either a DNS or a Firewall/Router issue, but the core of the issues is some packets are dropped on the Network stack on the computer itself.

 

While most of us use WiFi, it also applies to ethernet connections.

 

Symptoms:

Unable to access certain https sites, unable to login to https protected sites.

 

It might not be restricted to HTTPS only, but at this point in time I've only seen it happen with HTTPS sessions, not with any other (SSL) encrypted sessions (e.g. news with SSL, SSH, etc).

 

It's only in combination with external sites as far as I can see, so it might be related to the NAT translation happening on the Firewall/Routers. normally the network stack should auto adjust the package load to compensate, hence it seems the problem is related to the automatic network discovery of Mountain Lion, not compensating for the NAT translations on the ROuters/ firewalls.

 

It also only seems an issue when receiving on the system itself, sending seem ok and there are no dropped packages on the firewall/router.

 

I hope we can soon receive an fix for this because forcing a lower MTU size, also disable local link Jumbo frames and less optimized network speeds.

 

People or dropping their MTU package size to 1300, which should bot be required as this is extremely low.

 

I would recommend testing out what works for yourself and set it as close to 1500 as possible in your setting.

 

Depending on your internet connectivity PPoE (ADSL, VDSL use this mostly and some fiber), PPP (cable, ADSL, VDSL, Fiber)  and or straight ethernet (Fiber)

 

In my case I have a straight ethernet connection with NAT -> I have to take out 4 bytes for the NAT translation of the IP address -> 1496 works fine.

In case of PPPoE try starting with 8+4 -> 1488 MTU size.

For PPP try starting with 6+4 -> 1490 MTU size.

 

try lowering it with 2 bytes each step untill you can access your problemetic site again.

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion, Clean upgrade.
  • Mason Mark Level 1 Level 1 (0 points)

    I definitely saw this problem at work. None of the Macs could reliably access the Internet after upgrading to 10.8.

     

    Troubleshooting the issue, I found a reproducible case (trying to log into Amazon Japan failed with a timeout), and then found that the fix was to reduce the MTU to 1453. (That value found through trial and error; this office has a 100Mbps fiber optic line, connected via PPPoE.)

     

    We had to modify the MTU in the Hardware tab for every type of network interface: Wi-Fi, Ethernet, USB Ethernet, Thunderbolt Ethernet.

  • RickJ3 Calculating status...

    I too had the same problem and needed to lower my

    • MTU to 1454 and left my router set for 1492 with Ppoe with ATT DSL as 1492 is thier default settings.
    • Once the MTU was set to 1454 everthing worked fine.  Htpps was the most sensitive and would not conntect the port unless the imac computer was set to 1454 in advnced setting of the network protocol.  . 
  • Zacharias Beckman Level 1 Level 1 (100 points)

    So I'm giving the MTU fix a try, but thought I'd add this for anyone that's interest (in case the MTU fix doesn't work for you):

     

    Yes, same problem here. It is a widely experienced problem by a host of users that upgraded to 10.8 (it's unclear if it started with 10.8 or 10.8.2). E.g.: MacRumors has a long discussion on this, and it's just one of the many sites with many complaining users: http://forums.macrumors.com/showthread.php?t=1451152

     

    Here's what I've figured out so far, and this is after living with the problem (and trying to fix it now) for many weeks, and perusing many online resources:

    1. The problem in question (that I'm discussing) is one where your Mac network connection completely hangs. Attempts to open a web browser, for instance, hang for about a minute, and then you get the "cannot find the web site" page. Likewise, any network access (ssh, telnet, email, ping) are all completely blocked, as if you had no network at all -- and yet, at the same time, you've got 5 bars on your wifi status and a solid connection to the router. Network status in your settings all looks fine.
      1. The most common fix at this point is to either 1) turn off wifi and restart it, which almost always works, or 2) go ahead and restart the router, which annoys the heck out of everyone else in the office but also works fine.
    2. The problem is probably related to an update to the 10.8.2 network stack. Ignore anyone that says something like "reset your router," this is not the issue. This can be verified easily enough: Are any other devices on the router impacted? No? Then the router is fine (here we have about a dozen computers, iPads, and an AppleTV, and a VOIP phone system on the router -- they all keep working fine, it is only the MacBooks that were updated to 10.8.2 that exhibit the problem.
    3. The problem is apparently specific to the 802.11 'n' protocol. We successfully reconfigured our router so that it supports two different networks, one 802.11g "Boss Logic" and one 802.11n "Boss Logic 5Ghz." In other words, we switched it up so that you can use a 'g' network ("Boss Logic") or an 'n' network ("Boss Logic 5Ghz"). All the PC users are happily using the higher speed 5Ghz network -- and all the Mac users are now, unhappily, using the older 'g' network. If your router supports this (having a dual configuration, such as the Apple Airport routers do) then it's a great fix... at some performance cost. We've done this here, and yes, it did absolutely work, no hangs since switching over.
    4. I have read elsewhere that you might be able to continue using the 'n' network, if you change your MTU size to a non-1500 settings. I'm giving this a shot and will see how it goes. (Just go into settings and change your wireless network 'hardware' tab to use an MTU of, say, 1495). Good luck if you try this.

     

    Hope this helps and let's all cross our fingers and hope Apple starts paying attention. It seems like it's been an eternity... but it's probably only been a month or two. But hey getting booted off the network a few times a day can be a really, really annoying experience.

  • Etra2 Level 1 Level 1 (0 points)

    MTU 1495 worked for me too, just in network settings (no router adjustment).  Dual internet was connecting, then disconnecting constantly.  Thanks, wasted sometime before finding this.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.