Skip navigation

iMessage stuck waiting for activation...

54361 Views 20 Replies Latest reply: Feb 5, 2014 10:47 AM by Tillybug101 RSS
  • Tony Gilmore Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 22, 2012 7:36 PM (in response to daddyvenom)

    Apple servers were down. It should be working again.

  • claudettevargas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 4:56 PM (in response to daddyvenom)

    I think I may have a solution for your prob, it just happened to me yesterday at 11pm and I kept on reading and reading and trying but nothing. Then I starting watching videos on youtube. And I finally fixed my problem at 3:00am haha.

     

    Here's a possible solution for you.

     

    Settings > Wi-Fi (select your current wi-fi connection and press the blue circle with the arrows > Go down to where it says DNS and press it, delete the current number and put this:  8.8.8.8, 8.8.8, 4, 4

     

    Don't try on waiting with iMessage or Face Time it'll still will say "waiting for activation" but try on sending a message. It'll work, it work for me.

     

    As soon as a put those numbers my Push Notifications started working so good and so fast.

     

     

    Hope this helps!

  • NFH. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 5, 2012 12:03 AM (in response to claudettevargas)

    claudettevargas wrote:

     

    Here's a possible solution for you.

     

    Settings > Wi-Fi (select your current wi-fi connection and press the blue circle with the arrows > Go down to where it says DNS and press it, delete the current number and put this:  8.8.8.8, 8.8.8, 4, 4

    This is exactly the solution I had already posted above together with an explanation of why it works. I'm glad it worked for you too.

  • smat9073 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 4:36 PM (in response to daddyvenom)

    I was having this same problem.  Using the DNS codes may work for some, but I tried something else and it worked the first time.  I went into Settings -> Messages -> Send and Receive -> Apple ID -> Log Out.  Then I started over with turning iMessage on, logged in again, and everything was working perfectly.  Hope this helps. 

  • ahaavaa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 16, 2013 7:17 AM (in response to claudettevargas)

    THANK YOU SO MUCH! IT WORKED!

  • Tillybug101 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2014 10:47 AM (in response to daddyvenom)

    Had this problem with my new iphone 4s that came today was told by another site to make sure the time and date was set to auto update and hey presto it fixed the problem, facetime and imessage now working x

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.