Skip navigation

"Software for this printer is currently unavailable" Canon MP640

647 Views 3 Replies Latest reply: Sep 23, 2012 6:47 PM by i814u2 RSS
MrMic Calculating status...
Currently Being Moderated
Aug 5, 2012 12:47 AM

After doing the latest update (10.7.4) my printer (Canon MP640) has dropped out and all attempts to reinstall it are failing.

I have an iMac Mid-2007 running Lion

 

I have installed the latest drivers (PrinterDriver_MP640 series_106701.pkg) and uninstalled and reinstalled again.

Right clicked and done the 'Reset Printing System' option.

Done a CMD-OPT-P-R reset.

 

The printer is showing up in the (+) printer menu but regardless of what I try I get the "Software for this printer is currently unavailable" warning.

"Select printer software..." shows up blank.

And "Other..." doesn't let me choose anything from the installed printer settings.

 

Software Update also recognises the MP640 but when I choose to install it gives the same "Software for this printer is currently unavailble" message.

 

I have also tried this on my Macbook Pro 2010 which is running Mountain Lion and tried all the same things but still no joy.

 

Running out of ideas here anybody able to help?

iMac, Mac OS X (10.7.4), Canon MP640 - Software printer prob
  • Rudegar Level 6 Level 6 (18,435 points)

    I would give it a final try on a windows pc to verify that there is something wrong with the printer

  • i814u2 Calculating status...

    I have this same issue. All of the "fixes" I read (which apparently work for others) do not work for me.

    I've tried installing items from canon's site, I can setup the printer via canon's utilities, I can hit it's web service with my browser, I can print alignment test pages, but it will not add as a wireless printer.

     

    Mine also shows in the list, and claims that software is available direct from Apple. But when it goes to get that software, every attempt fails to find anything to download.

     

    Other other fixes I've found mention verifying settings within the printer (for name and service broadcast options). I verified those settings and had turned it all on as needed. That ensured that it was showing up in the list, but it will not download the drivers. When I choose the option to pick a driver from a list, I see a blank box without any options.

     

    I looked through Apple's lists, thinking that maybe it was no longer supported. However, it is listed as supported for Lion (for printing and scanning, though it doesn't mention anything about wired vs wireless. Just that it should have a driver to download).

     

    Printing via USB works fine, as do test pages (wirelessly) so the printer is fine. Since the message claims that Apple's sites have the needed software, I'm posting my info here, hoping someone has an answer to how to get the printer added via wireless, so that it can be used.

     

    Thanks

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.