Skip navigation

Cannot download App / Song

259 Views 5 Replies Latest reply: Aug 5, 2012 1:58 PM by joshakjohn RSS
joshakjohn Calculating status...
Currently Being Moderated
Aug 2, 2012 9:25 AM

I just flew out to Gran Canaria on Monday and yesterday I tried updating my apps over the hotels wifi without success. It seems to download but as it gets to the end it stops and says that it cannot be downloaded at this time. Today now I just purchased a song and it also failed to download. Im from the UK and believe I´m still in the UK store as I´m still logged in with my iTunes account and its showing prices in Pounds Sterling.

 

Any ideas why it won´t let me download anything?

iPad 2, iOS 5.1.1
  • Demo Level 9 Level 9 (73,760 points)
    Currently Being Moderated
    Aug 2, 2012 9:31 AM (in response to joshakjohn)

    There are some issues being reported with the app store today ... Mainly not being able to see purchased apps - they seem to have disappeared from users screens. I can't say that this is what is wrong in your case .. Also another user in the UK stated that he had problems getting his password to be accepted but signed out and then signed in again and it worked.

     

    Having said all of that, this is my boilerplate of things to try if you can't download or update apps.

     

    Make sure that you do not have a stalled download in iTunes - a song or podcast .... if you have a download in there that did not finish, complete that one first. Only one thing can download at a time on the iPad so that could be what is causing the problem.

     

    If that doesn't work - sign out of your account, restart the iPad and then sign in again.

     

    Settings>Store>Apple ID. Tap your ID and sign out. Restart the iPad by holding down on the sleep button until the red slider appears and then slide to shut off. To power up hold the sleep button until the Apple logo appears and let go of the button.

     

    Go back to Settings>Store>Sign in and then try to update again. Tap one waiting icon only if necessary to start the download stream.

     

    You can also try deleting the waiting icons - tap and hold down on an icon until it wiggles - the tap the X on the icon to delete it. Then try to download again.

     

    You can try resetting all settings. Settings>General>Reset>Reset All Settings. You will have to enter all of your app preferences and device settings again.

  • Demo Level 9 Level 9 (73,760 points)
    Currently Being Moderated
    Aug 2, 2012 1:44 PM (in response to joshakjohn)

    joshakjohn wrote:

     

    Tried the reset which didn´t work and then the Reset all settings. When I did reset all settings though it asked if I wanted to Set up as a new iPad which I assumed only effected the settings however it removed everything and now none of my music or apps will download so stuck with an iPad that has no games, movies or music for a week.

    This should NOT have happened. Resetting you settings - if done properly - only resets the device settings back to defaults. I think you accidentally clicked on Erase all content and settings which is directly under Reset all settings.

     

    I have seen a few people still posting about app store issues. I can download apps and update apps. I just can't see the purchased apps in the purchased tab of the app store.

     

    Did you try signing out of your account and then sign in again? What is the iPad doing now when you try to download .... Any error messages?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.