1 2 3 Previous Next 37 Replies Latest reply: Aug 6, 2012 10:16 AM by David Sloan1 Go to original post
  • 30. Re: Upgrading problem iphoto vers 9.3
    David Sloan1 Level 1 Level 1 (0 points)

    Not sure if I should post here but here goes.  Upgraded to 9.3. on my wife's new imac.  Yes it wanted to upgrade the library but in my case it worked ok.  (About11k pics).  Only problem found so far is as follows:

     

    opening several photos in edit mode to compare them. I have, say, 2 or 3 photos open. cmd click another and it should add to the group displayed. Up to 4 do but......  selecting a pic to open from the strip at the bottom only shows a small batch of pics.  the grey dash used to pull the strip along is not there.  I can get it to show sometimes - it appears that if I cmd click a 5th pic the dash pops up briefly and sometimes I can grab it if I'm quick!  Incidently 9.2.3 lets me open 8 pics to compare in edit.

     

    I still have 9.2.3 on my macBook Pro so I shall stay there meantime. Fortunately I had just copied the entire iphoto library across so I have an identical copy there as time machine and other back ups on externals.

     

    PS If I go to time machine back ups can I roll back the application (to 9.2.3) or just the library?

  • 31. Re: Upgrading problem iphoto vers 9.3
    Old Toad Level 10 Level 10 (115,690 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If the new library works as expected then it's your current library that's the culprit.

     

    If that is the case make a temporary, backup copy (select the library and type Command+D) and  apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Since only one option can be run at a time start with Option #1, followed by #3 and then #4.

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

     

    IF the problem persists with the new library then a reinstall of iPhoto seems indicated.  To do so you'll have to delete the current application and all files with "iPhoto" in the file name with either a .PKG or .BOM extension that reside in the HD/Library/Receipts folder and from the /var/db/receipts/  folder,

     

    Click to view full size

    Then install iPhoto from the disk it came on originally and apply any needed updaters.

     

     

     

     

    OT

  • 32. Re: Upgrading problem iphoto vers 9.3
    David Sloan1 Level 1 Level 1 (0 points)

    Old Mr Toad - you are always to be relied upon!  Thank you.

     

    I am out tonight (babysitting grandkids!) but will try your suggestions tomorrow.  Compared to other people my problem seems very minor but hopefully your ideas might sort it.  I don't see why it should be the library as the exact copy of the library is working fine on my MacBook Pro with 9.2.3 - unless the upgrade has affected it.  If it is not the library I shall not rush to completely reintall iPhoto until I see if anything else develops.   Seems others are having a much worse experience with 9.3!   Perhaps another upgrade from Apple soon!

    Thanks again

  • 33. Re: Upgrading problem iphoto vers 9.3
    Old Toad Level 10 Level 10 (115,690 points)

    It could be a combination of the 9.3-your account and the library.  If you get a chance copy the library to another account on the iMac and see if it will open there.  If it does'nt then it appears it's the application.

     

    However, if the library opens in the other account we're looking at your account as the problem. In that case the first thing to try is  make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home()/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home()/Library/Caches/com.apple.iPhoto folder. 

     

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    If that does'nt help the problem it could be another preference file(s), other than iPhoto's, that's causing the issue.  There is a way to determine if that's the case:

     

    Trouble Shooting Preferences

     

    1 - close all applications. 

    2 - open your Library folder, Home/Library, and drag the Preferences folder to the Desktop. A new Preference folder will be immediately created in the Library.

    NOTE: if dragging the Preference folder to the desktop only copies the folder then after the copy has been completed go back and drag the contents of the Preferences folder from the Library to the Trash in the dock. You will be asked to enter your Admin password. Then reboot and try again.

    3 - run the application again and determine if the problems is fixed. 

    4 - If the problem is fixed:

     

    A - open the working Preferences folder (HD/Users/your_name/Library/Preferences).

    B - Open the Preferences  folder on the Desktop, select all of the contents and drag them into the working Preferences folder.

    C - When the Copy window pops up check the "Apply to All" check box and then click on the Don't Replace or Skip button.

     

     

    5 - If the problem is NOT fixed, drag the contents of the Preference folder on the Desktop into the Preference of the Library folder are  replace the new one that was created by clicking on Replace.

  • 34. Re: Upgrading problem iphoto vers 9.3
    Koh Yin Level 1 Level 1 (0 points)

    Old Toad,

     

    You are the best!

     

    Your advice of using the library manager helped me to pin point the issue of my iPhoto library.

    When I tried to use the library manager, I found out that there is no library data file in my libray package.

    I assume when the new upgrade failed, the file went missing.

    So, I tried to use the "repair database" again. Originally, it kept failing and I gave up. But I kept trying this time. It failed on the first two tries to repair the database, but for the third try, the miracle happened and it repaired the database and I got back my original photo libaray working. I wonder if "repair database" worked this time because I renewed my preference files.

     

    Then, the second issue that was experienced by others came up. iPhoto kept trying to upgrade over and over.

    So, I tried your advice to remove the two files from the Library/Preferences folder. It worked!

    Now my iPhoto library is working

     

    Your help is very detailed and very helpful.

    Your advices are very compassionate and methodical.

    Apple should pay you for helping us.

    MANY THANKS!

     

    KY

  • 35. Re: Upgrading problem iphoto vers 9.3
    sandman21 Level 1 Level 1 (0 points)

    THank you Old Toad. Saved my hide. My wife would have killed me if I couldn't recover the Iphoto libarary.

     

    Dear Apple - you are better than this! Why release buggy code? Read you user boards - fix your products!

  • 36. Re: Upgrading problem iphoto vers 9.3
    Old Toad Level 10 Level 10 (115,690 points)

    Perseverance pays off. 

  • 37. Re: Upgrading problem iphoto vers 9.3
    David Sloan1 Level 1 Level 1 (0 points)

    Re my original posts 30 June.  Been away a lot. I am living with the minor problem I found and I have not tried Old Toad's very helpful advice yet.  A bit busy but I shall get round to it sometime and respond accordingly.

1 2 3 Previous Next