Skip navigation

Mountain lion server keep changing host name

11509 Views 33 Replies Latest reply: Oct 9, 2012 3:48 PM by Ryan Burkholder RSS
  • ablyes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 5, 2012 11:26 PM (in response to Tho615)

    I don't have an open directory !!

    How can i do ?

  • Eric. Level 6 Level 6 (12,260 points)
    Currently Being Moderated
    Aug 6, 2012 2:12 AM (in response to Tho615)

    I've had the problem from the start; after nearly every boot (max. 3) I get the alert that the hostname was changed from servername to servername.domain.com. No matter how many time I run through "update" or try to redo the Server.app Network settings (even though I'm not really changing anything), I still get the alert.

     

    I did a clean install (I wiped the HD) of Mountain Lion + Server. After adding Server.app, I followed through setting that up correctly the first time:

    - computer name: servername

    - hostname: servername.domain.com

    - IP address: I have decated IP address, and the Mini connects manually my Time Capsule.

    The domain is my registered domain, of the form "domain.com". I'm not using .private or .local.

    DNS got setup automatically and correctly; I can connect to Profile Manager from clients and bind to OD.

     

    Using Cteam's notes, I verified that these checkout:

    nslookup <server's IP address>

    nslookup servername.domain.com

    This one didn't until I added my domain to the search domain.

    nslookup servername

     

    Checking the system.log, I can see that configd is setting the hostname at boot.

    8/6/12 10:40:25.543 AM configd[21]: setting hostname to "servername.domain.com"

    I suspect that's what's generating the errors; for whenever I don't see that entry, I don't get an alert. The problem it seems is getting that FQDN to stick as the hostname. I haven't been successful.

     

    Here's a list of what I've tried, none with success:

     

    I've tried:

    sudo scutil --set HostName servername.domain.com

    as well as

    sudo changeip - IPaddress IPaddress servername.local servername.domain.com

    sudo changeip - IPaddress IPaddress servername.domain.com servername.domain.com

     

    I've also tried turning off the DNS, trashing the settings; and then running through Server.app Network again, which redoes the DNS. nslookup checks out, as does OD binding and profile manager from clients. I see the alerts after 1-3 reboots.

     

    I've even tried the radical method, of turning off the DNS and trashing the settings. Then deleting:

    /Library/Preferences/System Configuration/preferences.plist

    which as far as I can tell is the 'master' network config file. Trash that and you lose all Network interfaces, computer name, hostname, IP, etc. After trashing that I had to go into System Preferences: Network to create a new location, which generated new network protocals, particularly ethernet. Then did the Server.app: Network to set once again, computername and hostname, which again redid my DNS settings.

    2-3 reboots later I'm still seeing the alert and I see configd doing it's thing at startup.

  • Gary Finch Calculating status...
    Currently Being Moderated
    Aug 6, 2012 2:57 AM (in response to Eric.)

    Me too. I have done the same. Remade the OD master and everything. I still get the hostname change issue.

  • tcpudp Calculating status...
    Currently Being Moderated
    Aug 6, 2012 1:36 PM (in response to Gary Finch)

    I did many fresh installs,  the moment this alert start to occur in my setup is straight after installing Server app when I modify DNS zone records. So it should has nothing to do with directory or anything else that are turned off at that point.

     

    I feel this has something to do with the way bonjour works after a server's changes to .private (which I use) or a public domain. Probably a bug. I also have experienced very slow handshakes for AFP/screen sharing connections using the side bar of Finder (again bonjour here is a bit wried), but connect using CMD+K with fqdn works fluently.

  • tcpudp Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 6, 2012 2:20 PM (in response to Tho615)

    Submitted a bug report 12041267 for now.

  • rcsmac Calculating status...
    Currently Being Moderated
    Aug 7, 2012 3:42 PM (in response to tcpudp)

    After installing Parallels Desktop 7 in my server, this problem started to happen.

     

    The only programs I've installed on my ML Server are Plex Media Server and Parallels Desktop 7.

  • tcpudp Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 8, 2012 12:14 PM (in response to tcpudp)

    It's already being worked on. Let's hope it'll be in the next update.

     

    tcpudp wrote:

     

     

    This is a follow up to Bug ID# 12041267. This bug has been closed as a Duplicate. The issue is being tracked under the original Bug ID# 11922353 which is also listed in the Related Problem section of your bug report. To check the status of the original bug report, please visit the Related Problem section of the Problem Detail view of your closed duplicate bug.

     

    Submitted a bug report 12041267 for now.

  • pjp_1976 Calculating status...
    Currently Being Moderated
    Aug 21, 2012 1:50 PM (in response to Tho615)

    I think I actually found a solution ... yes it does not fix the bug, however it gets rid of the oh so annoying "red badge" appearing on the Server App icon in the dock and the push notifications appearing in Message center.

     

    Solution:

     

    1) Open Server App

    2) Click on Alarms

    3) Click on the Delivery tab

    4) Uncheck the two boxes next to "Network Configuration Change"

    5) Close Server App

    6) Try a reboot ... the nagging "cosmetic" bug should be gone now

     

    Enjoy ....

  • Engender Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 12, 2012 7:08 PM (in response to pjp_1976)

    I just did a fresh re-install of OS X Server, and I'm getting this error again - BUT I think I might know the cause! When I was setting the server up a few minutes ago, I entered server.<mydomain>.com as the host name, leaving the already filled "server" as the local host name.

     

    I think the key may be to change the local host name to match the host name!

     

    Anyone know how to change the local host name?

  • Engender Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 12, 2012 9:28 PM (in response to Engender)

    Nevermind, this didn't work. Changing your local host name is very simple through System Preferences, but does not allow for names in the "XXXX.XXXX.com" format.

  • Stefan R Calculating status...
    Currently Being Moderated
    Sep 16, 2012 7:45 AM (in response to tcpudp)

    I believe Server.app wrongly is checking LocalHostname against Hostname to find out if Hostname has changed. Programmatical error i presume.

  • c2ric Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 16, 2012 9:54 AM (in response to Tho615)

    Hello it's appear that i have this message alert too, when i reboot my router with or with out ipv6 and try with nativ or tunneling options.I'm ok with that and know what I do.so nevermind the alert.

    Considering that, see your pref system pannel and go to network,

    perrhups are you on dhcp? turn it off and stay with a ip fix...

  • elgringito Calculating status...
    Currently Being Moderated
    Oct 3, 2012 8:09 AM (in response to Tho615)

    Count me in. I have this problem too and am unable to solve it.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.