Skip navigation

aperture3 keeps asking for serial number

3054 Views 11 Replies Latest reply: Jul 1, 2013 4:14 AM by trevor.7 RSS
elucaswilliams Calculating status...
Currently Being Moderated
Jul 7, 2012 3:58 AM

i installed a new hard drive and brought aperture 3 out of the time machine to the new drive. I had to get a new serial number from apple because i deleted the old one. I received it but evertime i open the app it asks for it again. its kind of frustrating and i would like to remedy this problem. Thanks,



MacBook Pro, Mac OS X (10.7.4)
  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jul 7, 2012 4:31 AM (in response to elucaswilliams)

    You may have an outdated file " /Library/Application Support/ProApps/ProAppsSystemID" in your System Library.


    1. Quit Aperture.
    2. Go to your MacintoshHD and open the folder "Library", then "Application Support", then "ProApps".
    3. Remove the File "ProAppsSystemID" to the Desktop, if it exist and restart Aperture.


    Reenter your serial number, hopefully for the last time.




  • Syncopator Level 1 Level 1 (115 points)
    Currently Being Moderated
    Aug 1, 2012 11:51 PM (in response to léonie)

    i'm not sure if this is a change in mountain lion (os x 10.8), but i'm having the same problem with aperture -- except the ProApps folder you've mentioned contains no such file as "ProAppsSystemID." it contains only one folder, called "Internal Plug-ins," which contains other miscellaneous folders and files.


    any additional ideas?  :-)

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Aug 2, 2012 12:32 AM (in response to Syncopator)

    You may have a permissions problem with your system drive. Open Disk Utility and check the permissions; if Disk Utility reports a problem use the "Repair" button to repair the permissions.


    Then try again.


    Perhaps the Caches contain a corrupted file. Try to remove


    from your user library.


    Occasionally Aperture writes the "ProAppsSystemID" to the temporary directory $TMPDIR.


    Open a Terminal window and enter

         open /tmp

    This will open a Finder window in this folder. Browse it and look for this file, but do not change anything else.


    If you see the "ProAppsSystemID" quit Aperture and move this file to its proper location.

    Log off and on again, and try again.




  • Syncopator Level 1 Level 1 (115 points)
    Currently Being Moderated
    Aug 2, 2012 1:12 AM (in response to léonie)

    success, i believe! thanks for your detailed reply! my results, but the benefit of others:


    1. i repaired permissions, but the ProAppsSystemID did not appear.


    2. i removed the caches, but the file still did not appear (though it was unclear if i should have relaunched aperture at that point).


    3. ProAppsSystemID did not exist in the temporary directory.



    at this point i decided to just do a search for the file. (of course i had to enable the inclusion system files in the finder search window.) oddly, the finder *appeared* to find *3* copies of ProAppsSystemID, but i could not determine the location of either of the 3 files. it was as if they were "ghost" files; they appeared in the search window, but not even Get Info would display any info on them.


    then, with the search window still open, i decided to launch aperture -- and then, suddenly the ProAppsSystemID file appeared -- in the temp directory! i then quit aperture, then moved ProAppsSystemID to the ProApps folder.


    it now appears the problem has been fixed.


    i say "appears" because in the past i've sometimes been able to launch aperture a couple of times without being asked for the SN, only to be asked, the next time i launched the app (which may have been the next day). i've now launched and quit it 4 or 5 times, and so far, so good.



  • steveaburns Calculating status...
    Currently Being Moderated
    Aug 6, 2012 8:24 PM (in response to Syncopator)

    Great - this is working for me.  I'm assuming when you reboot, /tmp is cleared, hence the solution only lasting a few times if you don't move the file from /tmp to /Library/Application Support/ProApps

  • alexis23bledel Calculating status...
    Currently Being Moderated
    Aug 22, 2012 7:40 PM (in response to léonie)

    Hey, thanks man.


    I got the same issue after upgrading to ML from Lion and accidentally choosing another username (which I shouldn't do) when asked by ML while installing. Kinda' ****** me off. Lots of my apps are (basically) 'incorrectly installed' because I input different username on it, including Aperture.


    But your method works for me now.


    Thank you

  • Brotha J Calculating status...
    Currently Being Moderated
    Aug 23, 2012 5:58 PM (in response to Syncopator)

    Thank you. This worked like a charm. Very clear explanaiton

  • incendiaryfilm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2012 8:26 AM (in response to léonie)

    Removing the current ProAppsSystemID file from the ProApps folder and replacing it with the one in the /tmp directory did the trick for me.  THANK YOU!

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Nov 3, 2012 9:38 AM (in response to incendiaryfilm)

    You are welcome!

  • btoole Calculating status...
    Currently Being Moderated
    Jan 15, 2013 7:33 AM (in response to léonie)

    Just worked for me too with the supposedly fixed latest version of aperture. THANK YOU SO MUCH !

  • trevor.7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 4:14 AM (in response to incendiaryfilm)

    File only appeared with Aperture open but then it all worked as suggested by moving file from /tmp


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.