Skip navigation

Migration Assistant can't find my hard drive - can you help?

47484 Views 54 Replies Latest reply: Jun 5, 2013 8:22 AM by Pondini RSS
1 2 3 4 Previous Next
duncanos Calculating status...
Currently Being Moderated
May 22, 2012 1:46 PM

Hi, I've just bought a new MacBook Pro (Lion) as my 6 year old iMac (Snow Leopard) has died. I wanted to restore my data from my iMac, via my Time Machine back-ups which are stored on a WD MyPassport. When using the migration assistant, I've followed the instructions, but the assistant refuses to see the hard drive and all I get is "Looking for Other Computers" and a spinning wheel. I've done this before when a hard drive went south and it worked really well, but this is not good at all.

 

Any advice gratefully received. Thanks.

MacBook Pro, Mac OS X (10.7.3)
  • Pondini Level 8 Level 8 (38,710 points)

    Did you select From a Time Machine backup or other disk instead of From Another Mac or PC?

     

    Does anything show up in the Select Your System window?  

     

    If not, try Repairing the backups, per #6 in Using Disk Utility.

  • Pondini Level 8 Level 8 (38,710 points)

    duncanos wrote:

    . . .

    And instead of getting to select the hard drive (a WD MyPassport) I just get the spinning grey wheel, nothing shows up in the Select Your System window. Aside from this the external drive is recognised by the Mac thorugh Finder, I can see and access the backups, but there's no clear way of getting Migration Assistant to see it.

    A few folks claim that their drive was seen, but not displayed on that screen.  They just clicked the Continue button and it worked.

     

    I doubt that; I think they saw their backups, but didn't realize it -- Migration Assistant shows the name of the computer and disk that were backed-up, not the disk the backups are on, so some thought they were looking at their internal HDs, not their backups.  But it's certainly worth a try!

     

    Did you try repairing the backups per #6 in Using Disk Utility? If there's a problem with them, Migration Assistant may not show them, but the drive will still show up in the Finder.

     


    It's usually better to use Setup Assistant rather than Migration Assistant, or you'll end up with an extra user account, and the transferred accounts may lose permission to the older backups.  See Problems after using Migration Assistant for an explanation and some workarounds.

  • Courcoul Level 6 Level 6 (11,150 points)

    Also worth trying is gutting the old Mac, getting the hard drive out and putting it in a Firewire or USB enclosure. Plug it in and see if MA or SA sees it. Often the hardware such as the logic board may be damaged but the drive stll salvageable and can be used to pull the data from it. Happened to me las Dec., when my previous MBP died it its sleep.

  • Pondini Level 8 Level 8 (38,710 points)

    That's very strange. 

     

    It's a very long shot, but try connecting the drive to different ports (directly - no hubs or daisy-chaining), and don't connect anything else to USB if at all possible.  Also try a different cable and/or swap ends. 

     

    Can you see the backups via the Browse Other Backup Disks option, per Time Machine - Frequently Asked Question #17?   If so, then as a last resort, you should be able to restore selected files & folders to an alternate location, per #16 in the FAQ.

     

    You may, however, have a problem with permission to the backups.  If so, you'll have to create and delete some user accounts to get user accounts with the same UIDs as the backups.  See the pink box in Problems after using Migration Assistant for an explanation.  Post back if you need help doing it this way -- it's more than a little weird.

  • EvanG123 Calculating status...

    I'm experiencing almost the exact same problem. I just recieved my new RMBP and I am trying to use the Setup Assistant to restore from my TM drive (Maxtor 1TB, USB connection) where my current 2008 MBP Core 2 Duo (Lion) is currently backed up. After selecting "from another disk" in the "Transfer Informaiton to This Mac" screen, I too only see the spinning grey wheel on the next screen and the Setup Assistant never locates the connected drive. The "continue" button is greyed out and is not clickable. The strange part is that when I disconnect the TM drive from the new RMBP, I still get the warning message about properly ejecting the drive - so clearly the machine knows the drive is there. I would really like to complete this process via the Setup Assistant to avoid any problems with multiple user accounts. Per the earlier recommendations in this thread, I am currently in the process of repairing the TM drive and will try again when that process has completed and report back. Any informaiton on this problem would be greatly appreciated - it is very frustrating to have this shiny new paperweight.

  • EvanG123 Level 1 Level 1 (0 points)

    Successfully repaird the TM drive but the MBP-R still does not see it.

  • johnedale Calculating status...

    I stumbled into the answer to this one.  Mount your hard drive on your desktop and open it up.  Then click on the "username.backup."  That should mount a separate hard drive on your desktop.  Migration assistant should now be able to see it.


    Hope this helps!

  • John Brandt Calculating status...

    Was there ever a resolution to this issue? If so could you please post the details. Thanks in advance.

     

    I am having a very similar issue. I have an older MB PPC running 10.4.11. I have been using SuperDuper to create bootable backups on an USB external drive (formatted to HFS+). Both the MB and the drive work as start up disks and all is in synch.

     

    I purchased an now MBP and am upgrading from 10.7 to 10.8. Using Pondini's guides (thanks, http://pondini.org/OSX/Setup.html) I have tried the following methods but Setup Assistant never sees the source drive:

     

    1. Connect USB with SuperDuper backup to MBP => Setup Assistant doesn't see it (selecting as a disk)

    2. Start MB in Target Disk mode via Firewire connected to MBP => SA doesn't see it (selecting as disk)

    3. Start MB in regular mode, launch Migration assistant and select to another Mac, MBP select from another Mac.... Never saw the disk and suggested I needed to update Migration Assistant. Reran Software Update and confirmed on latest. No luck.

     

    NOTE: I had originally setup up the new MBP with an account and did NOT do Setup Assistant to migrate data. Ran into the same problems when running Migration Assistant not seeing the disks in the three modes above. Followed Pondini's advice and did a clean reinstall of Mtn Lion => booted from a USB boot thumbdrive, erased the main drive with Disk Utility, booted off the install thumbdrive with no issues until the disk recognition problems again)

     

    Is the main issue that I am trying to migrate from too old of an OS X version (e.g. 10.4.11)? I can't find any specifications that say this is not allowed but I can't get it too work. Any help and additional suggestions very much appreciated. I have a family member anxios to get their new machine.....

  • Pondini Level 8 Level 8 (38,710 points)

    John Brandt wrote:

    . . .

    Setup Assistant never sees the source drive:

    Does it show anything at all?  The disk should have a yellow icon.

     

    Is the main issue that I am trying to migrate from too old of an OS X version (e.g. 10.4.11)?

    I don't think so.  I don't have a Mac running Tiger, so couldn't test it, but many folks have done it without a problem.  

     

    Have you run Verify Disk or Repair Disk on the old Mac and/or the backups?  If there's a directory problem, it may boot the old Mac, but the new one may not recognize it.

     

    If all else fails, you may have to do it manually.  Try starting the new Mac normally, logging on as a normal (Admin) user, connect the clone to it, and see if it appears.  If so, you should be able to manually copy from the backups via drag & drop. 

     

    If so, you'll have to be careful of two things:

     

    User accounts:  If the old Mac only has a single account, the first account you set up on the new one should have permission to copy from the backups.  If not, either set up a second account on the new Mac and try it, or use Get Info on the backups to grant the user account on the new Mac permission to read the data on the backups. 

     

    Special files/folders like Mail and Address Book / Contacts.  You can't just copy the files since the structure has changed, but you may be able to import the old mailboxes via File > Import Mailboxes from the Mail menu on the new Mac.  Similarly, you may be able to use File > Import in Contacts on the new Mac to import contacts.

     

     

    (Note: it's late here, and I'll be going to bed soon, but will be back tomorrow.)

  • John Brandt Level 1 Level 1 (5 points)

    Thanks Pondini. It got late for me as well....Responses to your points below:

     

    Does it show anything at all?  The disk should have a yellow icon.

    No disks ever show up. In both Setup Assistant and Migration Assistant modes it hangs on the Select the Source page with the spinner over "Looking for Other Computers".

     

    Have you run Verify Disk or Repair Disk on the old Mac and/or the backups?  If there's a directory problem, it may boot the old Mac, but the new one may not recognize it.

     

    I believe SuperDuper does Verify and Repair as part of its backup process. However to be sure I ran Verify/Repair on the MB startup disk and then on the SuperDuper backup. Unfortunately same issue in all three modes...

     

    Based on the number of warnings about doing the moves manually I am trying to avoid that until its the only possibility. Are there any other suggestions / things I can check?

  • John Brandt Level 1 Level 1 (5 points)

    One other behavior I want to point out if it helps....

     

    When using the option to Transfer from Another Mac the new MBP says I need to "update Migration Assistant on the other Mac". The Old MB is stuck spinning at "Searching for other Computers".

     

    As noted, I have run Software Update on the MB 10.4.11 and believe it is up to the latest levels. Hence my initial question of whether this was an issue going from 10.4 to 10.8.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.