Skip navigation

Battery life dropped considerably on Mountain Lion.

520901 Views 3,396 Replies Latest reply: Oct 28, 2013 5:38 AM by CT RSS Branched to a new discussion.
  • david907 Calculating status...

    I've had the same problem for the last 10 days after upgrading to Mountain Lion.

     

    I have a MacBook Pro 15" mid 2010. I also had about 7 hours of battery life before upgrading from Lion to Mountain Lion, now the most I can get is about 4.5 hours. Also, my MacBook sometimes runs noticeably hotter, particularly if using Google Chrome (it's better if I use Safari or Firefox instead.)

     

    I have always been very happy wih this great MacBook, but now I'm decidedly unhappy - I was about to purchase the new Retina MacBook Pro, but have changed my mind, at least until Apple fix this software!!

  • adi190 Level 1 Level 1 (0 points)

    Has anyone tried going back to 10.7 from 10.8?? Is it easily possible? I had made a time machiene backup just before upgrading/updating. Cn i use it to restore it bk? But most importantly will it rectify the battery issue?

  • sehrbaz Calculating status...

    My problem seems to be solved after killing the bash process from Activity Monitor. MBP mid 2011Untitled.jpg

  • TechArea Calculating status...

    I've the same problem with my battery MBP13" early 2011 with SSD...

     

    and I've found out that if i use my trackpad, the process "hidd" goes up to 6% cpu! So i work a lot with the Trackpad... I don't have a mouse or something other... I assume that the new trackpad driver are buggy like the other stuff from Apple in the last time...

  • iconoclastic Level 1 Level 1 (0 points)

    i have the same problem and I do not have dropbox installed

  • Rayced Level 1 Level 1 (5 points)

    Same stuff as with Lion. SMC reset, login items etc. None of these solutions will fix it.*

     

    Just check your battery after 7 hrs sleep how much charge has lost. Mine is always losing around 7% from 100%, a litlle less (5%-6%) if I put it to sleep with a charge around 50%.

     

    Also check Windowserver process how much CPU percentage will use at any GUI interactions (just use a couple of times in sequence the Mission Control gesture).

     

    *obviuosly I'm not talking about the rare case of having some processes stuck at 100% CPU usage in the background, which is quite easy to see.

  • Softworn Calculating status...

    I definitely lost at least 512mb of memory on initial boot. The only thing I did was upgrade to Mountain Lion. I even did a lot of corner cutting beforehand to knock off every last megabyte of unneccessary memory consumption, yet the upgrade still managed to increase memory consumption. This is awful. I was reluctant to upgrade until I read a claim of improved system resource utilization. I have achieved the opposite. My common sense told me that the new UI features would use more memory, but I fell for the marketing. Please don't emulate Microsoft anymore. I am already strongly considering fully converting to Linux now.

  • yantaialec Level 1 Level 1 (0 points)

    OK, so confirmed now im my case that Dropbox doesn't seem to be the problem. The issue is still the same after removing Dropbox completely and rebooting.

     

    I have no bash processes running in activity monitor, but I checked Utilities>console and think it could be a Kernel Issue.

     

    There are literally hundreds of these - http://i.imgur.com/WFxgK.png


    That's with a FRESH install of ML onto a brand new drive.

     

    Does anyone know what this means? It's gone beyond me now we're into Kernel problems...

     

    I wish Apple would offer more in the way of support for this. I shouldn't have to take ~3 or 4 hours out of my day every day for the last two weeks trying to find the problem.

  • ellbow Calculating status...

    i have MBP 2012 13' after install ML my battery drop from 6.50hr to 4.30hr at 100% full charge, so problem because i always on MBP average 6hr to i can go home and charge ,apple team please solve as soon as posible.

  • kevinfromocala Calculating status...

    Has anyone done a clean install of ML with NO third party apps installed & had this problem? Seems like this would help clarify if it's Dropbox,  etc. 

  • yantaialec Level 1 Level 1 (0 points)

    kevinfromocala wrote:

     

    Has anyone done a clean install of ML with NO third party apps installed & had this problem? Seems like this would help clarify if it's Dropbox,  etc. 

     

     

    Yes. I don't know about others, but I personally have done it 3 times. Read back a few pages to my other post. Page 31.

  • kevinfromocala Level 1 Level 1 (0 points)

    Thanks. Seems pretty clear that it's an OS problem.

  • antonywu Calculating status...

    In my case though, Dropbox actually exacerbates the problem. The sad thing with Dropbox is that ever since they released new builds a few month ago, the app has been stuck with indexing a total of 3Gb data almost day and night with over 100% of CPU usage constantly (some of you may be able to verify this in Activity Monitor). So with Dropbox running, I definitely get far worse battery life, close to 1 hour maybe? Without dropbox it goes with a little over 2 hours on ML.

     

    Again, it is a fresh installation of ML (not upgrade from Lion). I depend on Dropbox for some of my work files, so I run it, but I apply a third party free app called cputhrottle that caps Dropbox CPU usage to 15% max. Does it help with the battery life? some..

  • Rayced Level 1 Level 1 (5 points)

    Guys, this problem is still here since Lion.

    This is a deja-vu, and nobody on this forum was ever able to find a real solution aside from workarounds and a bunch of common suggestions (SMC reset etc.), all of them not pointing at the right direction but just trying to blame it on single user's fault.

    Which is obviusly not the real problem.

     

    Do you want a better battery performance at the cost of all the fancy features? Use Snow Leopard.

    Do you want an ultra fancy and updated (more secure) OS at the cost of battery life? Stick with Mountain Lion.

     

    I'm unsubscribing before the pack of flamers and dumb fans will start with their no-sense in the thread.

    Have a good one.

  • Rayced Level 1 Level 1 (5 points)

    I never had this issue with DropBox and you're the first one I hear having it.

    Probably you can re-install it after being sure you've downloaded the latest stable version. I'd also use an app uninstaller —prior re-installing it—to get removed all of its components if I didn't knew exactly where they are located.

    You'd might as well try first to repair your disk permissions as well as your user's ACLs via passwordreset program after having booted from the recovery partition:

     

    http://osxdaily.com/2011/11/15/repair-user-permissions-in-mac-os-x-lion/

     

    Bye.

1 ... 37 38 39 40 41 ... 227 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (85)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.