Skip navigation

upgrade to Mountain Lion broke my exchange account

46144 Views 109 Replies Latest reply: Jul 29, 2013 11:40 AM by returnofthemac23 RSS
  • slmtrey Level 1 Level 1 (0 points)

    I deleted my Exchange account and set it up again in mail.  I have not had a problem with mail, contacts or calendar for a week in internal or external environments.  Everything is syncing as before ML upgrade.

  • norwenkel Calculating status...
    Currently Being Moderated
    Aug 7, 2012 5:25 AM (in response to hylax)

    https://discussions.apple.com/message/19189846#19189846

     

    should help in most cases when exchange related issues are mentioned

     

    Take care

     

    Norbert

  • charliefromnsw Calculating status...
    Currently Being Moderated
    Aug 7, 2012 11:45 PM (in response to hylax)

    Shutdown Mac Mail.

     

    Go to /Library/ in Finder and copy and delete the Mail Folder (make a copy of it somewhere before hand). This folder will be under your User Profile (ie /Users/<username>)

     

    Go to Preferences, then Mail and Contacts and then highlight the Exchange account and delete it.

     

    Go to /Library/Cache/ folder and delete all the contents under it.

     

    Go to /Library/Cookies/ folder and delete all the contents under it.

     

    Go to /Library/Saved Application State/ folder and delete all the contents under it.

     

    Reboot

     

    Go to Mac Mail and recreate the account

     

    Let me know if that helps.

  • charliefromnsw Level 1 Level 1 (0 points)

    Forgot to mention, before deleting the /Library/Mail folder, delete the exchange account under Preferences>Mail and Contacts.

  • dimitri0105 Calculating status...

    tried it twice and no luck i am about to give up i have wasted hours everyday for over a week now its so frustrating productivity has come to a stand still

  • mjc710 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 8, 2012 8:42 AM (in response to mjc710)

    After losing much of my Exchange calendar, I had to use my iPad (which I had immediately switched to airplane when I lost calendar entries on my iMac, MacBook, and iPhone) to manually reenter the lost calendar items. I then re-synched everything, and it seems to be working OK now, but what a pain!

  • FriedGreenTomatillos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 5:29 AM (in response to hylax)

    Exact same problem.  Anything tied to Exchange is not working properly.

     

    Server name changes to internal server and I need to edit the name to get it back online, which it does.

     

    With Calendar, appointments will not sync, so the Calendar function using Mountain Lion is not reliable and I have not found the work-around.

     

    Otherwise, things work well so far.

  • Casey Leedom Calculating status...
    Currently Being Moderated
    Aug 10, 2012 2:13 PM (in response to hylax)

    I've made an appointment to downgrade back to Lion since this bug and the Safari rendering issues (https://discussions.apple.com/thread/4148522) have made Mountain Lion a no-go for me.

  • melrosemark Calculating status...

    Yes, I requested the disk to downgrade to Lion and plan to do that.  I'm tired of messing with preferences, external/internal servers, etc.  I usually like Apple because as Steve Jobs said "it just works."  Unfortunately, they pushed too fast to release ML before it could run with Exchange.  Big error in my opinion, and I assume eventually they will fix it.  I wasn't planning to be a Beta tester for Mail when I did the upgrade. 

  • XianNewman Level 1 Level 1 (5 points)

    Don't do this. Made the problem worse.

  • mondenet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2012 2:07 PM (in response to hylax)

    It's so frustrating to come to this forum only to find that everyone has the same problem but no one seems to have the solution (Any word from Apple?!). I have found a work-around but it's not what I wanted. I've installed windows on my MacBook Pro (supplied by the college where I work). Now I boot into windows, get my mail, then boot back. Not an elegant solution. Please Apple, fix this problem!

  • William Lloyd Level 6 Level 6 (19,220 points)
    Currently Being Moderated
    Aug 13, 2012 2:12 PM (in response to mondenet)

    Mail uses Exchange's "Autodiscover" functionality to get the server name.  It appears from some of these notes that the Exchange server itself is returning incorrect information... It might be worth talking to your respective IT departments to ensure Exchange is returning accurate server information as part of its Autodiscover replies.

  • mofi007 Calculating status...
    Currently Being Moderated
    Aug 13, 2012 2:18 PM (in response to hylax)

    I have the same problem with exchange since i upgraded to the new OS. i am now using outlook for mac because of this issue but i would like apple to fix this ASAP. I heard that there is a new beta for developers that might be addressing this issue but this is not yet out to the public.

  • karhonchung Calculating status...
    Currently Being Moderated
    Aug 14, 2012 12:41 AM (in response to hylax)

    Hi,

     

    I just had this issue with a client, here's what I did as a workaround until Apple fix the issue.

    Ping the external OWA address, it hopefully will return an IP but will timeout. This is normal as Exchange does not respond to pings. With that IP, enter it into both the internal and external server fields. Your mail should start working now but bare in mind this will only work if your exchange has a static IP, I'm guessing most have.

    Another work around is by changing the Host file on you mac to point the internal owa url to the external IP. You can find out how to do that by doing search on: How to Edit the Hosts File in Mac OS X with Terminal.

     

    Hope that helps!

  • smittyrocks Level 1 Level 1 (10 points)

    THe IP address will only stay there until the next time autodiscvoery checks in or the user closes Mail.app. It reverts back to the server name. We've tried this when Mountain Lion first came out, some were already using this workaround for an issue in Mail.app that occured in Lion. Once ML was installed, it reverted the IP address into the server name. Also, if you work inside an office as well as remote, this won't work because the IP address changes depending if you are on the network or outside the network.

1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.