Skip navigation

Import video to Aperture library on Mountain Lion

18928 Views 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman RSS Branched to a new discussion.
  • TheWrongStuff Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 8, 2012 2:09 AM (in response to in2om)

    Might be a plugin. What plugin's are you people using for aperture?

  • lin qi-zhen Level 1 Level 1 (0 points)

    I don't think the problem comes from the plugin

     

    i've tried reinstall the system(not clean install)

    after that, the aperture plugin folder's empty

    but the problems still happen

  • TheWrongStuff Level 1 Level 1 (5 points)

    Solved the problem. I downloaded the final release of Mountain Lion (I previously had the gold master installed and hadn't bothered to download the final release) and reinstalled it over my existing gold master install. Worked perfectly after that. Took about 10 minutes to complete. I am not sure whether it was an issue with a corrupt file in the Gold Master or whether it was just an issue with the Gold Master itself but the final release seems to resolve it.

  • Gerhard Bergmann Level 1 Level 1 (60 points)
    Currently Being Moderated
    Aug 11, 2012 1:15 AM (in response to in2om)

    Hallo in2om,

     

    yesterday my problem was solved.

    First I reinstalled (and updated) Aperture again, but this did not help.

     

    Then I started from the recovery partition (cmd-r during start) and reinstalled Mountain Lion. No, you won't loose anything (but have a backup anyway!!). I did not have the Golden Master (as TheWrongStuff had), but the "normal" release fom the AppStore. But reinstallation helped anyway!

    Now I am able to import again, and play my "old" movies, as it used to be!

     

    Anyway, Apple is interested in my Aperture Library, I will send it to them on Monday. If they find out anything else, I will report here.

     

    Just try to reinstall Mountain Lion, you can't do anything wrong doing this, I hope it works for you, too.

     

    Have a nice weekend!

  • TheWrongStuff Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 11, 2012 1:36 AM (in response to in2om)

    When you reinstall you don't lose anything. Just reinstall over the existing install. It takes a short period of time and your machine will be the same way it was before, except Aperture is fixed.

  • lin qi-zhen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 1:36 PM (in response to léonie)

    hi, in2om

    I've checked the information in console

    it seems the problem here

     

    Aperture[543]: Failed to communicate with qtkitserver: Connection invalid

    Aperture[543]: Failed to initializeServer(), returned 5

     

    maybe you should check yours

  • lin qi-zhen Level 1 Level 1 (0 points)

    in2om

     

    I forgot one thing to tell you

    this error message happen to quicklook app too

     

    I've checked

    quicklook (space on video file) and preview app both coundn't play the video file

     

    maybe the problem's here?

  • Philip Kalina1 Level 1 Level 1 (5 points)

    I've been struggling with this same issue now for a day, and thankfully found this discussion. After re-installing AP 3.3.2 I could not play or import movies. The referenced movie files were fine, but AP was not operating correctly.

     

    So taking Bergmann's and WrongStuff's advice, I re-installed Mountain Lion from the recovery disk. I had to wait about 3 hours for it to finish....but it worked!

     

    The only issue I found was the poster frames (thumbnails) for most of the movies need to be refreshed manually.

     

    BTW, my problem began after I did a full restore from Time Machine, due to a corrupt system file.

     

    I've notified Apple Professional Applications Support of this issue.

     

    Thanks, guys!

  • TheWrongStuff Level 1 Level 1 (5 points)

    Thanks Philip. I also did a time machine restore after my drive failed so this might be the cause. Only thing in my case was my drive failed on DP4 and I installed Gold Master after that so the installation of Gold Master should have fixed it if that was the problem.

  • AJL. Level 1 Level 1 (5 points)

    Hi All,

     

    I may have found the root cause. I run a clean script, and one of the tasks is to clean out caches. Specifically, the following location was being cleaned out:

     

    /System/Library/Caches/

     

    Re-installing Mountain Lion as per Gerhard's post (which resolved the issue for me before I found the cause - thanks Gerhard ), replaces a file in this folder called:

     

    com.apple.xpchelper.cache

     

    I haven't found the file in any other location, so I've made a copy of it for safekeeping.

     

    So - if you want to test this, move this file from /System/Library/Cache and reboot - it will break Aperture video.

    Replace the file and reboot and it's fixed. I haven't investigated what the file does exactly, but open with TextEdit and you'll see it's pretty integral to the system.

     

    Time Machine does not back this location up, so restoring won't fix, however if you have a copy on hand you can replace it and resolve very quickly.

     

    I hope this helps...

     

    Regards,

    AJL...

  • lin qi-zhen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 4:48 PM (in response to in2om)

    to reinstall osx could resolve the problem

    but the problem happen again after restore the current system from time machine

     

    anyone tested it on 10.8.1 update?

  • _XtraN_ Calculating status...
    Currently Being Moderated
    Sep 10, 2012 11:19 PM (in response to AJL.)

    AJL.

    Thanks for you time invested in finding the problem!

     

    This indeed worked for me. com.apple.xpchelper.cache is the problem for sure I believe. I could not play my existing videos or import new ones.

     

    lin qi-zhen

    Re-installing 10.8.1 does indeed add com.apple.xpchelper.cache to the directory /System/Library/Caches/

     

    link to 10.8.1

    http://support.apple.com/kb/DL1571

     

    Aperture FIXED!

1 2 3 4 5 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.