Skip navigation

Lion WiFi Connection Problem

667616 Views 2,669 Replies Latest reply: Apr 20, 2014 7:29 AM by AleDeC RSS
  • gsspike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 12:53 PM (in response to lrogersinlv)

    I upgraded to Mountain Lion hoping it would fix my wifi.  Now I have to roboot every 20 minuts or so.  ***!

      We have 2 mac's almost side by side.  After instaling Lion on both only one had the issue.   I've only upgraded the one with the problem so far this time. 

    Mountain Lion is a 1000X worse.  Lion was dropping wifi occasionaly this thing loses it almost constantly.

  • NateKH Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 26, 2012 6:05 PM (in response to NateKH)

     

     

    on an iMac, problem started when I upgraded to lion, still present after upagrade to mountain lion.

     

    1) Yes, no result

    2) No option to choose 5Ghz (dlink dir-615 router)

    3) Yes, and there isn't an issue from waking, it just drops signal.  Have to turn off wifi then back on to reconnect

    4) Yes, no result

    4) same

     

     

     

    Oddest thing, deleted and re-added my wifi network from the system prefrences.  Seems to be all better.  Been 10 hours and counting with no drops.  This didn't work on Lion, but seems to have solved it after upgrading to ML. 

  • av_a_go Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2012 3:52 AM (in response to gsspike)

    Check your router settings and see if you have Wireless QoS (WMM) enabled? If so, diable it. This fixed my problems, and had the benefit of speeding up my wifi in the process.

  • jfsiman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2012 10:05 PM (in response to gsspike)

    Try changin your WiFi MTU to 1300, I did that and it solved my problems.

     

    Go to Networks -> Advanced - > Hardware -> Manually Configure , MTU Custom: 1300

  • mtpettyp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2012 9:02 PM (in response to lrogersinlv)

    I solved a similar issue with the following instructions (basically downgrading your Wi-Fi drivers to Snow Leopard:

     

    http://apple.stackexchange.com/questions/59007/wifi-doesnt-stay-connected-with-2 010-macbook-pro-after-upgrade-to-mountain-lion

  • William Kucharski Level 6 Level 6 (14,405 points)
    Currently Being Moderated
    Aug 2, 2012 9:19 PM (in response to mtpettyp)

    mtpettyp wrote:

     

    I solved a similar issue with the following instructions (basically downgrading your Wi-Fi drivers to Snow Leopard:

     

    http://apple.stackexchange.com/questions/59007/wifi-doesnt-stay-connected-with-2 010-macbook-pro-after-upgrade-to-mountain-lion

     

    Remember doing this may reopen numerous security holes, is completely at your own (significant) risk, and very likely will prevent future OS updates from applying properly, possibly requiring a complete reinstall of OS X to repair.

  • Alexlava Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 6:55 AM (in response to av_a_go)

    I did that .... didn't do jack **** !

  • gsspike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 11:31 AM (in response to lrogersinlv)

    I've posted this else where.

     

       I thought I should pass this on.  Apple called me yesterday and they are following these threads.   They told me that right now they are gathering data and they weren't calling me with a fix yet.  They had me try different things others have recommended and then they would have me run some test and email it to them.    Luckally my Mac kept dropping wifi while I was talking to them and using my Macbook without it going into sleep mode. . 

     

         Again they are taking it seriously, they are reading the threads.   They are looking into what has worked for some people and not for others.

     

         Now this is My advise,  Post what you are trying, BUT Don't post that it's working for you until you test it for a day.  Some are trying everything in every post and then they are disappointed that it didn't work  and forget to change things back and that could lead to other issues down the road.

     

    Again don't post it worked for you because it didn't drop wifi for a few hours give it a day.

  • Vognbygger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 3:01 AM (in response to lrogersinlv)

    I can deffently say that resetting all wifi setting on my macbook cleared my issues under Lion. Been up and running for about 14 days with no dropout. Still it is much slower at connecting to my Wifi from sleep mode than before Lion, though not a big issue.  

  • gsspike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 10:13 AM (in response to lrogersinlv)

    Verizon Fios Actiontec router users only!

     

    This is something that has been working for me since early Saturday. 

    I've passed it onto Apple.  I know most of us has tried deleting our network setups with no luck.

     

    Well this is what i did:

    1: Deleted all networks and setting on my Mac again.

    2: This time after that I did a Hard Reset of my router.

    3: Rebooted my Mac

    4: I then let our 2 Macs and Router set them selves up Automatically.

    5: I left all settings to the default  settings including Network name

    6: Later I set my energy settings to deep sleep every 5 minutes.

     

    This morning I decided to update my Onkyo receiver.  I disconnected my router and moved it over to the receiver it needed to be hard wire connected to the receiver.  The net worked fine there and when I put it back in the other room and connected to my PC every thing was still working wirelessly on our Macs.

     

    I intentionally waited 2 days before I posted this and 36hrs before I passed it onto Apple.

     

    I really don't know if this is just a fluke or if it works on other routers.

     

    If you try it let me know your results.  I'll pass it onto Apple.

  • ryanmarc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 4:10 PM (in response to lrogersinlv)

    Here's a $15 solution to the WiFi dropping problem that worked for me:

     

    I have had problems with my WiFi intermittently dropping for years now (MacBook Pro late 2008), but as of last week the constant frequency of the drops basically rendered the WiFi inoperable... after hours and hours of troubleshooting I suspect this is due to a faulty wireless card.

     

    Anyway, based on another poster's (GSL1909) recommendation in a different thread, I purchased an Airlink 101 adapter (link below) and this completely solved the issue. As they mentioned, this USB adapter protrudes less than 1/4" from the computer, which also allows it to fit in the computer case. Additionally, drivers for OS 10.7 are available on the Airlink website, and it's also compatible with 10.8:

     

    http://www.meritline.com/showproduct.aspx?ProductID=45923&SEName=airlink101-awll 5088-wireless-n-ultra-mini-usb-adapter

  • The creative genie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 5:49 PM (in response to gsspike)

    I too upgraded to Mountain Lion about a week ago and so far I have had no further problem.

  • PepperSalsa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2012 1:15 PM (in response to lrogersinlv)

    I work from home and have 3 iMacs on the network.  I upgraded one of the iMacs on Sunday to Mountain Lion.  The other two iMacs are running Snow Leopard.  Since the "upgrade", the ML iMac will not stay connected to wifi.  The connection drops every couple of minutes.  Both of the Snow Leopard iMacs work like a charm and yet Apple keeps insisting that it "isn't the ML upgrade" even suggesting that someone in our neighborhood had set up a device at the exact same time we were downloading ML that is interfereing with our wireless network.  HUH?

     

    We have made four calls to Apple support, tried every single "workaround" and temporary fix, to no avail.  They act like they've never heard of the problem.

     

    This is the kind of sloppy, "it's not our software" excuses I used to get from Microsoft.

     

    I never, ever thought I would say this about Apple, but this is just pure, 100% crap. If I wanted to spend four days and 26 hours trying to fix my computer after downloading your software, I would have stayed on a Windows machine.

     

    I'm having Vista flashbacks and it's not pretty.

     

    I guess we're back to Snow Leopard until Apple acknowledges the problem and provides a real solution.

  • fixerdrew02 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2012 8:56 PM (in response to lrogersinlv)

    I too am having difficulty remaining connected with internet.  I've posted on MacRumors and someone suggested changing MTU to 1453 (or whatever it was) but that didn't work. I also tried changing my Location to something new which didn't help either. 

     

    This is getting really frustrating.  I had to restart the WiFi (turn off and then back on) in order to keep having internet connection, even while writing this.  I have a download going right now, but I don't think that's it because it also occurred when I was watching an Adobe Flash video this afternoon.

     

    I never know I've lost internet unless I try to load something or I see the download pause (connection speed dwindles).  However the WiFi icon on the task bar will always show connected.

     

    What my wireless currently shows:

     

    PHY Mode: 802.11n

    Channel: 6 (2.4 Ghz)

    Security: WPA2 Personal

    RSSI: -69

    Transmit Rate: 39

    MCS Index: 10

     

    If anyone has a fix on this, please let me know.  This was a problem that occurred under Lion before I updated to ML, but it occurred very seldomly.  Now it's happening fairly often.

     

    Thanks!!

  • edfromarvada Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2012 12:17 PM (in response to fixerdrew02)

    Just got off with apple wifi tech and their solution has worked so far.  Go into Library/Preferences then delete the system configuration file. Next go into system preferences Network and uncheck the ask to join new network button then restart the computer.  Hope this works for everyone else.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (80)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.