Skip navigation

Getting EPSON Perfection 4990 to work properly

3149 Views 10 Replies Latest reply: Nov 22, 2012 4:04 PM by Johnlog RSS
julesmazur Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 2, 2012 8:18 PM

I used to have my EPSON 4990 scanner hooked up to a Windows machine, where I had the drivers and some proprietary software installed via the included CD. One of the scanner's defining features was the ability to detect separate negatives and slides in the holder, and save them as separate images. However, now that I've hooked it up to my Mac (and downloaded the drivers via the App Store), the scaner has lost the ability to separate negatives and slides into different files, even when I select "detect separate items" from the dropdown menu in the scanner app. Is there any way to restore this feature?

  • Matt Broughton Level 5 Level 5 (4,905 points)
    Currently Being Moderated
    Aug 3, 2012 7:30 AM (in response to julesmazur)

    The drivers you got from the App Store are for use with Image Capture that comes with OS X.  You might have better luck getting Epson's older software from the Epson site.  When you get to the download page for the drivers for you scanner, there will be a pop up menu to select your operating system.  Select Mac OS X 10.6 and you should have access to the v3.07a drivers.  Although not officially supported for Mountain Lion, I believe they will work just fine.  That is the version of the drivers that I use for my Epson 3490.

  • Chloemann Calculating status...

    I am having the exact same problem as JulesMazur - same Epson scanner (4990), same problem recognizing separate slides, etc.  Big project stopped in my tracks.  I tried your solution, Matt, and it doesn't seem to work.  I downloaded the 10.6 drivers and got something called the Epson ICA Installer.  Opened it up, it seemed to process (bars running showing me progress) then nothing.  Can't find the application, if that's what it is, anywhere - just the ICA installer and we go through the process all over again.  I can no longer even FIND my scanner unless I go to System Preferences- Printers & Scanners - and click on my device.  I'm sure I get the same thing Jules does - a very rudimentary screen allowing me to pick very few options (photo/film negatives/color positives).  Gone are the different formats this scanner offered: Home Mode, Full Auto, etc. And when you try to scan slides, it scans the whole flatbed, slide holder and all.

     

    I did have one other thought (and I've never tried anything close to this, being a real neophyte, computer-wise). Since I still have the actual disks of Snow Leopard when I upgraded to that (and the scanner worked fine with that), is it possible to partition the hard drive, and install Snow Leopard as the operating system for the other drive, and then re-install the software for the scanner on that hard drive and do all the scanning there?  In other words, is it possible to run two different OSs on the same computer by partitioning the hard drive?

     

    The other thing I wondered is whether our inability to work this has anything to do with Silverlight.  I'm trying to remember why I have that on my system, but I'm thinking it came with the scanner and the scanner software.  Would upgrading the version of Silverlight (if there IS an upgrade) put us back in business? 

     

    Thanks!

  • Matt Broughton Level 5 Level 5 (4,905 points)
    Currently Being Moderated
    Aug 5, 2012 4:30 PM (in response to Chloemann)

    Chloemann wrote:

     

    I am having the exact same problem as JulesMazur - same Epson scanner (4990), same problem recognizing separate slides, etc.  Big project stopped in my tracks.  I tried your solution, Matt, and it doesn't seem to work.  I downloaded the 10.6 drivers and got something called the Epson ICA Installer.  Opened it up, it seemed to process (bars running showing me progress) then nothing.  Can't find the application, if that's what it is, anywhere - just the ICA installer and we go through the process all over again.  I can no longer even FIND my scanner unless

     

    Unfortunately, you grabbed the drivers for OS X 10.6 Image Capture for you scanner.  It sounds like they installed over the Mouintain Lion drivers.  That is why Image Capture and Print & Scan cannot find your scanner anymore.

     

    First, let's get the working older Epson drivers working for you.  You can download the Epson Scan drivers using this direct download link.  Note for all others -- these drivers are for the Epson 4990 scanner only.

     

    Second item of business is to try to get the correct Image Capture drivers installed.  Go to /Library/Image Capture/Devices.  Remove the item EPSON Scanner and restart your computer.  Now when you go to System Preferences > Print & Scan, click the Plus icon and select your scanner.  I think the system should now go out and get the latest drivers for you.  Rudimentary or not, at least it gets you back to square one.

     

    The other thing I wondered is whether our inability to work this has anything to do with Silverlight.  I'm trying to remember why I have that on my system, but I'm thinking it came with the scanner and the scanner software.  Would upgrading the version of Silverlight (if there IS an upgrade) put us back in business?

     

    Silverlight does have an updated version of their software for Mountain Lion.  I have no idea if it is a free upgrade for you.  You might want to explore this option after you try the Epson Scan software.

  • Chloemann Level 1 Level 1 (0 points)

    It worked!!!  I used your direct download link.  Another note for other Epson 4990 users who will find this advice helpful:  In order to INSTALL the driver that you get from the direct download link, you have to go into your Mac "System Preferences" - "Security & Privacy" - then unlock the lock icon, and click on "Allow applications downloaded from ANYWHERE."  Otherwise, it would not let me open the installation softward I downloaded from Mr. Broughton's link.  (I saw this on another post, and it didn't work previously but I must have had the wrong driver, as Mr. Broughton suggested).  Once I did that, I could open the installation software, install the driver, and Voila!  There was the regular Epson Scan menu that I was familiar with but had lost after installing ML, and when I clicked on all the options for scanning slides (positive film, etc.), it previewed everything perfectly - and in individual slides. 

     

    Thank you Mr. Broughton!!!

     

    P.S. don't forget to go back into System Preferences/Security and change it back from Anywhere to only Mac and authorized software, or whatever, to keep your system safe.

  • Chloemann Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 3:57 PM (in response to julesmazur)

    Jules -

     

    Have you solved the Epson 4990 problem yet?  See Mr. Broughton's response to my e-mail - it worked for me after many other failed attempts.  I seem to be back up and running.  Just can't figure out how to give him 10 points!

  • Matt Broughton Level 5 Level 5 (4,905 points)
    Currently Being Moderated
    Aug 9, 2012 4:11 PM (in response to Chloemann)

    Chloemann wrote:

     

    It worked!!!  I used your direct download link.  Another note for other Epson 4990 users who will find this advice helpful:  In order to INSTALL the driver that you get from the direct download link, you have to go into your Mac "System Preferences" - "Security & Privacy" - then unlock the lock icon, and click on "Allow applications downloaded from ANYWHERE."  Otherwise, it would not let me open the installation software…

     

    Chloeman,

    I am glad to hear you have the functionality that you wanted.

     

    Gatekeeper can be a mixed blessing.  The default setting is to allow properly signed packages and purchases from the Mac App Store.  You can override this setting on a case by case basis without going to the System Preference.  If you control-click on the installer, you will get a contextual menu that will allow you to choose Open.  When you do it that way, you will be presented with a dialog box asking if you really want to install the installer.

     

    By the way, only the person initiating the thread can award points.  I do this to help people, not to get points.

  • Nippon07 Calculating status...

    Fan-freaking-tastic!!  Thanks from me too for helping out with this.  I even went so far as to call Epson's helpline (not so helpful) directly and yet they couldn't offer up this advice. 

     

    Thanks.

  • PoohBah100 Calculating status...

    Hi There,


    I just followed your instructions and I can see the scanner in the Print/Scan tab under system preferences, but it doesn't show up in image capture, or Epson Scan. When I click open scanner I just get a grey box with a dotted line in the shape of a rectangle inside it. It has "show details" and "scan" as two button at the bottom, but "scan" is greyed out so I can't use it. When I click on "show details" I get a lighter grey box with "hide details" "overview" and "scan" butttons at the bottom, but all of them are greyed out. The computer knows that the scanner is there, but none of the scanning software does.

     

    Thanks for your help

  • PoohBah100 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 3:13 PM (in response to PoohBah100)

    An update to this post - It seems my USB cable wasn't in tight, so after fixing that. Image capture does see the scanner, though I cannot scan - that button is still greyed out. However, I am able to use the old photoshop CS3 to scan, so I guess I can scan in CS3 and then save the file and open them up in CS6 to work on them - Workable solution, though not what I had hoped.

  • Johnlog Calculating status...

    Thanks from me too for the direct download link. I've moved my 6 year old scanner to my new Mac replacing my Windows desktop and you've saved me hours of searching.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.