Skip navigation

Vacation Autoresponders in Lion Server

8918 Views 35 Replies Latest reply: Dec 17, 2012 10:02 AM by CharlesY RSS
  • paulfromburwood Level 1 Level 1 (85 points)
    Currently Being Moderated
    Apr 11, 2012 11:57 PM (in response to pilbaraecho)

    Another person banging there head against the wall!

     

    I just cant get it to work, I have added the email address of the user to the "Additional list of recipient e-mails" and its still not working

  • paulfromburwood Level 1 Level 1 (85 points)
    Currently Being Moderated
    Apr 12, 2012 4:08 PM (in response to paulfromburwood)

    Take it back all working now.

  • tomas.wedoit Calculating status...
    Currently Being Moderated
    Jul 17, 2012 6:07 AM (in response to jorge cristian)

    It helps me, Thanks

    jorge cristian wrote:

     

    I have noticed in mailaccess.log when a mail arrives to a user with an autoanswer filter active and configured, the part of the system that is responsible for delivering to the user's mailbox folder, which i think is called DOVECOT, puts a log saying

     

    "discarding vacation response for implicitly delivered message; no known (envelope) recipient address found in message headers (recipient=<user@hostname>, and additional `:addresses' are specified)"

     

    and that gave me a hint.

     

    The problem is that DOVECOT does not uses the user's mail address.

     

    After looking a way to correct this I found a line in master.cf, wich is located in /etc/postfix, that says

     

    dovecot   unix  -       n       n       -       25      pipe

      flags=DRhu user=_dovecot:mail argv=/usr/libexec/dovecot/dovecot-lda -d ${user}

    # Use these settings to enable +addressing (user+mailbox@example.com)

    # flags=DRhu user=_dovecot:mail argv=/usr/libexec/dovecot/dovecot-lda -d ${user} -a ${recipient} -m ${extension}

     

    I've added at the end of the flags line what is suggested

     

    -a ${recipient} -m ${extension}

     

    and reloaded postfix master.cf

     

    After that, vacation messages started to be sent.

     

    Hope this helps.

  • Jashin Rodriguez Calculating status...
    Currently Being Moderated
    Aug 10, 2012 1:15 AM (in response to Mike Friedman)

    Mike Friedman wrote:

     

    I also found that it's necessary to ACTIVATE the set of filters that you are using, otherwise nothing happens.

     

    I have to say that this is a huge step backwards for something that should be trivial. It was trivial in Snow Leopard and now they've made it hugely difficult to do something simple.

     

    I can't for the life of me fathom why.

     

     

    Thanks man!

    I've missed that one and I had a user that wasn't working because of that, you save mi life.

  • iBlink Level 2 Level 2 (180 points)
    Currently Being Moderated
    Nov 8, 2012 10:57 PM (in response to pilbaraecho)

    ok, I had this working. I haven't looked at it for a while and it must have changed after doing some updates.

     

    We are running Server 10.7.5

     

    Open Server Admin

    Select your server and drop the menu down

    Select Mail

    Select Settings

    Go to Filter tab

    at the bottom of the page there is an option to enable server side mail rules

    Save

     

    Now when you log in to Webmail and go to Settings and then Filters and add a filter there is the optino for reply:

     

    Log into webmail

     

    Click on Settings (top right corner)

     

    Click on Filters Tab

     

    Click on Add Filter (single page with green + icon)

     

    Name the filter something like Vacation or auto respond or whatever

     

    Click All Messages

     

    Choose Reply with Message from the drop down menu

     

    Fill out the form to say what you want (you can leave the last two fields empty)

     

    Click Save or Add (both seem to create the Filter)

     

    Far right there is a Filter Disabled check box for you to use to activate or disable auto response.

  • CharlesY Calculating status...
    Currently Being Moderated
    Dec 17, 2012 10:02 AM (in response to tomas.wedoit)

    +1 for jorge cristian's modification to the dovecot flags.

     

    Note that my master.cf file had the following timestamp:

    0 -rw-r--r--    1 root  wheel   7422 Oct 10  2011 master.cf

     

    So it's possible that other versions have the flags set differently. I'd be interested to know if that is the case for someone that did not need to make the modification.

     

    Cheers

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.