Skip navigation

Can't download or update apps from App Store

492 Views 3 Replies Latest reply: Aug 10, 2012 3:15 AM by Steffen_R. RSS
jwang158 Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 8, 2012 3:28 PM

I'm using a MBP Retina Display with Mountain Lion. Whenever I attempt to update apps or download new ones, the sign in window pops down. I type in my log in information and the window goes back up, just to come back down again. It doesn't stop no matter how many times I sign in. I've tried signing out again, signing back in, deleting cache, etc. Nothing works. Any pointers?

MacBook Pro with Retina display, OS X Mountain Lion
  • Carolyn Samit Level 10 Level 10 (84,015 points)
    Currently Being Moderated
    Aug 8, 2012 10:25 PM (in response to jwang158)

    Disable anti virus software and turn off the Firewall in System Preferences > Security & Privacy > Firewall.


    And try here >  Mac App Store: Sign in sheet does not appear, or does not accept typed text

  • Steffen_R. Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 10, 2012 3:15 AM (in response to jwang158)

    Guess, you only have another issue with the app store problem. Some cannot login, some are caught into a loop of password prompts...
    All is related to Macs with MacOS 10.4.7 - but seems to have follows on MountainLion as well.

    For MacOS 10.7.4 there are two different solutions trials, one is to go to close all applications then navigate to /var/db/crls and delete there the files crlcache.db and ocspcache.db - reboot the system, empty trash and see if this solved the problem.

    If not, second chance is to reset the certificates, mentioned here:



    1. Delete the files /var/db/crls/crlcache.db and /var/db/crls/ocspcache.db. These can be found using Finder’s Go >; Go To Folder menu (Cmd + Shift + G). This resets the cache of accepted certificates in the system. It doesn’t remove them, it just forces the system to rebuild the caches upon restart.
    2. Open Keychain Access (/Applications/Utilities/Keychain Access). Select Certificates in the Category picker on the left side. In the search bar, type in the word Class. Look through that list, and find any certificates that have a blue + symbol over their icon. These are the ones you need to modify.
    3. Select one that has a blue +, and hit Command + I. Click the disclosure triangle beside the “Trust” list to show the list of permissions. Now, what we need to do is to set this certificate to use the system defaults. However, for some reason, when you select it, it doesn’t save. So what you need to do is this. Under “Trust”, where it says “Secure Sockets Layer (SSL)”, change the dropdown menu to say “No Value Specified”. Then, close the window. It will ask for your administrator permissions. Then, open the info pane for that certificate again. Under “Trust” again, now set the dropdown that says “When using this certificate:” to say “Use System Defaults”. You can then close out of the info pane, and enter your password again. Do this for any of the certificates that have a blue + on their icon. There should only be one or two at most.
    4. Restart your system.

    So, as you see, it start again with reseting the certificate cache and next manually working the certificates, to ensure proper system setting...

    But there are evenly people who failed with this... but you can give it a try, I don't know if it's in MountainLion compareable...


    If all fails - then we have to wait for a fix from apple, because if those guess from apple service have no clue, well, then it must be done by higher instance of apple


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.