Skip navigation

iCal keeps prompting me for password

11391 Views 36 Replies Latest reply: Apr 23, 2013 4:53 PM by gregfromLA RSS
1 2 3 Previous Next
edlsoccer Calculating status...
Currently Being Moderated
Aug 7, 2012 9:58 PM

Everytime a refresh is needed for iCal I keep getting prompted for my Google Calendar Password. Any thoughts?


I have multiple google calendars and I am using the "Delagates" feature.


iCal 6.0, OS X 10.8

OS X Mountain Lion, iCal 6.0
  • emarmite Calculating status...
    Currently Being Moderated
    Aug 9, 2012 1:46 PM (in response to edlsoccer)

    I have this problem too. It's only started in the past few days but now it's affecting all my calendars. I'm seeing the same error as you plus hundreds of copies of:


    8/9/12 1:38:54.237 PM CalendarAgent[660]: Unexpected EOF, returning last token as fallback


    The only way I could make it stop was to disable all delegated calendars and restart the app a couple of times. It's clearly either a bug in Mountain Lion or a Google issue, and I suspect ML: colleagues running 10.8 are experiencing this issue but those still on 10.7 are not.


    I'm curious if Apple and/or Google are tweaking security policies following the Wired hack last week. I'm using two factor authentication, I wonder if anyone without two factor are seeing this issue?

  • rcork Calculating status...
    Currently Being Moderated
    Aug 10, 2012 11:20 AM (in response to emarmite)

    I was having this issue and thought the same thing about 2 factor authentication. However, i have the problem using the old password sytel and the 2 factor authentication. The problem doesn't happen until i try to enable my delegage calendars.

  • rcork Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 10, 2012 11:27 AM (in response to rcork)

    Ok. So after it keeps asking me to re-enter my password in Calendar app, i thought maybe that the attempts were triggering Google to lock the account to protect it from attacks. I went to google and changed my google password, then used that new password in Calendar and its working again. Delegates refreshed and everything working correctly.

  • rcork Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 10, 2012 12:29 PM (in response to edlsoccer)
    1. I was originally using old single factor. Starting getting the prompts to re-enter my password in iCal. Searched online on google groups and found someone saying that they turned on 2 factor authentication and that fixed it. I then turned on 2 factor auth, setup app specific passwords through google's account management site. I then put the new passwords into iCal but it didn't fix it. I then disabled 2 factor authentication. That didn't fix it either. I then changed my google password and put that password into iCal and it worked.
    2. iCal and iOS don't support 2 factor authentication. You have to create app specific passwords through google account management and then use those passwords in OSX and iOS.
    3. I use 1Password to generate all my passwords (i have different passwords for every site). They are over 32 characters long and a mix of numbers, letters and symbols.
    4. In iCal i deleted the Google account and set it back up using the new master password i described in #1
  • alex349 Level 3 Level 3 (635 points)
    Currently Being Moderated
    Aug 10, 2012 2:01 PM (in response to edlsoccer)

    I'm seeing exactly the same thing. The moment I add any Delegate calendars the password prompts begin. This only started last night for me (may be coincidence that I had just changed my password). Nothing I have tried works, so I just hope this is something on Google's end that is fixed with us simply waiting this out. It is annoying, but at least everything being synced means we have other options to access it and issues with Calendar don't compromise the data (and my iOS devices still sync properly without any hitches).

  • LCohen Calculating status...
    Currently Being Moderated
    Aug 12, 2012 10:53 AM (in response to alex349)

    Same problem.  Has someone contacted apple about this?

  • seagullmouse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2012 2:37 PM (in response to edlsoccer)

    Same thing here, annoying. Going back to Google Calendar until Apple fix this!

  • targus Calculating status...
    Currently Being Moderated
    Aug 13, 2012 3:15 AM (in response to edlsoccer)

    Having the exact same problem here. Changing password did nothing.

  • Vic van Dijk Calculating status...
    Currently Being Moderated
    Aug 13, 2012 6:12 AM (in response to edlsoccer)

    I got the password prompt, too and also "error 302". I was not able to sync new events from iCal to Google. I force quit the process "CalendarAgent" using Activity Monitor, and now syncing seems to work. And I haven't seen the password prompt nor error messages yet (though Console is full of errors).

  • targus Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 13, 2012 6:37 AM (in response to Vic van Dijk)

    Quitting calendar agent worked for me as well...

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.