Previous 1 2 3 4 Next 47 Replies Latest reply: Aug 24, 2012 5:52 AM by Gadget Go to original post
  • Gadget Level 1 (25 points)

    Here's another idea. On the SL disk that stopped working, I deleted only the plugin and copied to its place a version I knew was working.  That solved the problem.  So another approach might be to use a TM backup to just copy a version of the plugin before the 2.10 update to the Library/Printers/hp/ PDEs folder (assuming your crash logs show that this plugin is causing the crash).

  • gamechanger Level 1 (0 points)

    Thanks for the 2.9 tip, which worked for me.  Except in Address book.  If I print to any HP printer or to PDF it causes Address Book to crash. Deleting/reinstalling made no difference.  Any ideas?

  • Gadget Level 1 (25 points)

    You'll need to confirm that it's due to the same problem.  Look in Console/User Diagnostic reports for the crash that occurred and see if it points to any particular piece of software.

  • Upton666 Level 1 (0 points)

    I had the same issue with my HP CP1518ni. I ended up deleting the HP  and PPD Contents folders in 'Macintosh HD / Library / Printers' and then copying a 08/07/12 version back from Time Machine.

     

    Copy the required folders from Time Machine first onto your desktop as it will not restore them for you as "they are required by OSX" etc and then manually delete and re-copy in Finder.

  • John Blanchard1 Level 5 (5,230 points)

    Would you be willing to send me the install logs from the Mountain Lion machine that is crashing please? My email is jblancha@mac.com. You could also send a full Apple System Profile (from under the Apple menu). Thank you.

     

  • electrophoto Level 1 (10 points)

    Same problem here with OS 10.8, HP 2.10 Update

     

    Printing from any app to a HP 2300 Business Inkjet crashes the app and nothing gets printed.  Reinstalling the HP 2.10 Update made no difference. 

     

    Solution was to downgrade the hpPostScriptPDE.plugin to the previous version using TM in for following folder:

     

    /Library/Printers/hp/PDEs

     

    HTH

  • stevemcc Level 1 (0 points)

    electrophoto:

     

    That indeed seems to fix the problem....

     

    Thanks,

     

    stevemcc

  • k208709327 Level 1 (0 points)

    Me too. Can't print from any app since the update. Removing the printer and deleting /Library/Printers/hp did not help.

     

    Fixed via sudo rm -rf /Library/Printers/hp/PDEs

  • sdeplater Level 1 (0 points)

    Same solution worked for my HP LaserJet CP4025DN.  At least things work while we wait for a fixed plugin!

  • obscurebug Level 1 (0 points)

    I had a similar problem. Trying to change the presets in the printer popup inside Safari would cause it to crash every time. Restoring /Library/Printers/hp solved the problem. I attempted to configure an equivalent printer on another system, but the software wants to print to the edge on the 2605 with A4 paper, but the printer seems incapable of it.

  • Upton666 Level 1 (0 points)

    In Finder  navigate to  Macintosh HD / Library / Printers / hp / PDEs. Right (control) click on 'hpPostScriptPDE.plugin' and 'Show Package Contents'.

     

    Then open the Contents folder and you will find a plugins folder. DELETE IT and your printer will work.

     

    The old 2.09 version did NOT have this folder and plugin.

  • gamechanger Level 1 (0 points)

    Great job.  This finally worked.  Thank you.

     

    If only HP had tested their update properly....

  • SimonJCarr Level 1 (0 points)

    Thanks! After a few days of frustration, anger and misery I have finally got my 1320nw to work again. I'm very annoyed though that Apple sent out this update without adequately testing it: it has clearly been a widespread problem, and not one that is straightforwards to work out. Poor customer support, and I expect better, to be honest.

  • bfor-5 Level 1 (0 points)

    Thank you so much Upton666 !!!

     

    The solution to delete the plugins folder worked. Didn't even need to restart.

     

    I posted my problem in another section, I will update there.

  • mebyard Level 1 (0 points)

    Thanks Upton666.  This worked great for me on my 27" iMac 2.7 Ghz Core i5.  I'm now printing again to my two LaserJets.  Strangely, the problem did not manifest itself on my MacBook Pro (2.4 Ghz Core i5).  It was able to print, even though it too had the 2.10 Hp drivers update installed via Apple Software update.  I'm leaving it alone, at least for now!  :>)

     

    Regards,

     

    Mark Byard