1 6 7 8 9 10 Previous Next 198 Replies Latest reply: Jul 9, 2014 12:27 PM by Mac.Dee Go to original post
  • 105. Re: iMessage sent from email address rather than phone number...
    AndreIzq Level 1 Level 1 (0 points)

    THIS WORKED FOR ME, IS THE ONLY SOLUTION. I tried other solutions that didn't worked at all, like:

     

    -Changing my wifi's DNS to 8.8.8.8

    -Setting my timezone to automatic

    -Changing my timezone

    -Making a new apple id

    -Updating "my info" with my own contact, and making sure my number was set as "iPhone"

     

    The only thing that worked for me was making a FRESH download of my iOS and making a full restore. I tried restoring my iPhone and it didn't worked, untill a made a new download of the iOS and configured as New iPhone. After that, make a restore from your bakcup.

     

    iMessage and Facetime should work within a few minutes (2 or 3) and none of your data will be lost.

     

    This worked for me on a iPhone 3GS with iOS 5.1.1

  • 106. Re: iMessage sent from email address rather than phone number...
    camilla25 Level 1 Level 1 (0 points)

    There is so much conflicting and oftentimes way out there advice on the internet.

     

    All you need to do is go to Contacts--->find your name in the contacts----> press edit and you will see that only your email is saved into your contacts hence the receiving end getting your iMessages with only your email stamped---->type in your mobile number and save--->

    your problem is now solved and your recipients will see your name and not your email, when you iMessage them

  • 107. Re: iMessage sent from email address rather than phone number...
    cardrome Level 1 Level 1 (0 points)

    Same problem with me. I have toggled iMessage on and of number of times and each time it send an international SMS.last month I paid for 237 intl SMS. Did everything from factory restore to obtaining a fresh sim card. All in vain.

    How did u solved ur issues. Pls share.

  • 108. Re: iMessage sent from email address rather than phone number...
    Patki Level 1 Level 1 (0 points)

    Thanks "moza16" (Page 7)! That helped in the most simplest way! Kept wondering why my carrier was sending me txt msgs saying i dont have enough airtime/credit to send a txt, when i wasnt txtn anyone at all! It made sense when you described and explained about airtime in your answer! Sometimes, things happening behind the scenes that we're unaware of can be frustrating! Thanks again!

  • 109. Re: iMessage sent from email address rather than phone number...
    Patki Level 1 Level 1 (0 points)

    Has it worked for you yet?

  • 110. Re: iMessage sent from email address rather than phone number...
    moza16 Level 1 Level 1 (0 points)

    No need to restore, reboot etc etc. Follow all the procedures I posted on page 7 it should work in no time.

     

    It's IMPORTANT that you have sufficient, not much, but enough airtime in your phone. It's the only way it'll work.

     

    Cheers

  • 111. Re: iMessage sent from email address rather than phone number...
    moza16 Level 1 Level 1 (0 points)

    Glad. Please share

  • 112. Re: iMessage sent from email address rather than phone number...
    Rygel XXV Level 1 Level 1 (0 points)

    First time post- hopefully this actually will be helpful.

     

    Apparently, on the iPhone, you can have the option to use EITHER your phone number OR the email address associated with your Apple ID.

     

    This is my solution to get my phone number showing:

     

    1) On my iPhone, sign out of Apple ID.  Do this by going to (Settings->Messages->Receive At).

     

    2) Tap on your Apple ID (top of the page) if it is highlighted and you will get a number of choices including "Sign Out."

     

    3) Tap "Sign Out."  (Note you can sign back in if you eventually decide you want to use your email address for iMessage.  I did read somewhere in this thread that if your iMessage recipient adds your email address to his/her contacts, then your name will show up.  That could be an alternative solution.)

     

    That did it for me.  Now my iMessage shows up again with my phone number.

     

    Hope that helps!

     

    Now I have to figure out how to do the same thing with Messages on my Mac and iPad...

  • 113. Re: iMessage sent from email address rather than phone number...
    STEVEWISONUSA Level 1 Level 1 (0 points)

    GOOD JOB frankfrommadera

  • 114. Re: iMessage sent from email address rather than phone number...
    Patki Level 1 Level 1 (0 points)

    Hey Moza16...

     

    My cousin just got a new iphone and she's having the same issue.. i followed your steps as per page7 however it doesnt seem to be working for her phone! Is there any other alternative?! plz help.. its driving me mad to fix her phone and it ain't working!!

     

    Thanks

  • 115. Re: iMessage sent from email address rather than phone number...
    moza16 Level 1 Level 1 (0 points)

    Hey Pakti,

     

    assuming the iPhone is factory unlocked and you had sufficient Airtime/credit on it when you tried the process. Yeah?

     

    Well you see mate, it's a standard Apple's procedure to contact your carrier when activating FaceTime/iMessage to use your phone number rather than your Apple ID/email. 

     

    Having say so, that's why the message "Your carrier may charge for SMS messages used to activate FaceTime/iMessage." pops up to get permission from you to use The Airtime/credit I'm talking about. 

     

    So unless your cousin's iPhone is locked and using Gevey it shouldn't work - cause, as you already know, it's only the factory unlocked iPhones that get to use the FaceTime and iMessage features. 

     

    Airtime/credit is the main issue when activating both the features to use your phone number rather than email. 

     

    Try again and give us feedback,

     

    Cheers. 

  • 116. Re: iMessage sent from email address rather than phone number...
    moza16 Level 1 Level 1 (0 points)

    PS - sorry for misspelling your name above.

  • 117. Re: iMessage sent from email address rather than phone number...
    Patki Level 1 Level 1 (0 points)

    Its ok!

     

    Phone came as a gift from Canada and we're based in NZ. She got her phone 'jail-broked' here in NZ! She has lots of credit aswell on her phone! One thing tho, after following your instructions, I didnt get a prompt from her carrier saying "Your carrier may charge for SMS messages used to activate FaceTime/iMessage."!

     

    However, i keep receiving the msgs from her carrier about balance?

  • 118. Re: iMessage sent from email address rather than phone number...
    moza16 Level 1 Level 1 (0 points)

    When it was brought to NZ it didn't work on any of the carriers there till jail broken and unlocked? If correct, odds are it's not factory unlocked meaning nor iMessage or FaceTime will work.

  • 119. Re: iMessage sent from email address rather than phone number...
    Dkcolby Level 1 Level 1 (0 points)

    I finally figured it out. I tried all the things this thread. Suggested. In the window where the Received at 2 addresses. Is click on the apple Id at top. There r 4 options. Choose LOG OUT. Yay that's it

1 6 7 8 9 10 Previous Next