Skip navigation

HT2954: Mac OS X v10.5: Setting up Mail, troubleshooting Mail issues

Learn about Mac OS X v10.5: Setting up Mail, troubleshooting Mail issues

HT2954 Mail keeps losing passwords; what can I do to fix this problem?

856 Views 2 Replies Latest reply: Dec 3, 2012 9:14 AM by Armando Stettner RSS
Steve-n-NJ Calculating status...
Currently Being Moderated
Aug 11, 2012 10:09 AM

Everytime I open Mail, within a few minutes, the program forgets the passwords I have typed into the Preferences for each account. It then starts prompting me to type those passwords in again for each account I have configured. If I open preferences, each of the password fields is blank. Could someone please tell me what is wrong with Mail and causing it to lose those passwords each time the program is run.

 

Thanks, Steve

iMac, OS X Mountain Lion, 27 inch iMac, 16 GB, 2 TB, 10.8
  • MrHoffman Level 6 Level 6 (11,720 points)
    1. Make sure you have a good backup, before proceeding with the following.
    2. Don't confirm the passwords in the fields in Mail.app.  Rather, look in Keychain Access for the passwords, and see if what's listed there is correct.  You can see the cleartext passwords using Keychain Access.
    3. Look for a network error, or a server connectivity issue.  I've seen this exact password-prompting behavior with Mail.app with a marginal WiFi coverage.  If you're on a WiFi, then try a hard-wired connection as a test.
    4. If the previous steps fail to resolve this, then open up Keychain Access, and run a keychain repair pass, and then find and remove any of the password entries related to your mail accounts, then re-enter the passwords over in Mail.app.
  • Armando Stettner Calculating status...

    I, too, have this annoying problem.

     

    I have run repairs on my Keychain until my fingers ache.  Also, this happens whether I'm hardwired or via WiFi.  I had a mid-2011 Macbook Pro and now I have a Macbook Retina and same problem occurs.  All updates are applied.

     

    Furthermore, this happens to different accounts being served by the same server.  I don't believe it is a network error or anything external....

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.