1 2 3 Previous Next 35 Replies Latest reply: May 12, 2014 3:39 PM by Zatixo
JadedEye Level 1 Level 1 (25 points)

Up until yesterday, my upgrade to Mountain Lion had been completely smooth.  Today when I launch mail, it crashes consistently on thread 0.  So I did the Windows rule of rebooting first off.  no joy

 

 

I tried restoring the app via Time Machine and it crashes as well so the problem cause remains unknown.

 

I have tried this with iCloud sync both on and off and also tried resetting sync services since this used to be a fix in the old days with Lion and Snow Leopard although I think it no longer applies with iCloud. 

 

I've also tried removing the envelope index files and even all the plist files but the app does not launch long enough or far enough to get there.

 

I've also done a Repair disk permissions and while it found tons of faults, mostly in the printers area, this did not resolve the issue.

 

At this point, Mail is unusable which is a major pain in the ***.  if anyone has solutions, I'd appreciate hearing.

 

Ross


Mac Pro, Mac OS X (10.7.4)
  • 1. Re: Mail.app crashes on launch consistently
    hpr3 Level 5 Level 5 (5,710 points)

    Try starting up in Safe Mode. Then Restart.http://support.apple.com/kb/HT1455

  • 2. Re: Mail.app crashes on launch consistently
    Funkey Monkey Level 1 Level 1 (0 points)

    I'm having the same problem as JadedEye.   Mail.app worked just fine yesterday, but now I can't get it to launch.

     

    I've tried your suggestion, hpr3, to use Safe Mode.   No luck.

     

    Other things I've tried:

     

    1. Using recovery partition, repaired disk - no problems

    2. Using recovery partition, repaired permissions - nothing that looked as if it were related.

    3. Tried restoring Mail.app through Time Machine

    4. Tried restoring entire ~/Library/Mail folder from yesterday

    5. Tried deleting Mail Envelope files

    6. Tried removing entire ~/Library/Mail and ~/Library/Mail Downloads folders

    7. Tried deleting preferences files -- only one I found was com.apple.mail.plist.lockfile

     

    NONE of these things has made any difference.  I would re-install Mail.app, if I could find an installer package anywhere.

     

    I've copied the header and footer of the crash report below:

    Process:         Mail [632]

    Path:            /Applications/Mail.app/Contents/MacOS/Mail

    Identifier:      com.apple.mail

    Version:         6.0 (1485)

    Build Info:      Mail-1485000000000000~3

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [245]

    User ID:         501

     

     

    Date/Time:       2012-08-01 19:44:01.482 -0400

    OS Version:      Mac OS X 10.8 (12A269)

    Report Version:  10

     

     

    Interval Since Last Report:          331251 sec

    Crashes Since Last Report:           17

    Per-App Interval Since Last Report:  276196 sec

    Per-App Crashes Since Last Report:   15

    Anonymous UUID:                      FCE49931-23F4-4817-A753-154DA076FBDB

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

     

     

    VM Regions Near 0:

    -->

        __TEXT                 00000001094da000-0000000109877000 [ 3700K] r-x/rwx SM=COW  /Applications/Mail.app/Contents/MacOS/Mail

     

     

     

     

    TOTAL                             394.2M

     

     

    Model: iMac7,1, BootROM IM71.007A.B03, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.21f4

    Graphics: ATI Radeon HD 2600 Pro, ATI,RadeonHD2600, PCIe, 256 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3636374731

    Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3636374731

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (5.10.131.36.16)

    Bluetooth: Version 4.0.9f8 10405, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Ethernet, Ethernet, en0

    Serial ATA Device: WDC WD30EZRX-00MMMB0, 3 TB

    Parallel ATA Device: MATSHITADVD-R   UJ-85J

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0606, 0xfa400000 / 3

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0606, 0xfa410000 / 4

    USB Device: MP560 series, 0x04a9  (Canon Inc.), 0x173e, 0xfa413000 / 8

    USB Device: C-Media USB Headphone Set, 0x0d8c  (C-MEDIA ELECTRONICS INC.), 0x000c, 0xfa412000 / 7

    USB Device: USB to ATA/ATAPI Bridge, 0x152d  (JMicron Technology Corp.), 0x2352, 0xfa411000 / 6

    USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfa200000 / 2

    USB Device: Apple Keyboard, apple_vendor_id, 0x0220, 0xfa220000 / 5

    USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd400000 / 2

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8206, 0x1a100000 / 2

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x5d100000 / 2

  • 3. Re: Mail.app crashes on launch consistently
    ggirol Level 1 Level 1 (0 points)

    I having  similar issue since upgrading to OS 10.8. My Mail.app launches but within a minute I get the beachball of death and the application freezes and so does the entire machine. After several attempts to kill the app using command + option + escape the force quit dialog finally comes up and I can kill the app and the machine becomes responsive again. I have downloaded Thunderbird for use until this issue is resolved, hopefully with 10.8.1. I am using IMAP so I have access to al my messages.

  • 4. Re: Mail.app crashes on launch consistently
    cozar Level 2 Level 2 (340 points)

    Could be caused by a rotten mail message

    http://support.apple.com/kb/TS4066

  • 5. Re: Mail.app crashes on launch consistently
    Norman Daniel Level 1 Level 1 (0 points)

    Already tryed, dosent work

  • 6. Re: Mail.app crashes on launch consistently
    David Mccollum1 Level 1 Level 1 (0 points)

    Same problem. Apple support didn't know what to do except they said to reinstall Mountain Lion. Tried that, didn't work. Now I'm going to see if i can do an archive and reinstall. Evenif that does work, it seems that there is a problem that may reoccur at any time.

    Curious thing that if I logged in as a different user, it did come up to a screen asking me to establish an account, so there has to be some incompatibility with whatever is in my user folder.

  • 7. Re: Mail.app crashes on launch consistently
    Norman Daniel Level 1 Level 1 (0 points)

    I already did a clean reinstall and still dosent work, but the webcam got fixed, it was wasnt working before

  • 8. Re: Mail.app crashes on launch consistently
    David Mccollum1 Level 1 Level 1 (0 points)

    I fixed it! I went to ~/Library/Containers. There I removed the entire com.apple.mail folder to the trash, emptied the trash and rebooted. Mail opened just fine and started populating with all my email. So, I'm back in business. I did make a copy of the file on an external USB thumb drive just in case, but it looks like I won't need that.

     

    Good luck.

  • 9. Re: Mail.app crashes on launch consistently
    Norman Daniel Level 1 Level 1 (0 points)

    It is not working either, still mail and "mail, contact & calendar" under system preferences are closing unexpectedly.

     

    It is something about the Library folder, but not sure what

  • 10. Re: Mail.app crashes on launch consistently
    Norman Daniel Level 1 Level 1 (0 points)

    I got it !!

     

    You guys need to delete the folowing files from the Library folder

     

    - com.apple.AddressBook

    - AddressBook-v22.abcddb

    - com.apple.preferencepanes.cache

     

    Good luck !

  • 11. Re: Mail.app crashes on launch consistently
    bbendorf Level 1 Level 1 (0 points)

    Funny how Apple deleted my posts when i called it a bug. Everyone I know is having problems with mail! I even posted crash log. MAIL DOES NOT WORK ON Mountain Lion for most users.

     

    I tried fix abaove still crash.

     

    I have a Simple fix. Don't Use Apple Mail!!! Use MS Outlook works like a charm!!

     

    Called Apple Tech support. They had me reinstall everything. Sorta like going to get your flat tire repaird and tey say just buy a new car that will fix it. Worthless call don't bother.

     

    Went to local Apple store they were awsome but could not fix it.

     

    So it is up to the users here to come up with the fix. When Steve Jobs was around he would never release a rev without mail working.. Wow do I miss him!! he really used this stuff.

     

    Please post any fixes you find thanks for all the USERS support. Seem to be more knowledgable then
    Apple,

  • 12. Re: Mail.app crashes on launch consistently
    Funkey Monkey Level 1 Level 1 (0 points)

    David's advice worked like a charm for me.   I just got back from a 10 day vacation -- I was hoping Apple would've released an update or fix for this while I was gone, but David solved my problem.   Thanks.

     

    David Mccollum1 wrote:

     

    I fixed it! I went to ~/Library/Containers. There I removed the entire com.apple.mail folder to the trash, emptied the trash and rebooted. Mail opened just fine and started populating with all my email. So, I'm back in business. I did make a copy of the file on an external USB thumb drive just in case, but it looks like I won't need that.

     

    Good luck.

  • 13. Re: Mail.app crashes on launch consistently
    ggirol Level 1 Level 1 (0 points)

    Did not work for me, and as far as this being caused by a "funky" message, Thunderbird is having no problem with the same messages.

  • 14. Re: Mail.app crashes on launch consistently
    David Mccollum1 Level 1 Level 1 (0 points)

    Obviously some combination of events seems to be triggering this, Hopefully all the crash reports that get sent to Apple will give them a clue how to fix it.

     

    I get odd behavior in some other programs, too, but nothing that really interferes with my work. I guess like all the other major updates version X.0 needs some work. Since everyone was saying that ML is a much more stable OS than Lion was, I was hoping not to have to deal with early adopter woes.

1 2 3 Previous Next