Skip navigation

Unsupported Video Format in Aperture 3.2.2 - flummoxed

2389 Views 14 Replies Latest reply: Mar 30, 2014 2:34 AM by abugy RSS
Neil Duncan Calculating status...
Currently Being Moderated
Jan 18, 2012 10:19 AM

Hi all,

 

I am having an issue playing video imported into Aperture 3.2.2 from my iphone (or any device). I'm running Lion 10.7.2. The files seem to import into Aperture fine either directly from the iphone or from a folder on the hard drive, but once in Aperture, they cannot be played. I can, however, right click the file in Aperture and open it in Quicktime. The same issue exists from .avi formats generated by my slr.

 

I've tried the solutions regarding uninstalling Divx and 3vix components from Quicktime as per this discussion:

https://discussions.apple.com/message/15714152#15714152

...and even removed all other components in the Quicktime library in my troubleshooting efforts, to no avail.

 

And I've tried the suggestions regarding importing and moving files to the personal directory, then importing into Aperture as per this discussion:

https://discussions.apple.com/message/17138620#17138620

...also to no avail.

 

I've tried repairing permissions. Launching Aperture in a different user account and creating a new library also did not work. I'm flummoxed. Anyone have any ideas?

  • léonie Level 8 Level 8 (46,405 points)

    Hello Neil,

    is your video format supported by Aperture? Have you checked this list?

    Aperture 3: About Video and Audio formats in Aperture: http://support.apple.com/kb/HT4025

     

    Regards

    Léonie

     

    P.S.: Have you tried to repair your Library (option+command while double clicking on the Aperture library), not just to repair your permissions?

     

    Message was edited by: leonieDF  added: repair library

  • léonie Level 8 Level 8 (46,405 points)

    S0334_Refimgnotfound.pngS0341_LowRes.png

    Which of the above icons do you see on your videos? The left on? That means, that the referenced master cannot be found. You might try to reconnect the video, I am not sure if reconnecting will work on videos, I only ever tried this for images however.

     

    Select the video that you cannot play, ctrl-click the video in the Browser and select "Locate Referenced Files". If you are lucky, you will see a file chooser, then point Aperture to the location of your video and select "reconnect".

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,405 points)

    O.k. the icon on the right means: "Because of low image resolution, the image’s print quality may be affected. This badge appears on images placed in book pages and webpages."

    That is a funny warning in case of a video. I assume it means in this case, the video quality is poor.

     

    You may try some diagnostics:

    • Whenever you import, make sure the Console.app (Allications -> Utilities) is running, so that you see diagnostic messages, if errors occur.
    • Have you tried to create a new, empty Aperture library and to import your videos into that library (to see, if your library may be corrupted)?
    • Have you tried importing from your iPhone using a different account, to see, if settings n your account may be problematic?
  • shuttersp33d Level 4 Level 4 (1,540 points)

    Do you happen to have a Flip camera? You may have a video codec (3ivx) that is know to cause some issues in Aperture.

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Oh, forget it. Just saw you looked at that already...

  • léonie Level 8 Level 8 (46,405 points)

    That kind of crash occasionally occurs, when no video previews can be generated, because of a broken or unsupported video format.

     

    Are you sure, all your videos really are o.k. and can be viewed in Quicktime?

    If you are sure, then you might try to stop launching the preview agent:

     

    Quit Aperture. Launch the Terminal.app and type the following command:

     

         launchctl unload /System/Library/LaunchAgents/com.apple.quicklook.plist

     

    Then relaunch Aperture and try again.

  • léonie Level 8 Level 8 (46,405 points)

    Hello Neil,

    thank you for letting us know, that a reinstall could solve that problem.

    But since you are worried, because you do not know what caused the problem, you might look thru the other log files for crash reports  - use the console window for a quick access to the log files.

    Then compare if there is a common pattern in the crash reports of Aperture, Mail, and Safari: Same framework crashing? Same kind of Error message?

     

    Regards

    Léonie

  • lcooperd Level 1 Level 1 (5 points)

    Hi Neil,

     

    Did you ever find a solution to this problem? It has happened to me recently and my entire library is riddled with these icons! I would love to hear from you if you fixed it.

     

    Many thanks,

    Lewis

  • bazone Calculating status...

    me too!! .. i just did a clean install of mountain lion hoping it would resolve this issue in my aperture library (restored via time machine) but the same "unsupported video format" problem exists! ... they play in quick time but it ***** that they don't play in Aperture

  • abugy Calculating status...

    I got the same trouble and didn't find a solution in 15 minutes in the internet. Yet I've found a workaround which could probably work under exact conditions hence don't blame me for that.

     

    Source conditions:

    - Mavericks,

    - Aperture 3.5.1.

    - All the photos and videos are made by iPhone 5, all videos can be opened in the import without any additional questions by Quick time player.

    - All of them were sometime ago imported from iPhone in Win7 and stored on an NTFS formatted USB drive.

     

    The solution: copy files to your local HDD and import from this location. Haven't tried to copy to another native for Mac HDD on USB/Firewire/Net yet it seems to me that it should work.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.