Skip navigation

how do I downgrade safari 6 to 5.1.7 in Lion?

21005 Views 24 Replies Latest reply: Dec 18, 2013 1:31 PM by Bobdc6 RSS
1 2 Previous Next
James Wall1 Level 1 Level 1 (15 points)
Currently Being Moderated
Aug 7, 2012 2:31 PM

I installed Safari 6 in Lion more or less by accident. I didn't notice it in Software Update, I guess that's my bad. I really hate Safari 6, If it does load or render faster then it's not fast enough for me to notice and it is full of quirks and bugs. The tabs thing is annoying and I don't like the magic uni-bar type anything here.

 

I found 5.1.7 online but can't figure out how to delete Safari 6. I could go in and do it the Unix way but that may break dependencies.

 

Any advice would be most apprecieated.

MacBook Pro, Mac OS X (10.7.2)
  • aurelien.aries Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2012 3:56 AM (in response to James Wall1)

    I have the same question.

     

    I have the pkg but it doesn't want to install because I have a 'more recent version already installed'.

     

    Any help ?

     

    thx

  • ASmit010 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 10, 2012 4:04 PM (in response to James Wall1)

    Hi there!

     

    I find this topic via google because I got fed up with Safari 6 for these reasons:

    - It's buggy

    - I don't like the change in tabs

    - I cant open certain links, like my favourite vacuum tube forum for example

    - Sometimes I can't scroll on a page

    - I use google to Google, not the address bar

     

    Because I figured there would not be an answer on Google yet I started messing around myself, this is what I did to downgrade Safari:

     

    I Downloaded Safari 5.1.7 from here: http://appldnld.apple.com/Safari5/041-5467.20120509.F6PPX/Safari5.1.7LionManual. dmg, http://mac.softpedia.com/dyn-postdownload.php?p=25616&t=0&i=1

     

    I opened Terminal.app and became root:

    sudo su -

     

    I figured removing Safari would be a good start

    rm -rf /Applications/Safari

     

    The installer still complained about a newer version of Safari being installed, so I did a little find command to see if there would be more files that need to be deleted:

     

    find / | grep Safari | grep -v Users

     

    - I removed these directories:

    #rm -rf rm -rf /System/Library/Automator/Get Current Webpage from Safari.action

    #rm -rf /System/Library/SyncServices/AutoRegistration/Schemas/com.apple.Safari.syncsche ma

    rm -rf /System/Library/StagedFrameworks/Safari

    rm -rf /System/Library/PrivateFrameworks/Safari.framework

    #rm -rf /System/Library/Automator/Get Feeds from Safari.action

    exit

     

    After removing these directories I was able to use the 5.1.7 installer and I am now writing this to you hapely in Safari 5.1.7

     

    I didn't test if all these directories should be removed, I just removed these and then tried the installer again and it worked. I guess not all these directories have to be removed, the ones I assume do not have to be deleted are commented out.

  • smarachi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 12:36 PM (in response to ASmit010)

    This worked for me, except the Safar 5.1.7 download, which I did find available to download at SoftPedia.com

    Loving being back on Safari 5!

     

    Seriously concerned that Apple's been sucking & regressing on usability with each recent release!

     

    Thanks for helping me restore the sensible version.

  • zelmoe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 1:39 PM (in response to James Wall1)

    Safari 6.0 is absolute poop-poop, what are these people thinking, it's a black mark boys and girls. I mindlessly install it this morning at software updates request, and oh my God. Why did install change all my settings? Where is my search window, explain why I can't open sites that open yesterday. I'm not experienced enough to go into terminal and start rewriting the **** software! Embarrassment, thankful I have Windows 7 and Exploier running on the same machine in an emulator. Well migrate back to Firefox tomorrow. If you know anyone else in the Mac brotherhood warned them quickly! Thank you "apple" (case by design) morons (scr_w you if you think I'm politically incorect, oh you're right morons are smarter!)

  • aurelien.aries Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2012 3:38 AM (in response to ASmit010)

    Work for me, thanks.

     

    I had to replace rm -rf /Applications/Safari by rm -rf /Applications/Safari.app

     

    Also I did delete all the folders you mention manually

     

    back to 5.1.7, feel good

  • Thomas Bolingbroke Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 12, 2012 11:37 AM (in response to James Wall1)

    I used RSS feeds in 5.1.7 and it was a convenient way of managing my news, etc. I don't like being dumpted into mail everytime I try and open a feed. (I've got a bookmark folder full of them).

     

    I'm going to try the suggested downgrade and will remember to stop being such an early adopter in the future. Makes me wary of Mountain Lion. Not that there are any major faults/bugs but there will be many subtle changes not to my liking. Will wait a while.

  • Yves M Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 13, 2012 6:29 AM (in response to aurelien.aries)

    When I wrote the command :

     

         rm -rf /Applications/Safari.app

     

    in Terminal, not only was Safari deleted, but all my other applications began to disappear also, as I saw them being deleted one by one in my open Applications folder.

     

    What in the world did I do wrong ?

     

    What if I wrote an extra space after the first "/"  ( rm -rf / Applications/Safari.app )  ?

     

    Or, did this happen because my Applications folder was open ?

     

    Absolute mystery to me !

     

    Lucky I had a fresh Carbon Copy Cloner backup on hand. I got everything back to work in a mere 20 minutes.

     

    Anyone has a clue ? Because I would really like to reinstall Safari 5.1.7 in my Lion partition.

     

     

    YM

     


    iMac, OS X Mountain Lion, Core i7, SSD, 12 GB Ram.
  • Peter Moraca Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 13, 2012 6:39 AM (in response to Yves M)

    I used AppDelete to archive and then uninstall Safari 6.  Download 5.17 from Cnet.  Open the 5.17 installer with Pacifist.  Highlight the directory and click install.  I answered yes to all of the questions regarding overwriting duplicate files.  I then repaired permissions and rebooted (not sure if the reboot was needed).  All is well, I am typing this reply in Safari 5.17 on OS 10.8.

  • ASmit010 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 13, 2012 6:46 AM (in response to Yves M)

    Hi Yves,

     

    That's strange, did you copy/paste the command or did you write it over? If you did do a 'rm -rf /' then I can understand why all your applications got removed since you basicly where removing everything in your filesystem.

     

    Please try this to remove the new Safari from your system, just selected the lines between the ###'s and copy/paste them into a terminal:

     

    First make sure you have downloaded the old Safari (5.1.7) !!

     

    ###

    sudo rm -rf /Applications/Safari.app

    sudo rm -rf /System/Library/StagedFrameworks/Safari

    sudo rm -rf /System/Library/PrivateFrameworks/Safari.framework

    ###

     

    Now go and mount the Safari 5.1.7 installer dmg, install Safari and you should be back on track with Safari 5.1.7 installed on your Mac.

     

    Regards,

    Anthonie

  • Yves M Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 13, 2012 7:38 AM (in response to ASmit010)

    Anthonie, THANKS !

     

    My UPGRADING from Safari 6.0 to Safari 5.1.7 went flawless.

     

    Now, I have :

     

    - My separate Search bar back

    - My RSS's are back to work

    - My Top Sites refresh and, again, show their update Stars !

    - The possibility to change fonts and appearance again.

    - And what more !

     

    AND, most important : my firm conviction that from now on, before upgrading any Apple software, one must ask oneself  "What are we going to lose, this time ?" !!!

     

    Thanks again !

     

     

    YM

     

    Happily replying from my fresh new LION Safari 5.1.7 (that, unfortunately, can't be installed in Mountain Lion). And hoping that Apple will soon upgrade their common sense brainware.

  • Thomas Bolingbroke Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 13, 2012 8:19 AM (in response to ASmit010)

    Anthonie

    I'll add my thanks. Just one tip for others doing the same, copy each line between the ###s individualy and past into terminal. After the first line you'll get a password prompt (Your admin password).

     

    I tried to paste all three lines in one go, and that didn't work. After entering my password it all worked perfectly.

     

    To bad about deferring Mountain Lion until (if) Apple fixes Safari. But I didn't see that much, even for $20, that affects me. Maybe I'll try Crome or Firefox.

  • Sasparilla256 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 28, 2012 10:44 AM (in response to James Wall1)

    Just as an FYI, the v6 install process actually backs up v5.1.7 to be used with an uninstaller (which Apple didn't release for production v6).  However, Apple did release an uninstaller for the v6 beta (safari_6_developer_preview_2_for_lion_uninstaller.dmg was the most recent one) and it appears to work just fine (tested it on mine) rolling back production v6 installs on Lion back to v5.1.7.

     

    It requires some digging around online to find it (http://steevepatrick.com/), but would appear to be an option for those that don't want to hop into terminal.

     

    Best of luck to everyone wanting to roll back to v5.  One thing that is important for folks to keep in mind, v6 did have a bunch of security holes fixed in it that our v5 rollbacks won't have.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.