1 2 Previous Next 15 Replies Latest reply: Aug 14, 2012 7:01 AM by Winston Churchill Go to original post
  • 15. Re: updating contacts
    Winston Churchill Level 10 Level 10 (81,980 points)

    Then unfortunately you can't use iCloud with your Mac, iCloud requires 10.7.2 or better.

     

    10.6.8 isn't the highest for intel, but it might be the highest for your Mac, have you tried updating to Mountain Lion (10.8)

1 2 Previous Next