Skip navigation

IMessage won't activate my phone number

167871 Views 96 Replies Latest reply: Jan 15, 2014 11:39 AM by Radiotron RSS
  • Kliffy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 2:20 PM (in response to allanes5)

    Same problem here tried everything

  • diehummel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 11:50 PM (in response to Kliffy)

    also same Problem.

     

    4S (5.1.1) iMessage and Facetimme won't activate the Phonenumber any more.
    Apple ID is working.

     

    On my Iphone 4 with iOS  6 Beta 3 its working and does activate (but with a different sim card/provider)

  • Kliffy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 6:34 PM (in response to diehummel)

    Problem solved! If you have premium sms service deactivated enable it by calling the operator. And wait 24h then enable Facetime and Imessage and it should work again like charm!

  • mizanini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2012 10:04 PM (in response to Kelsey12)

    I have tried everything!!!!!

     

    I've been here for hours restoring, switching things on and off, etc, etc. At one point, iMessage didn't even work from my email. Now, it's back to my email and stuck "verifying" my phone number, leaving that option grayed out.

     

    I am in Canada for the week, do you think that has anything to do with it? It was working with my phone number just fine yesterday and up until a few hours ago.

     

    HELP!!! Please!!!!

  • mizanini Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2012 10:04 PM (in response to mizanini)

    P.S. I am with Verizon

  • chcn Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 14, 2012 10:34 AM (in response to mizanini)

    mizanini wrote:

     

    ...  I am in Canada for the week, do you think that has anything to do with it? ...

     

    It might. As explained previously, in North America Facetime and iMessage activation works by sending a text message to a special SMS short code. I think this short code may be different for different carriers, or at least in different countries. The carrier with whom you are roaming in Canada (likely one of Rogers, Bell, or Telus) may not be passing on that message correctly. If it worked for you before with Verizon, then when you reattempt to activate upon your return to the US it will probably work.

     

    I don't know why Apple chose to do it this way, as not all carriers allow short codes, and, as you've noticed, short codes may not work between carriers and between countries. I think in Europe the iPhone simply sends a regular SMS to a properly-formatted international phone number. This may have the drawback of incurring an international text message charge (only when activating), but it is probably more reliable.

  • tungddao Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2012 8:42 AM (in response to Kelsey12)

    It's simply!

    Turn on iMessage then make a phone call to : 011+445773142076

                 With Facetime & Siri: 011+447786205094

  • Escuintle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2012 8:09 AM (in response to allanes5)

    After reading a lot on the net, updating my iOS to latest version and spend a lot of money in SMSs I have came to the conclusion that this is a Movistar issue. It looks like they do not support silent SMS messages. I have also found that this happens in several countries. Also if you call tech support they say non-sense, they believe they know what they are talking about and they try to convince you.

     

    It looks like I will have to wait until they decide to let us enable it.

  • mel138 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 9:25 PM (in response to Kelsey12)

    I had my iMessage on my phone set up to use my phone number. Then I tried to connect my ipad to iMessage but it could only use my email, and it changed my phone to using my email too. I couldn't change my phone back to activating with my phone number. I found out how to to fix it though:

    I had to go on my iPad and log out of iMessage with my apple ID, then logout on my phone too. Then I was able to log back in with my phone and use my phone number, but I can't use iMessage on my ipad without both going back to email.

  • Cryak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 8:34 PM (in response to Kelsey12)

    Hey all.

     

    I turned off buth iMessage and Facetime, tried the two numbers quoted by tungddao, got a 'not connected' voicemessage both times, turned on both iMessage and Facetime, waited a couple of minutes and BANG, both activated after hours of frustration and effort, including a hard re-start.

    Had to power cycle the phone to initiate iMessage, but all back in the blue.....

     

    Thanks for the wierd solution tungddao.  Got to say your the man.......(or woman, as the case may be)

  • nilesh73 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 10:22 PM (in response to Kelsey12)

    i have solved this issue by restoring to ios 6.1.3 to my iphone 4s.

    i tried every steps on this forum and google.  then i found a way to activate imessage and facetime with following steps.

    step 1: backup your device to itunes.

    step 2: fresh restore your device with latest firmware.

    step 3: while activating your device do not sign with your apple id-skip it.

    step 4: let it activate your phone number first. start using iphone.

    step 5: imessage and facetime will activate to your phone number.

    step 6: restore you backup and you will see your phone number and apple id activated to imessage and facetime.

     

    hope this will solve your problem.

  • chiptopha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2013 10:36 PM (in response to nilesh73)

    hey i have had the same proble, what to do step 3 and 4?

  • Leah3999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2013 7:10 PM (in response to Antman1984)

    Well looks like many people have the same issue. This has happened to me before. Couple weeks ago. What I did was make sure my date & time was accurate but ever since yesterday.. My imessage wouldnt let me use my number on my iPhone. I really have tried everything & im getting really annoyed & dont know what to do. If anyone, please find a solution.

  • Leah3999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2013 7:24 PM (in response to Leah3999)

    OMG! I called that weird number and my imessage is working! Your awesome. Omg thank you! I highly suggest you call the number tungddao suggested. It actually worked.

  • Justinb51 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 8:00 PM (in response to Kelsey12)

    I was skeptical that calling the number tungddao listed would work.

     

    However after hours of messing with my phone trying to get it to let me activate my phone number with no luck I went ahead and called the number. It made a strange noise after connecting, so I hung up. Went in to settings and my number was check marked and activated.

     

    Thanks tungddao!!!

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.