Skip navigation

NetBoot won't serve more than SEVEN clients at a time

1170 Views 2 Replies Latest reply: Aug 15, 2012 10:37 PM by Ellsworth Chou RSS
Ellsworth Chou Level 1 Level 1 (135 points)
Currently Being Moderated
Aug 12, 2012 7:45 PM

I'm running OS X Server 10.5.8 to configure a lab via DeployStudio. There have been no changes to the server or network since configuring it for the same purpose in 2009.

 

But when using the current version of DeployStudio (1.0rc133) to restore 10.7.4 to client workstations (iMac 12,1), only seven (7) at a time will successfully NetBoot. Any remaining clients give up NetBooting after a few minutes and boot to internal hard drives (regardless of whether booting with "N" key, "option" key selection of NetBoot volume, or setting NetBoot volume in Startup Disk).

 

CLUE: If I interrupt any of the seven currently NetBooted iMacs while they are restoring via DeployStudio (by powering them off), any other machines on the network already attempting to NetBoot will be successful, up to the maximum number of seven. Left to run, seven DeployStudio sessions complete successfully.

 

The past two times I've done network restoration of Mac labs (with NetRestore in 2006 and DeployStudio in 2009), I did not encounter this behavior.

 

Among other things, I've tried restarting NetBoot service and the whole G4 Server. I tried switching from the external DHCP server to OS X Server's "DHCP server" service. Tried this "Reset NetBoot" suggestion:

 

. . . no change in symptoms at all.

 

Suggestions?

 

Same as 2009 (when it worked successfully):

  • OS X Server 10.5.8
  • PowerMac G4 Dual 1.0 GHz
  • Network hardware and topology
  • DHCP server is via simple hardware router, and NOT from OS X Server
  • NetBoot images in default directory for OS X Server
  • DeployStudio images are served via AFP on same G4 Server

Differences from 2009:

  • New client workstations: iMac12,1
    • (Old workstations iMac 8,1)
  • DeployStudio current build
    • (rather than build in 2009)
  • DeployStudio Client Master Images are OS 10.7.4
    • (vs. 10.5.8 on iMac 8,1)
  • NetBoot images (build by DeployStudio Assistant) from iMac 12,1 running 10.7.4
    • (vs. 10.5.8 on iMac 8,1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.