Skip navigation

mountain lion enable require password after sleep or screen saver begins?

7699 Views 28 Replies Latest reply: Mar 5, 2013 11:35 PM by a4444 RSS
1 2 Previous Next
chief quimbie Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 3, 2012 12:06 PM

after upgrading to mountain lion, I cannot enable require password after sleep or screen saver begins. I can see the feature but unable to click it or anything. Anyone have a solution for this?

MacBook Pro (15-inch Early 2011), OS X Mountain Lion
  • DThiot Calculating status...

    Unfortunately, I don't remember exactly where this was enabled on Lion or Snow Leopard but look in:

    System Preferences --> Security & Privacy --> Require password after sleep or screen saver begins

  • Shootist007 Level 6 Level 6 (16,640 points)

    Click the Lock icon on the bottom of that page and type in your password.

     

    EDIT:

     

    Although that option is available without unlocking the lock icon on my system.

     

    Not sure where to go from here.

  • DThiot Level 1 Level 1 (0 points)

    OK, chief...  This is a pretty obvious question.  Sorry in advance.  Does your user have a password set already?  This is my Security and Privacy form - http://screencast.com/t/VDFsruAly.  I use this feature.  I have it setup in Energy Saver to sleep as well as Hot Corners (Desktop & Screen Saver - Desktop).  Is that all the same for you?  I am running Mountain Lion on a MacBook Pro 13 (Mid 2009).

  • Courcoul Level 6 Level 6 (11,150 points)

    Something that may be obvious, but... are you doing this using a user account with Admin privileges?

  • Courcoul Level 6 Level 6 (11,150 points)

    chief quimbie wrote:

     

    Courcoul, I had admin privileges prior to upgrading, so I would like to say yes unless something small changed.

    No idea what ails your cat, but over here my ML testbench works just fine. Once the "padlock" gets opened by proper authentication, all options are enabled:

     

    SecPriv.jpg

    And it works perfectly, I might add.

  • Courcoul Level 6 Level 6 (11,150 points)

    This sounds suspiciously like a preference file gone bad. Sorry that I don't have the time right now to sleuth which .plist is guilty, but I have a hunch that purging the correct one and having the system rebuild it should cure the issue.

  • anouak Calculating status...

    Hi chief quimbie,

     

    this would not help you at all but I can tell you I have the same problem. So I perfectly understand your concern but do not have any solution as of yet. Even more, I do not have the "Disable automatic login" option that can be seen in your screenshot. Also, in Desktop & Screensaver I would not be able to specify the time when the screensaver should start. This menue is grayed out as the menue in the "Require password" section. In User Accounts under the login options I do have the option "Automatic login". But also here the menue is grayed out.

     

    The only solution I can think of is to clear the harddisk, install Mountain Lion from scratch and use the migration assistent together with my Time Machine Backup to bring my data back in. This certainly will be a pain in the *** since I am not sure if all my unix tools (LaTeX, gpg and others) will be transferred. But if there is no other solution to that problem -- and up to know I did not find any. Even you last post is 9 days old -- I do not see any chance.

     

    I deleted some .plist files but unfortunately to no avail.

     

    Did you find any other solution to your problem?

     

    Bildschirmfoto 2012-08-28 um 16.01.24.png

    Bildschirmfoto 2012-08-28 um 16.07.36.png

    Bildschirmfoto 2012-08-30 um 10.38.17.png

  • anouak Level 1 Level 1 (0 points)

    Thank you for your offer. I now did a clean install of Mountain Lion and just migrated my user data. However, I believe that something is not OK on Apple side regarding these problems. And some questions arise:

     

    • Did you reset the Parameter-RAM (Cmd-Option-P-R during startup)?
    • Is your partition encrypted?

     

    The reason I ask this is that it took me quite some effort to reinstall a freshly new system. I alwas received a message telling me "A problem occured during installation. Try new" without any indication where the "problem" should be. I tried to start from various startup disks, I reformatted the drive entirely with no result. Only the reset of the Parameter RAM finally let me install Mountain Lion.

     

    However, I still do not see a proper Security Pane (General). "Disable auto login" is still missing (a tribute to the encrypted disk?) and the check box is missing for the "Require password" bit and it looks kind of distorted.

     

    But generally speaking it now works properly at least although I am not really convinced that ML is mature for release. They should have waited for a vetsion what we will receive as 10.8.2.

  • PapaiMAC Calculating status...

    I am having exactly the same issue. My IT guy, on same Macbook Pro, logged in as his admin user account DOES NOT HAVE SAME ISSUE....

     

    This is a really odd issue and a big PIA. Anyone find a solution yet!!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.