Skip navigation

iTunes 10.6.1 STILL won't play videos on Win7 64-bit

21913 Views 24 Replies Latest reply: Nov 11, 2012 8:07 PM by DDownes RSS
  • slprescott Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 5:30 AM (in response to scmibis)

    scmbis,

     

    Thank you for this thread -- I had an identical problem and followed your trail of workarounds.

     

    Last night I was able to solve the problem by following Apple's instructions here: http://support.apple.com/kb/HT1925

     

    Like you, I found that running in Safe Mode was a successful workaround, but I didn't want to do that all the time.  Like you, I looked for addins but didn't find any (except the Mozilla ones that probably didn't affect me since I don't run Mozilla).

     

    Two important facts from the instructions above:

    • Uninsntall six pieces of software, not just iTunes
    • Uninstall them in a specific order

     

    Here's my recap of the instructions:

     

    A. Uninstall six programs

    1. iTunes
    2. Quick Time
    3. Apple Software Update
    4. Apple Mobile Device Support
    5. Bonjour
    6. Apple Application Support

     

    B. Use Windows Explorer to validate that all remnants of these programs are actually gone

     

    C. Re-install iTunes.  (It doesn't mention re-installing the other 5 products; maybe that happens automatically as a result of the iTunes intall?)

     

    This worked for me.  After the install I was immediately able to see (in Windows) movies that I had purchased from iTunes.

  • Blue5 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 18, 2012 12:31 AM (in response to scmibis)

    I've just done this and it STILL isn't working.  It's horribly jerky (if it starts at all).  Works fine when played directly through Quicktime or when streamed to an iPad/Macbook through home sharing.  Anyone have any ideas?

  • priapus_ Calculating status...
    Currently Being Moderated
    Aug 21, 2012 1:03 PM (in response to Blue5)

    I had the same problem.  The issue ended up being that I was trying to listen through a headset and it would not play the movie until I switched to playing through the computer speakers.  It took hours to figure that out, and I'm still confused by the fix but at least now I can finally watch this season of Breaking Bad....yay.

  • DaveInMelbourne Calculating status...
    Currently Being Moderated
    Sep 19, 2012 8:58 PM (in response to scmibis)

    I'm not sure if this will help but I have been having video playback issues and found this post in my scearhes. I came across another post on another site that talked about settings in Quicktime via the control panel. So I went into the control panel and started looking for something that might be affecting the playback. Your postings about DirectX pointed me in the right direction. This worked for me on my Win Xp PC.

     

    Control Panel, QuickTime, Advanced, Uncheck "Enable Direct3D video acceleration", OK

     

    I hope this works for you. Without this post I would have most likely never found this fix.

     

    Thanks,

     

    Dave

  • hshirl Calculating status...

    This worked for me.  Thank you!

  • Tonybiskuit Calculating status...
    Currently Being Moderated
    Sep 24, 2012 12:32 AM (in response to scmibis)

    Wel it appears I found the solution... I also couldnt play vids on my Itunes.. The thing was that the video I was trying to play was located in Drive (F:) and itunes was installed in Drive(C:) ... So i just moved the Video from drive (F:) to Drive (C:) and Voilaaa! Everything worked ... I guess itunes doesnt accept or wont play videos from anywhere but from where its installed ... In my case in Drive (C:)

     

    Hope this Helps! Good Day all!

  • Girlonfire Calculating status...

    Dave, just to let you know... This worked for me! I knew it had to be something simple, but that was definitely not in my repetoire of possible things to try. Thanks so much!

  • DDownes Calculating status...

    Daveinmelbourne - THANK YOU!! I have not been able to watch any video content for months and you have just solved my problem!! YAY !!! 

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.