Skip navigation

Sometimes USB HD does not appear connected in desktop

285 Views 7 Replies Latest reply: Aug 23, 2012 9:55 AM by hani7up RSS
hani7up Level 1 Level 1 (20 points)
Currently Being Moderated
Aug 18, 2012 4:53 PM

I am using a new iMAC and in general terms I am quite happy with it. However, I have connected to it, through a D-Link 4 port hub, with external power source, two USB HD, both of which being 1TB each, an Iomega with its own power source and a Toshiba, which has a double pronged usb cable, one of which is to draw the extra needed power to run this HD (if and when required). As I said, both are connected to a D Link hub, which in turn is connected to one of the rear USB ports in my iMAC.

 

However, at startup, I sometimes discover that the iMac did not detect the HD, although both iMAC and the hub in question are connected to the same power source distribuitor.

 

Does this mean that the USB port is mal functioning? Do I need any special upgrade software (although Software Upgrade says all is in order), or is it the D link? I get over the problem by disconnecting the D Link USB cable from the rear of the iMAC and plugging it again to the same USB rear port.

 

Would you guys recommend a different setting?

 

Thank you in advance for your help.

iMac, Mac OS X (10.7.2)
  • RRFS Level 5 Level 5 (4,425 points)

    Is your iMac not seeing both of the hard drives? Will your iMac see the drives if they are directly plugged into it?

  • BDAqua Level 10 Level 10 (114,685 points)
    Currently Being Moderated
    Aug 19, 2012 12:33 PM (in response to hani7up)

    Great work, thanks for the report!

  • luisyalmu Calculating status...

    I have a simillar problem with my WD external HD (1TB) connected directly to the USB port. OS is 10.6.x (the latests 10.6), not always hapend, but some times. I have another HD conected by Firewire for the time machine task, no problem with it. I´m thinking to move to the 10.8.x OS, but i dónt know if it will be resolved.

     

    Tested the same HD in other MAC (Mac book) with a 10.7.x OS, it works fine.

     

    Luis

  • BDAqua Level 10 Level 10 (114,685 points)

    Hi Luis, I'd wait on 10.8, or at least investigate all the new problems with it first.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.