Skip navigation

Timezone in .ics invitation incorrectly taken into iCal

1562 Views 5 Replies Latest reply: Apr 15, 2013 11:10 AM by o1sowise RSS
dobieguy Calculating status...
Currently Being Moderated
Dec 16, 2010 3:46 PM
Hello,
With my iPad I receive .ics calender invitations. The invitations that I send from my company computer to my iPad are all 6 hours off.
So I receive an invitation for a meeting 2-3pm EST and it displays at 8-9pm in my iPad when I am about to accept it. So the iPad is in middle-european time. I have checked and tried all the settings for calendar, and I haven't seen any improvent.

Oddly, when I open the same calendar invitation on my Mac, it is put correctly at 2-3pm in my calendar.

Does anyone know what is going on?

Thanks!
Macbook Air, iPad, iPhone, iOS 4
  • lllaass Level 10 Level 10 (135,110 points)
    You do the Time zone set correctly in Settings>Mail ,Contacts Calender?
    Mac Mini Early 2010 OSX 10.6.5, G4 MD OSX 10.5.8 - iPad 3G & G4 Touch, iOS 4
  • Chad Banning Calculating status...

    I am a new iPad owner and am having this same problem. Although mine appears to be posting the time of the person sending the invite. In this case its Eastern time. How frustrating that this simple issue is 20 months old and unresolved.

  • CandaceJ Calculating status...

    Wished I could help, but I have no solution here.  What is worse, you can accept the invitation and load to your calendar, but you do not have an option to adjust the time.  My only proposed solution is to accept the invitation, link with a computer, change the time on the computer, and then resync.  What a waste of time.  This should have been fixed eons ago.

  • o1sowise Calculating status...

    I have the same problem. When I accepted an ICS invitation from Kansas, it went onto my cal in their time (one hour behind me); when I accepted an ICS invitation from Spain, it went into my calendar in their time (six hours ahead of me).

     

    This happens from both my iPhone (IOS v6.1.3) and iMac (OSX v10.8.3).

     

    I see similar but not this exact problem spread around the different Apple Communities.

    Is there any resolution to this?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.