Skip navigation

Exchange under Mountain Lion

290427 Views 831 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine RSS
  • EmmanuelMD Calculating status...
    Currently Being Moderated
    Aug 23, 2012 8:51 AM (in response to m@zo)

    Mountain Lion 10.8.1 is out! Let's see if Exchange in Mail is now fixed....

  • Tgara Level 4 Level 4 (3,540 points)
    Currently Being Moderated
    Aug 23, 2012 8:53 AM (in response to EmmanuelMD)

    Good luck everybody!!!!!!!!!!!!  Hope the fixes work for everyone! 

     

    http://support.apple.com/kb/HT5418

  • mav2 Calculating status...
    Currently Being Moderated
    Aug 23, 2012 9:09 AM (in response to Tgara)

    Seems to be working better and now have option to use autodiscover or disable.

     

    I'm having one issue where since troubleshooting this issue I've deleted and re-added my exchange account several times and now the inbox only shows a subset of messages.  I created a new user account on mac and Mail works fine showing all messages.

     

    How can I completely remove Mail settings/data from my original Mac profile so I can re-add my Exchange account here?

     

    Thanks,

    Marlon

  • awdavis55 Calculating status...
    Currently Being Moderated
    Aug 23, 2012 9:16 AM (in response to mav2)

    mav2

     

    Click on your desktop and choose "Go" from the top menu bar.

    When the drop down menu is displayed then hold down the "Option" key

    This will reveal the "Library" folder.

     

    Go to Library/Mail/V2/

     

    Delete the folder that is related to your exchange account.  You may have several.  Delete and empty the trash.  Of course, do only if you feel comfortable, but from my experience you aren't hurting anything.

     

    Reopen Mail and that folder will automoatically repopulate.

  • thesaint_dfw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:23 AM (in response to mav2)

    It's good that they have added an option to disable autodiscover. Hope it works for everyone now.

  • mav2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:31 AM (in response to awdavis55)

    Thanks awdavis55,

     

    I see several subfolders and files under the Library/Mail/V2 folder.  Is it safe to delete everyhting here since I have no Mail accounts configured anymore?  I figure this will give me a fresh start.

  • awdavis55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:34 AM (in response to mav2)

    I have actually deleted everything within the V2 folder before.  You will then just have to let everything rebuild, which might take a little bit of time depending on how much content you have.  You'll be setting up all of your account files from scratch - meaning you'll re-create every account you have.  iCloud, Exchange, Gmail, etc...

     

    You always act at your own risk, but I have never had a problem in doing this to clean up issues.  You can do that with the calendars folder as well.

  • gabarrios Calculating status...
    Currently Being Moderated
    Aug 23, 2012 9:43 AM (in response to awdavis55)

    Not helping me.  I deleted my Exchange account and readded it.  My calendar doesn't contain anything amd only new mail seems to be coming through.  Any old mail saved in subfolders or that were still in the main inbox are not there.  I've tried switiching Audo discover on and off and it doesn't do anything

  • EmmanuelMD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:46 AM (in response to gabarrios)

    In Mail, try Mailbox > Rebuild. It should rebuild the database associated with your Exchange account, and pull all emails (new ones and any older emails in subfolders).

  • mav2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:55 AM (in response to awdavis55)

    OK, deleting contents of V2 folder did the trick for me and restored all my inbox.  Thanks!

     

    One last question, I didn't notice it before but I see that Exchange account in Mail has an option for checking mail at certain intervals (set to 1min).  Is this a new setting or was it always there?

  • Turgi Calculating status...
    Currently Being Moderated
    Aug 23, 2012 9:56 AM (in response to mav2)

    never delete all under V2 folder. only exhange account. there is much more on all other folders like signatures and so. Also if you have other mail accounts other than exchange. Don't touch Mailboxes and MailData. Only that for Exchange! May be there are several for Exchange if you tried often.

  • joshuaiz Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 23, 2012 9:56 AM (in response to thesaint_dfw)

    While I am not taking credit for it - this is the exact solution I proposed earlier in this thread.

     

    I can confirm it works for me. Thanks for listening Apple.

     

    It bears repeating that in my case, my outsourced IT company would not make any changes to their Exchange server setup so without the hosts file hack, this is the only option for me.

     

    Hopefull this will solve it for most people.

  • Ondray Wells Jr. Calculating status...
    Currently Being Moderated
    Aug 23, 2012 10:14 AM (in response to joshuaiz)

    Indeed.  I removed my hosts file hack and all the Exchange enabled apps are working fine both on the corporate network and on an outside network.  Mail, Calendar, and Contacts now all automatically connect with either the Internal Server or the External Server without issue or error messages.  I did find one thing odd though.  On my machine when I checked Use Autodiscover Service in Mail preferences it only populated the Internal Server field.  I presume this is because that just happens to be the way our Exchange server is configured.  In any event, it disabled both the Internal Server and External Server fields.  So I'm thinking it will populate both if it's configured to do so.  In my case I had to set the External Server first and then turn Autodiscover on.  What's weird though is that while Calendar and Contacts both had their Internal Server fields changed automatically to reflect what was in Mail ... the fields weren't disabled in the same manner so I was able to override them.  Which just doesn't seem right since I had turned Autodiscover on.  It seems like all the focus was on Mail from a user interface perspective but Exchange is Exchange is Exchange.  The Use Autodiscover Service checkbox and the enabling/disabling behavior of the Internal Server and External Server fields should be consistent across Mail, Calendar, and Contacts in my view.  But maybe that's just me.

     

    That being said, I hope everyone who's been affected by this is back in business now.  And on that note ... I'm out!

  • gabarrios Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 10:27 AM (in response to EmmanuelMD)

    The Rebuild command in Mail got all my old mail back.  However my Calendar is still empty. Any ideas

  • Tgara Level 4 Level 4 (3,540 points)
    Currently Being Moderated
    Aug 23, 2012 10:33 AM (in response to gabarrios)

    Are you using Exchange?  If so, try going into Preferences, Accounts.  Uncheck and then check the box that says Enable This Account.  It seems to reset things.  It worked for me.

     

    Also, give the calendar a few minutes to update.  In my experience, it takes a bit longer than the mail under Exchange. 

1 ... 30 31 32 33 34 ... 56 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (62)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.