Skip navigation

Deleted emails in Apple Mail IMAP account reappear after deleted

33856 Views 58 Replies Latest reply: Mar 21, 2014 12:07 PM by Keith Dvorak RSS
1 2 3 4 Previous Next
Torrey Tayenaka Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 5, 2012 4:42 PM

Ok so this has been driving me NUTS!

I have an IMAP email account set up within my apple mail program and I am having a strange case where emails are reappearing in my inbox (marked as read) after I have deleted them!!!! So I start my day going through emails, replying, organizing, deleting, etc. then I do something else - come back and they have all re-appeared! Its like spam email **** - I have to go through all my emails 3-4 times a day!

 

The account is an IMAP from GoDaddy

Under Mailbox Behaviors I tried unchecking "store deleted messages on server" (found that somewhere online) but it didnt help :/

MacBook Pro (17-inch Mid 2010), Mac OS X (10.7.4)
  • bug00 Level 1 Level 1 (45 points)

    I'm experiencing the exact same issue.  Additionally, emails deleted from one device do not show as deleted on other devices.  It's as though it isn't an IMAP account at all. 

     

    I posted my experience at https://discussions.apple.com/message/18709494#18709494 but I just wanted to reply here to let you know you're not alone.  Wish I had an answer for you...it's extremely frustrating!

  • tylerskis Level 1 Level 1 (0 points)

    Same thing here. I have a godaddy IMAP email and the only place with the problem is on my macbook. Both my old 2011 macbook air and my new 2012 macbook air. Some problem. My androids and ipads do not have this problem. When I delete on those they are deleted.

  • INOGuy Level 1 Level 1 (0 points)

    Same issue.  Godaddy IMAP email account.  Mac OS X 10.7.4 iMac Early 2008.  I thought Mail might have too many emails in inbox so I moved 2000 plus to an On My Mac folder reducing inbox to 609 emails, no help.  Noticed in godaddy webmail in the Deleted Messages that the deleted emails are there 2,3 times depending how many times I have tried to delete and redelete emails.  I guess I'll call godaddy to see if they have a solution.

  • INOGuy Level 1 Level 1 (0 points)

    I called godaddy and we were able to replicate the issue with tech support.  Tech support refreshed/reset my mail account, and did not solve the issue.  I was then asked to delete the email account  and then recreate the same account with same password.  And now it is working properly, for the time being.  I would recommend calling in to godaddy so they can develop a "known issues" report to investigate this further.  Another thing we noticed was a latency issue of deleting a message in Mail took about 3-4 minutes to propagate to godaddy webmail and be removed from webmail inbox.

  • The Liz Army Level 1 Level 1 (15 points)

    Has anyone received a fix for this issue?

     

    I am having the same problem.

     

    Thanks.

  • Marian33 Level 1 Level 1 (0 points)

    I have talked with Go Daddy.  I have talked with AppleCare. I have gone to see the Apple Geniuses.  All multiple times.  The Apple Genius even called Go Daddy tech support once when I was in the apple store.  Everyone has ideas of what to do to fix it. Nothing works permanently.  This is SOOOOOOO frustrating!

     

    Has anyone figured this out yet? I'm going to see if I can copy this conversation and send it to Go Daddy. (Although Go Daddy techs sometimes say it's an Apple problem; and of course Apple reps say it's a Go Daddy problem.)

  • tylerskis Level 1 Level 1 (0 points)

    I found a solution. I switched to Outlook. Works fine. I usually Love Apple products. But a fail with Mail.

  • bug00 Level 1 Level 1 (45 points)

    I was going bonkers with this problem for months, but my IMAP accounts are functioning correctly now. Unfortunately, I did two things in rather fast succession, so I'm not really sure which one cured the problem.  But here they both are FWIW:

     

    Firstly, in Mail Preferences, under "Accounts", in the "Advanced" pane, I unchecked "Use IDLE command if the server supports it".

     

    Then fairly soon after that, I upgraded to Mountain Lion.

     

    Again, not sure which action cured the problem...but all my GoDaddy IMAP accounts are functioning perfectly now.  (Oh man, I probably shouldn't have said that out loud, huh?  <knocking wood>)

     

    Hope one of those solutions helps you.

  • Marian33 Level 1 Level 1 (0 points)

    I'm already using Lion OX, so I tried unchecking the "Use IDLE command if the server supports it" the way that you did, bug00.  In a manner of speaking, it worked: no emails came back because no emails came in -- not even new ones! So I had to check it again in order to get any emails.

     

    Go Daddy told me they are aware of the problem and they are fixing it, but don't know when it will be fixed. (Sorry Torrey)

     

    I am going to move one of my email accounts to another service (probably 1&1 which my husband uses). If that email address works fine, I'll find out what it will take to move my other domains (which have websites associated with them, so it may not be so easy...or may be too expensive if I have to reconstruct the websites.) 

     

    Final option: Join Tylerskis and change to Outlook.

     

    Thanks everyone for your replies. Much appreciated!

  • bug00 Level 1 Level 1 (45 points)

    Very sorry to hear that your new mail stopped coming in at all after unchecking the "Use IDLE command if the server supports it" preference.  Strange, because having that item unchecked did not affect my incoming mail at all, in any of the 5 GoDaddy IMAP accounts that I changed.  My accounts are all continuing to function perfectly with that unchecked, and no deleted emails have returned since the change.

     

    Also, just for clarification, In my original reply I mentioned that I had upgraded to *Mountain* Lion (OS 10.8).  I already had Lion, as you said you have now.  So I was remarking that it's possible for me that my upgrade to *Mountain* Lion may have done something.

  • INOGuy Level 1 Level 1 (0 points)

    bugg00's fix of unchecking the "Use IDLE command if the server supports it" has worked for me since 8/17/12 when I read about it on the forum.  I have had none of the problems reported by Marian33 with my goDaddy IMAP accounts.  I have a godaddy domain that I am running two active mail accounts from.  My fix reported above on 7/16/12 only lasted a few days.  I am also running Mountain Lion.  Thank you, bug00, let's hope the fix holds.

  • GoDaddyGuy Level 1 Level 1 (75 points)

    Marian33,

     

    I'm sorry to hear that you haven't been able to resolve the issue as some of the others in the thread.

     

    I'm not personally familiar with the issue that causes this, but since you said that someone at Go Daddy mentioned being aware of the issue, I'd like to try to research it by reviewing your account and speaking with whomever discussed it with you. Would you be comfortable replying here with one of the domain names in your account so I could find it and investigate?

     

    Also, as much as I'd prefer you stay with Go Daddy for all your services, if you do choose to go elsewhere for email service, you should know that it's not difficult at all. There are records associated with every domain name that control what happens to email. They're called "MX Records", and you can edit them whenever you'd like - you'd just need to find out what your new provider's MX Records are. If and when you do need to make this change, we have a help article that explains how to edit your MX records - http://x.co/n7Ox - We also have Support staff you can call at any time for help if you'd prefer to speak with someone directly.

     

    Good luck to you moving forward, and thanks for sticking with it.

     

    Alon

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.