Skip navigation

Major UI Lag in Logic Pro 9.1.7 on OS 10.8?

65173 Views 888 Replies Latest reply: Mar 31, 2014 1:50 PM by The Art Of Sound RSS Branched to a new discussion.
  • ZXC Level 2 Level 2 (180 points)
    Currently Being Moderated
    Aug 23, 2012 11:02 AM (in response to ZXC)

  • battlegimp Calculating status...
    Currently Being Moderated
    Aug 23, 2012 11:03 AM (in response to hypnotik)

    I loaded the remix I was working on a few days ago, which was **** to finish and deliver. It has 80 tracks and was almost impossible to use after the first couple of tweaks, now it's fluid and responsive with multiple animated plugins open (4 EQ windows with analysers). I just tried switching them to high resolution and that was fine too. It did then lag slightly for less that a second, but no loss of control like before. I also changed a load of synth plugin settings at random with no issues.

     

    More generally, I actually found ML had horrible lag after upgrading from SL. This update has resolved that too. Suddendly my OS is way faster and probably a bit snappier than SL was.

     

    So far I am very relieved, but only time will tell as always with there situations!

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Aug 23, 2012 12:13 PM (in response to battlegimp)

    Sounds like they got if figured out...  Logic must have been thoroughly tested with this release.... will follow this thread a while longer before I recommend clients upgrade.

  • MonbazaTAIWAN Calculating status...
    Currently Being Moderated
    Aug 23, 2012 4:45 PM (in response to Mark Lindsey)

    Just upgrade to 10.8.1...

    The problem is still there.

    Only happen less often.

  • mrhoodmr Calculating status...
    Currently Being Moderated
    Aug 24, 2012 3:38 AM (in response to MonbazaTAIWAN)

    Also upgraded to 10.8.1. Problem is the same for me as 10.8 and Lion. So we wait for 10.8.2 or Logic 9.1.8.

     

    Pathetic.

  • battlegimp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2012 8:27 AM (in response to Pancenter)

    Started playing up again for me after about 4-5 hours. Seems much more random than before and it's not really the EQ that's doing it most. It's now more general faders and drag-dropping in the arrangement window.

     

    However, it is usable now and nothing like as bad (for me). I haven't had to force quit and I've had no locked playback for longer than a few seconds. Reloading the project helps.

     

    Perhaps they did a quick fix and will address it properly with 10.8.2. Would be nice if they would comment.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Aug 24, 2012 12:43 PM (in response to battlegimp)

    Well, at least it's improved for some.

     

    As for Apple commenting....  you will only hear very general statements like "improved reliability", however, Logic updates sometimes reference a list of bug fixes or changes but that's only during an update release.

     

    You will never hear a "direct" statement from Apple that -specifically- addresses a current problem, at least in my experience. The closest I've heard was when Final Cut X was released and users were switching to other programs or demanding (and receiving) refunds.

  • ZXC Level 2 Level 2 (180 points)
    Currently Being Moderated
    Aug 24, 2012 1:57 PM (in response to Pancenter)

    Pancenter wrote:

     

    You will never hear a "direct" statement from Apple that -specifically- addresses a current problem

    They post about it when the issue has been resolved, in the release notes. They haven't posted about resolving the lag problem some people has with 9.1.7 on ML, but in all the Logic release notes I've seen the last year, specific issues are listed, like eg "Resolves an issue in Logic Pro 9.1.6 in which projects with a large number of fades displayed “I/O Error, Result code = -36” when playback was started" for 9.1.7 or "Fixes an issue in which record repeat would delete the wrong take" for 9.1.6, and so on: http://support.apple.com/kb/TS2565

     

    It seems evident that the lag problem in 10.8 can be caused both by 3rd part drivers and the OS, and maybe there will be a Logic update adressing it too. Or maybe the entire problem has to be adressed exclusively with new 3rd part drivers/OS X subreleases.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Aug 24, 2012 2:45 PM (in response to ZXC)

    They post about it when the issue has been resolved, in the release notes. They haven't posted about resolving the lag problem some people has with 9.1.7 on ML, but in all the Logic release notes I've seen the last year, specific issues are listed, like eg "Resolves an issue in Logic Pro 9.1.6 in which projects with a large number of fades displayed “I/O Error, Result code = -36” when playback was started" for 9.1.7 or "Fixes an issue in which record repeat would delete the wrong take" for 9.1.6, and so on:

    ZXC wrote:

     

    Pancenter wrote:

     

    You will never hear a "direct" statement from Apple that -specifically- addresses a current problem

    They post about it when the issue has been resolved, in the release notes. They haven't posted about resolving the lag problem some people has with 9.1.7 on ML, but in all the Logic release notes I've seen the last year, specific issues are listed, like eg "Resolves an issue in Logic Pro 9.1.6 in which projects with a large number of fades displayed “I/O Error, Result code = -36” when playback was started" for 9.1.7 or "Fixes an issue in which record repeat would delete the wrong take" for 9.1.6, and so on: http://support.apple.com/kb/TS2565

     

     

    I said that in my previous post that you cherry picked a single line out of. "Logic updates sometimes reference a list of bug fixes or changes but that's only during an update release."

     

    They didn't use to release this info at all, it wasn't until enough users complained they added the list of fixes or issues that were resolved. Updates used to be released (not that long ago) without giving users any idea of what was addressed and what wasn't.

  • ZXC Level 2 Level 2 (180 points)
    Currently Being Moderated
    Aug 24, 2012 4:26 PM (in response to Pancenter)

    Well, what really matters for me is that that they have posted lists over specific problems they have solved for at least the last 10 versions. EVen the old Logic 8.02 release notes had very detailed listings of fixes.

     

    I certainly wouldn't miond more communication from Apple about known isues, but since I use 9.1.7 and the lag thing seems to have disappeared for me, and since/even if it improved with 10.8.1, and since I've seen some Cubase user reporting the same thing, it could be that this isn't about Logic or even OS X at all. Maybe the new OS just reveals shortcomings in old drivers or that the drivers arn't compatible with M-Lion yet. But all this is just speculation.

     

    Since some people *seems* to have problems with Logic and/or the OS, Apple could still have posted a line about this even if the reason was 3rd part drivers or background apps/tasks from 3rd parts.

     

    Some people have a tendency to not only blame everything on Apple, but to use every chance to mention what they aren't happy with, repeatedly, both when it's relevant and when it's not. That's not my cup of tea, and repeated statements about Logic being 'less pro' than it was, 'the free support isn't good enough', 'Logic will become more GarageBand like' and so on can be tedious.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Aug 24, 2012 5:16 PM (in response to ZXC)

     

    ZXC wrote:

     

    Some people have a tendency to not only blame everything on Apple, but to use every chance to mention what they aren't happy with, repeatedly, both when it's relevant and when it's not. That's not my cup of tea.

     

    More power to you, no one is discouraging you from doing so!

     

    I imagine if the list mods thought something was too out of place, they would remove it.

     

    I'm sure you can see from the number of points accumulated I've certainly been more helpful than "some people" and don't just sit around blowing my Apple Horn. (or that an eMagic horn?)

  • Alexander One Calculating status...
    Currently Being Moderated
    Aug 26, 2012 2:21 PM (in response to Mark Lindsey)

    Reinstall 9.1.7 download here: http://support.apple.com/kb/DL1014

     

    verify your main disk permissions,

     

    repair.

     

    Worked an hour with no lag, also on vengeance plugins & multiple chan eq + analyzer istances too,

    had some corrupted permission into java, graphic frameworks & audio unit stuff,

     

    testing tomorrow properly, time to bed for me.

  • MonbazaTAIWAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 26, 2012 9:38 PM (in response to Alexander One)

    Dear Alexander One

     

    Thank you for the advise.

    Everything works finely until I start to tweak the built-in EQ plugin.

    It seems to have a related relation with the EQ's Analyzer button.

    Ever since I turn the Analyzer on, it starts to lag.

    Also... is there a special secret about making the Mixer bigger?

    My eyes can be very exhaused when tweaking these little knobs.

  • Qbical Calculating status...
    Currently Being Moderated
    Sep 1, 2012 12:57 AM (in response to Mark Lindsey)

    Using Logic in 64Bit mode fixes the problem for me. Most of my 3rd party plugins are now 64Bit so no biggy, but the 32bit bridge still ***** for the other plugins. Also I'm running Logic in Low Resolution mode on my Retina, that way I can read the numbers in a plugin interface in a normal way...

     

    We really need a complete overhaul of logic to get it into this decade...

  • bnhmphrys_86 Calculating status...
    Currently Being Moderated
    Sep 6, 2012 5:03 AM (in response to Mark Lindsey)

    I'm having this problem too. Logic 9.1.7; OS 10.8.1. Is Apple working on this?

1 ... 3 4 5 6 7 ... 60 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.