Skip navigation

No new mail alert sound in Mountain Lion

24844 Views 108 Replies Latest reply: Apr 17, 2014 9:10 AM by Tom in London RSS
1 2 3 ... 8 Previous Next
Lady Engineer Level 1 Level 1 (25 points)
Currently Being Moderated
Aug 7, 2012 8:52 AM

I did a clean install of ML, In Lion when I had an alert sound when new mail arrived, i cannot get it to work in ML.

 

It is enables in mail, and also in sound preferences as well, but still no sound when new mail arrives.

 

Anyone else?

  • docjonathanday Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2012 12:11 AM (in response to Lady Engineer)

    I have the same problem, yet am surprised to see little postings on the issue. Seems a very limited problem.

  • Retired Engineer Level 4 Level 4 (2,710 points)
    Currently Being Moderated
    Aug 8, 2012 2:23 AM (in response to Lady Engineer)

    Is it also enabled in Notifications?

  • docjonathanday Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2012 3:22 PM (in response to Lady Engineer)

    Yes, the checkbox to play a sound in notification centre on receiving new emails is checked, but still no sound plays.

  • drewwwy! Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 8, 2012 4:18 PM (in response to Lady Engineer)

    I have the same problem except what happens is, when I launch Apple Mail the sound alerts work just fine but once my Mac goes to sleep and I log back in, the sound is now disabled unless I relaunch the app again. Quite annoying to have to constantly relaunch it every time my Mac goes to sleep.

     

    Hope they fix this bug soon!

  • Mikaeldo88 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 24, 2012 7:55 PM (in response to Lady Engineer)

    After trying many methods. I found this a temporary fix. The solution is to set a rule in Mail Preference to run an Applscripts if there is new email. This Applescript will play a notification sound of your choice:

     

    tell application "Mail" to if (count of (every message of inbox whose read status is false)) isgreater than 0 then do shell script "afplay '/Applications/Mail.app/Contents/Resources/New Mail.aiff'"

     

    You can change the path /Application/Mail.app/Contents/Resources/New Mail.aiff to any folder that containt an aiff file. For example: /System/Library/Sounds/Glass.aiff (in this folder you can find all the alert sounds of Mac OS)

     

    Applescript Editor

     

    1. Open Applescript Editor in Applications folder

     

    2. Paste the script in after choosing your notification sound path

     

    3. Save in ~/Library/Application Scripts/com.apple.mail (can name it New Mail in my example)

     

    4. Now you can choose the script in Mail Rules setting

     

    For the Mail rules setting

     

    Open Mail Preferences then Rules then Add Rule. The setting like photo

     

    https://www.sugarsync.com/pf/D8942998_67824332_008550

    It works like a charm !!!
  • Mikaeldo88 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 24, 2012 8:08 PM (in response to Lady Engineer)

    There is also another method that also work. That is the Permissons Repair

     

    1. Quit Mail app

     

    2. Go to Applications folder/Utilities/Disk Ultilities

     

    3. Select Macintosh HD then Repair Dish Permissions

     

    Wait for a couple of minutes, open Mail and try to send yourselft an email again (remember to off the rule to see effect). This method is need to be repeated overtime so I still prefer the Applescript method.

  • Mikaeldo88 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 24, 2012 8:27 PM (in response to Lady Engineer)

    I did the Permissions Repair while I was still using the computer like normal not in Recovery mode. Doing it in Recovery mode doesn't help. How about Applescript method ?

  • Montrose Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 24, 2012 10:47 PM (in response to Mikaeldo88)

    Same problem. Lose all mail sounds after computer has been asleep for a while.  Have to restart mail or sometimes restart the computer.  It happens more frequently if Power Nap is selected.  Have spoken to apple care for 3 weeks and the issue has been sent to the engineers but no response at all. I'm surprised there have not been more reports of this problem posted.  Have Macbook Air 2012. Started after upgrade from Lion to Mountain Lion about 3 weeks ago.

    Sounds can also be restored by going to activity monitor and quitting coreaudiod file. This has been reported before.  All sounds that should have played will then play after coreaudiod file is forced quit.  You can hear 4-5 sounds play right after each other depending on how many sounds that were supposed to play but didn't until the file was stopped.

  • Trublue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 25, 2012 9:55 AM (in response to Montrose)

    Stopping the coreaudiod file in activity monitor did the trick. Thank you! Had noticed this even in Snow Leopard, but never bothered me enough to contact Apple about it. Annoying that the fix will have to be repeated every time, but maybe if enough people post about this, they'll issue a permanent fix.

  • docjonathanday Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 26, 2012 5:48 AM (in response to Lady Engineer)

    Have also tried repairing permissions via various routes but still with no joy. The audio alert for new mail that featured in Lion / Snow Leopard on my MacBook Pro is now absent in Mountain Lion, even after installing the recently launched update.

  • antmon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2012 7:36 PM (in response to Lady Engineer)

    Just adding a "me too" to this thread.  I have a new retina MBP and sounds for mail and messages don't work after a sleep.  If I restart the coreaudiod it fixes the problem.  I did a clean install of Mountain Lion to try and resolve it and it didn't help.  I am running 10.8.1.

  • Öllegård Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2012 2:17 AM (in response to Lady Engineer)

    I got the same problem with my iMac 2011 running 10.8.1. When I quitting coreaudiod it works till next time the computer goes to sleep; but I noticed that the sounds come with a delay. I don't remember that behavior from 10.7 when it worked all the time.

1 2 3 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.