Skip navigation

Permissions Bricked my MBP. Download Startup Disk?

445 Views 9 Replies Latest reply: Sep 1, 2012 6:43 AM by xeqtv RSS
xeqtv Level 1 Level 1 (20 points)
Currently Being Moderated
Aug 27, 2012 8:16 AM

I changed the permissions on my hard drive from Everyone to No One.  I understand now that's a no-no.  Now I get the startup screen that's stuck at the apple and the sticks rotating in perpetuity.  I've tried everythign I could find, most unsuccessfully. 

Reset PRAM - fail

Reset SMC - fail

Boot in safe mode - didn't work.  I was going to try to boot from a clone on my external HD.

Boot as singel user and try CHMOD - fail

etc, etc

 

I'm working out of state and my recovery disk (whatever it's called) is back home.  Other than having my wife find it and sending it to me, is there a way download the disk and burn it to DVD and use that?  Do you think the geniuses at the apple store an hour away could help w/ that?  Do you have any other ideas?

MacBook Pro, Mac OS X (10.6.8)
  • Roger Wilmut1 Level 9 Level 9 (64,025 points)
    Currently Being Moderated
    Aug 27, 2012 8:30 AM (in response to xeqtv)

    There is no way to download the disk. You could ring the Apple Store - if you quote the serial number of your Mac they should be able to supply you with a disk at a small charge, but you might just as well get your wife to FedEx it (or whatever).

  • Mark Jalbert Level 5 Level 5 (4,385 points)
    Currently Being Moderated
    Aug 27, 2012 10:30 AM (in response to xeqtv)

    Boot as singel user and try CHMOD - fail

    In single user mode you are root, it should not fail. You did something wrong. Follow these directions:

    Boot into single user mode - http://support.apple.com/kb/HT1492

    Once you are at the prompt then:

     

    /sbin/fsck -fy /
    

    If the filesystem is clean then:

     

    mount -uw /
    

    Remore the ACL entry from the boot disk:

     

    chmod -N /
    

    And finally:

     

    reboot
    

    If this does not fix the issue then a trip to the Apple Store would be a good idea.

  • roam Level 6 Level 6 (13,545 points)
    Currently Being Moderated
    Aug 27, 2012 11:56 PM (in response to xeqtv)

    Start in Single user mode again like before, but use these commands,

    Note: there must be a space between the / and that which precedes it. The font I used is intended to show this.

     

    mount -uw /

     

    chmod 1775 /

     

    reboot

    iMac, Mac OS X (10.5.8), 10.6.8
  • roam Level 6 Level 6 (13,545 points)
    Currently Being Moderated
    Aug 31, 2012 4:21 PM (in response to xeqtv)

    I'm glad you can access your disk again.

     

    "but my HD still has stuff like the new CD I recently purchased before this fiasco."

    "What do I do now?"

    I don't understand what you mean here.

     

    Message was edited by: roam

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.