Skip navigation

Mountain Lion Mail upgrade hangs- One Solution

6694 Views 18 Replies Latest reply: Apr 18, 2013 5:29 AM by dinky2 RSS
1 2 Previous Next
Lightingmatters Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 26, 2012 1:23 AM

Just upgraded to Moutnain Lion and updating Mail Upgrade and it hangs , as many others have found.

My Solution!

 

Force Quit. Restart. Try mail again. If it hangs again, force quit and the second time I restarted it all kicked in and did its job upgrading Mail. (Phew)

All is OK.

The second restart seem to solve the problem for me.

 

Good luck

Mac Pro, Mac OS X (10.4.3)
  • tosk Level 1 Level 1 (0 points)

    I have not force quitted it, just clicked cancel after 30 minutes on the same file, i restarted it about 20 times, initially it seemed to go a little more far, but after some time it hanged at the same spot.

  • tosk Level 1 Level 1 (0 points)

    Hi

    No i have not solved it, at first it hanged on msg     12104 of 22440

    force quitted then it hanged at                                12102 of 22438

    force quitted and it hanged at                                 12100 of 22436

    force quitted and it hanged at                                 12098 of 22434

    no error reports on console app

  • Arbey Level 1 Level 1 (0 points)

    Hi,

    I have the same problem. Force quitting several times hasn't helped so far. The progress bar always stopps at the edge of the stamp.

  • Quack_Salvesen Level 1 Level 1 (0 points)

    Lightingmatters;

     

    Yes that did the trick.

    (I also restarted my mac, not only the app).

    Works now...

     

    :-)

  • jebworks Level 1 Level 1 (30 points)

    Have force quit mail repeatedly and also restarted the Mac Book Pro a few times but Mail still hangs or if it starts I constantly get the spinning beach ball for minutes at a time. Sometimes messages in the inbox show up sometimes they don't.

     

    I tried the send web page from Safari which correctly opens a new message in mail but again the beachball keeps spinning and just entering an email address takes literally minutes with a spinning beach ball after each keystroke. Drives me totally nuts!

     

    I was already on iCloud so MobileMe is not an issue. On original launch the mail database update worked. I was able to use Mail yesterday but as of this morning the above problems occur making it literally unusable.

  • tosk Level 1 Level 1 (0 points)

    Ok i partially solved it, go to your user Library/Mail/V2/Mailboxes

    move the contents to another directory

    open mail and choose file->import folders (the one above print, sorry i have it in italian so i don't know if it is the exact translation)

    choose the first option

    open each mbox separately, so you can skip the one that is having problems. (and hopefully wait for a fix)

  • Arbey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 8:25 AM (in response to tosk)

    Hi tosk,

     

    it doesn't work for me. I did exactly what you wrote but the import funktion seems to be broken too. Whe I choose import and select import from apple mail I'm not asked for the postbox to import. Rather mail tells me "error" and to select at least one object from the list, but there is no list. I can then click ok and get the spinning beachball for ever.

  • Arbey Level 1 Level 1 (0 points)

    In the end I had to do a clean install of ML and import everything. Now it works.

  • Lowell Denning Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2012 12:41 AM (in response to Arbey)

    My clean install on my Macbook Air still hangs up downloading emal and rebuilding the cache.  ML Mail on my Macbook Pro and iMac downloads and updates the cache in a few seconds. Got to be a bug in ML for MacBook Air somewhere.

  • terriergal Level 1 Level 1 (5 points)

    I found this other thread that helped me with this same problem. If it is hanging on the 'upgrading database' portion please see this discussion and the solution posted by registerednderd at the bottom of the first page.  It worked for me at least to get past the 'upgrading database' hangup and then to import the old messages.

     

    https://discussions.apple.com/thread/4137441

  • manofdogz Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 23, 2012 10:06 AM (in response to terriergal)

    Similar problem when upgrading my wife's system from SL to ML 8.2. Mail hung constantly and so did icloud in syst prefs. After pulling most of my hair out I found the problem was to do with her not having an icloud acount - still had a mobile me account. Answer was to do the following (in this order):

     

    1. go to mobile me online, log in and and thereby upgrade her account
    2. syst prefs: mail, contacts, calendars - delete old mobile me account - add icloud account
    3. syst prefs: icloud - activate

     

    Thereafter all kicked into action and has been perfect since.

     

    I'm not sure all the problems listed in this thread are the same but I'm sure my wife's issue was related to accounts rather than software because 8.2 has largely fixed the software issues. Also, I upgraded from Lion (as opposed to SL) to ML 8.2 - already having an icloud account - and had no trouble at all

     

    Hope this helps someone.

  • ferndock53 Level 1 Level 1 (0 points)

    My problem was somewhat similar. Would hang on "importing mailbox "INBOX/Deleted Messages"" Tried all the other things we've seen in discussions. Figured it was that one mailbox(s) that was the problem.

     

    Entered Library (command-shift G, entered ~/Library/Mail/V2/) and went through each account, deleting all the instances of " Deleted Messages N.NN.NN PM.mbox"

     

    Then relaunched Mail, which imported all the mailboxes - except deleted messages or Trash. Trying to import some/all of those deleted messages now. If that works I have to go through and actually delete the ones I am certain I don't need to Spotlight and find.

     

    FWIW, this was a forced upgrade. Failed HD and new install of 10.8. Which was totally working, mail and all. Problem occurred today after upgrading to 10.8.2. Similar issue on a laptop, there I cloned the drive on exterior HD, then swapped out. Zero issues. Hmmmm, wonder what will happen if I upgrade THAT to newest OS. Maybe I'll wait a bit!

  • Denny99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 3:47 AM (in response to ferndock53)

    Yup,

    removing the specific folders in ~/Library/Mail/V2/ always worked for me.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.