Skip navigation

Apple TV 1st gen stuck in infinite loop

2924 Views 6 Replies Latest reply: Mar 2, 2013 7:55 PM by Tweep27 RSS
sounddave Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 28, 2012 7:08 AM

Hi

This has probably been covered a few times but the only answers I could find was from an archived discussion.

 

The other day I was given an Apple TV 1st gen, it had not been used for quite some time, and decided to upgrade the software, when I noticed it still had old pictures and music on from the previous user, not wanting to keep these pictures, I decided to reset the machine to factory settings, which it did, but on the restart it was stuck at a loop giving me a code to enter into iTunes, and then resetting and giving me a different code.

 

i've tried several resets of the settings, holding menu and - together, but still having no joy.

 

Its never been tampered with, but its really annoying me.

 

Can anyone help? this is a very old product so figure something might have been done during this time

 

Cheers

Dave

Apple TV, Windows Vista
  • livingstonl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2012 3:59 PM (in response to sounddave)

    sounddave,

     

    I have been in the middle of the same problem for months.

     

    I think the problem is with the software version that the older 40GB Apple TV's revert to after the factory restore.  Mine reverted to version 1.0, and that is when the loop started happening.  Since when did a factory restore become a factory paper weight creator!

     

    I read somewhere that the Apple TV looks at an Apple server and the older software doesn't play well with the updated server causing it to keep rebooting.  I'll try to find a link about this if I can find it again.  I remember reading that it happened to a bunch of people with older Apple TV software on a particular day that Apple upgraded their server.

     

    If you don't let your Apple TV connect to the internet, it will stop the infinite loop, but it also means you can't upgrade your software.  I haven't tried it yet, but it also might be an issue with newer versions of iTunes.

     

    I tested this by unplugging my router, and the Apple TV stopped looping.

     

    I tried to fix this before without success, but I am really determined this time.

  • livingstonl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2012 8:34 PM (in response to livingstonl)

    ok, I fixed it!!

     

    I followed these directions from crhendo1 here...

    https://discussions.apple.com/thread/2152096?start=0&tstart=0

     

    The trick is to turn off all internet, then plug in the ethernet cable, then set the DNS settings 208.067.222.222 (acording to crhendo), then turn on the internet.  I'm not even sure you would have to set the DNS address??

     

    Then I was able to update to 3.0.2!!

     

    Then I installed ATV Flash, so I am definitely back in business after many months.  Thanks to crhendo1

  • Dr Alves Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2013 7:08 PM (in response to sounddave)

    Thanks a lot!!
    Works 100%
    TTTTHHHHHAAAANNNNNNKKKSSSS!!!!

  • Snobrotha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2013 8:50 PM (in response to sounddave)

    Hi, I had the same issue. I also had the problem that I share a house with two other guys - all of us have a ton of mac products and they weren't too keen on disconnecting everything.

     

    The easiest way to get this to work is to connect it via ethernet, and after it starts the loop, disconnect the cable. Then press the menu button, Settings, then hover over to Update Software. Plug your cable back in, and then keep hitting the play button on your remote to begin the download. You'll get an error message saying "Can't connect" but when you go back to the menu immediately press the play button to try it again. If the system goes into the loop, disconnect the cable and try it again.

     

    In my case, my room was very far from the house internet router, so did reverse tethering using my macbook pro to turn my laptop into an internet router. I went to Network Settings, Ethernet, Configure iPv4 manually. Set IP to 10.0.0.1 and Subnet to 255.255.255.0. Then from Settings go to Sharing, check the box for Internet Sharing and make sure the Ethernet box is checked. Now I was able to do the method above to update my ATV software but without physically being by the router.

     

    Hope this helps!

  • Tweep27 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2013 7:55 PM (in response to livingstonl)

    Thankyou so much I have spent countless hours trying different methods, and this one is the only one that has worked so far!!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.