Skip navigation

iCal birthdays showing up twice?

4595 Views 14 Replies Latest reply: Mar 10, 2014 10:28 AM by Georgine Cheavens RSS
Anon M Calculating status...
Currently Being Moderated
Aug 27, 2012 2:27 AM

Hello!

 

I have a problem where all birthdays on my Mac are showing up twice. This problem has occured only now. I've had iCloud and Mountain Lion since they came out. And I am using iOS 5 on my iPhone. The birthdays don't show up twice on my iPhone, only on my Mac in iCal. Also, not all of them show up twice. Only those in the future.

 

I don't synchronize my calendar or my contacts or anything of this kind through iTunes, I use iCloud for that. So how come they show up twice?

 

I hope someone can help me! I'd really appreciate that

 

Greetings

iMac, OS X Mountain Lion (10.8.1)
  • keg55 Level 5 Level 5 (5,615 points)
    Currently Being Moderated
    Aug 29, 2012 1:30 PM (in response to Anon M)

    Try this..... open Calendars/Preferences/General and uncheck Show Birthdays calendar. Wait a minute then recheck it and see if the dups go away.

  • keg55 Level 5 Level 5 (5,615 points)
    Currently Being Moderated
    Aug 29, 2012 5:34 PM (in response to Anon M)

    That's odd since all that checkbox does is show birthdays in Calendar. Weird that it would say 'something bad or mistake has happened'.

  • joshuafromsilverhill Calculating status...
    Currently Being Moderated
    Sep 18, 2012 11:45 AM (in response to Anon M)

    It sounds like you were/are having the same problem as me.  I don't know if you got it worked out, but this is what I did based off a different discussion.

     

    In iCal, birthdays were showing up twice for the same person on the same date.  I went to Address Book (because birthdays are linked there and then displayed in iCal).  In Address Book, I had two sets of addresses: "On my Mac" and "iCloud."  I recently had merged all of my contacts to match up (can't remember how) because under "All Contacts" on my iPhone people were showing up more than once.  So, all of my contacts were the same "On my Mac" and on "iCloud."  Because my iPhone uses the iCloud contacts, I simply clicked on the first contact under "On my Mac" and pressed Shift and clicked on the last contact to select all of them.  (Select all didn't work.  I made it select both sets of addresses.)  Then I pressed the Delete key and they are all gone.

     

    I went back to iCal and now my contacts show up once.  I hope this helps!

  • rmaruzzi Calculating status...
    Currently Being Moderated
    Sep 29, 2012 7:24 AM (in response to Anon M)

    Anon M,

     

    same issue here, but solved. In Contacts I had two iCloud accounts, one xxxx@me.com and a recently created xxxx@icloud.com. Contacts were displayed twice, and hence birthdays duplicated in Calendar. By removing one account from Contacts, I now have just one instace per birtday in Calendar.

     

    Hope this helps, Stefano

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Sep 29, 2012 8:25 AM (in response to Anon M)

    Anon M wrote:

     

    Thanks for the tipp man, I tried this but unfortunately it didn't work Plus, when I rechecked it, it gave me a message that a big mistake has happened and some stuff could be lost, but it didn't say why it happened nor it said how to solve it.

    Start giving us actual error messages, your paraphrasing them makes it difficult to pin down what is happening, you did not get a message that "a big mistake has happened'

  • ixab Calculating status...
    Currently Being Moderated
    Jan 8, 2013 9:54 PM (in response to Csound1)

    I had this problem, but what was showing up were contact birthdays from my Google Calendar account.   I noticed the duplicate entries weren't exactly the same.  One had a note about it being the contact's birthday, the other had an alert for the day before the event.  That might be why there was two entries, since they are slightly different for some reason.  Anyway, I got rid of the dupicates by removing the Google Calendar account.  I then switched off the default notification for all day events and closed Cal.  I then re-opened Cal, and re-added the Google account.  I did not use the account add wizard to also set up contacts, messages, etc.  This got my GCal back in Cal, without the duplicate contact birthdays. Not sure if all of those steps were needed, or if they will work for anyone else, but I figured I'd share.

     

    Also, if you have delegates (like I have my wife's Google calendar as a delegate in mine) you might get duplicate birthdays for contacts that you and your delegate have in common.

  • mconahan Calculating status...
    Currently Being Moderated
    Nov 2, 2013 11:28 AM (in response to Anon M)

    Click the Calendars button at the top of the calendar window or chose Calendars from the Window menu. This shows a list of sources for the holidays, birthdays, etc. I unchecked US Holidays under "Other" -  it's still checked under "iCloud" - and my duplicate holidays went away.

  • Georgine Cheavens Calculating status...
    Currently Being Moderated
    Mar 10, 2014 10:28 AM (in response to mconahan)

    Thank-you. The birthdays etc on my calendar were duplicating up to 20 + times, leaving no room for other items. Now there is only one copy of each. Yeah!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.