14 Replies Latest reply: Mar 10, 2014 10:28 AM by Georgine Cheavens
Anon M Level 1 Level 1 (0 points)

Hello!

 

I have a problem where all birthdays on my Mac are showing up twice. This problem has occured only now. I've had iCloud and Mountain Lion since they came out. And I am using iOS 5 on my iPhone. The birthdays don't show up twice on my iPhone, only on my Mac in iCal. Also, not all of them show up twice. Only those in the future.

 

I don't synchronize my calendar or my contacts or anything of this kind through iTunes, I use iCloud for that. So how come they show up twice?

 

I hope someone can help me! I'd really appreciate that

 

Greetings


iMac, OS X Mountain Lion (10.8.1)
  • 1. Re: iCal birthdays showing up twice?
    Anon M Level 1 Level 1 (0 points)

    Nobody??!

  • 3. Re: iCal birthdays showing up twice?
    Anon M Level 1 Level 1 (0 points)

    Thanks I've read all of this, but please show me a solution... because I didn't find any in any of the threads you just posted.

  • 4. Re: iCal birthdays showing up twice?
    Anon M Level 1 Level 1 (0 points)

    What the ****!!!! Now some even show up 4 times? What the **** is this ****...

  • 5. Re: iCal birthdays showing up twice?
    keg55 Level 5 Level 5 (5,925 points)

    Try this..... open Calendars/Preferences/General and uncheck Show Birthdays calendar. Wait a minute then recheck it and see if the dups go away.

  • 6. Re: iCal birthdays showing up twice?
    Anon M Level 1 Level 1 (0 points)

    Thanks for the tipp man, I tried this but unfortunately it didn't work Plus, when I rechecked it, it gave me a message that a big mistake has happened and some stuff could be lost, but it didn't say why it happened nor it said how to solve it.

  • 7. Re: iCal birthdays showing up twice?
    keg55 Level 5 Level 5 (5,925 points)

    That's odd since all that checkbox does is show birthdays in Calendar. Weird that it would say 'something bad or mistake has happened'.

  • 8. Re: iCal birthdays showing up twice?
    Anon M Level 1 Level 1 (0 points)

    Alright now suddenly I have over 800 contacts. This explains the birthdays. They are all multiplied by 4!

     

     

    When I am in the contacts app, in the bottom right corner of the left page, there are 3 buttons for different appearence of the page. When you click the one at the left it should say "All contacts, iCloud, Last import".

     

    But "iCloud" appears twice, and I can not delete it. It says "iCloud" and then "All iCloud" underneath. Why is that?

     

    I tried deleting some contacts, but when I delete one, then it deletes two of them. So when I delete the 3rd, it also deletes the 4th. I then have to undo every time, and then only the 4th would reappear. Very annoying!

     

    I guess this is because it syncs twice with iCloud, and both times it syncs with it, it duplicated them. So that's 4 times.

     

    I do not sync contacts through iTunes. I have all going through the iCloud. On my Mac I selected the contacts to sync with iCloud, and on the iPhone too. Is that how it should be? Or is that the reason why it's twice in the iCloud? Because if yes, how is it ment to sync between the Mac and the iPhone then?

     

    This is so uber-complicated, especially because I didn't even do anything. I came back from holiday and that was it...

     

    Thanks for all the help so far guys!

  • 9. Re: iCal birthdays showing up twice?
    joshuafromsilverhill Level 1 Level 1 (0 points)

    It sounds like you were/are having the same problem as me.  I don't know if you got it worked out, but this is what I did based off a different discussion.

     

    In iCal, birthdays were showing up twice for the same person on the same date.  I went to Address Book (because birthdays are linked there and then displayed in iCal).  In Address Book, I had two sets of addresses: "On my Mac" and "iCloud."  I recently had merged all of my contacts to match up (can't remember how) because under "All Contacts" on my iPhone people were showing up more than once.  So, all of my contacts were the same "On my Mac" and on "iCloud."  Because my iPhone uses the iCloud contacts, I simply clicked on the first contact under "On my Mac" and pressed Shift and clicked on the last contact to select all of them.  (Select all didn't work.  I made it select both sets of addresses.)  Then I pressed the Delete key and they are all gone.

     

    I went back to iCal and now my contacts show up once.  I hope this helps!

  • 10. Re: iCal birthdays showing up twice?
    rmaruzzi Level 1 Level 1 (0 points)

    Anon M,

     

    same issue here, but solved. In Contacts I had two iCloud accounts, one xxxx@me.com and a recently created xxxx@icloud.com. Contacts were displayed twice, and hence birthdays duplicated in Calendar. By removing one account from Contacts, I now have just one instace per birtday in Calendar.

     

    Hope this helps, Stefano

  • 11. Re: iCal birthdays showing up twice?
    Csound1 Level 8 Level 8 (35,430 points)

    Anon M wrote:

     

    Thanks for the tipp man, I tried this but unfortunately it didn't work Plus, when I rechecked it, it gave me a message that a big mistake has happened and some stuff could be lost, but it didn't say why it happened nor it said how to solve it.

    Start giving us actual error messages, your paraphrasing them makes it difficult to pin down what is happening, you did not get a message that "a big mistake has happened'

  • 12. Re: iCal birthdays showing up twice?
    ixab Level 1 Level 1 (0 points)

    I had this problem, but what was showing up were contact birthdays from my Google Calendar account.   I noticed the duplicate entries weren't exactly the same.  One had a note about it being the contact's birthday, the other had an alert for the day before the event.  That might be why there was two entries, since they are slightly different for some reason.  Anyway, I got rid of the dupicates by removing the Google Calendar account.  I then switched off the default notification for all day events and closed Cal.  I then re-opened Cal, and re-added the Google account.  I did not use the account add wizard to also set up contacts, messages, etc.  This got my GCal back in Cal, without the duplicate contact birthdays. Not sure if all of those steps were needed, or if they will work for anyone else, but I figured I'd share.

     

    Also, if you have delegates (like I have my wife's Google calendar as a delegate in mine) you might get duplicate birthdays for contacts that you and your delegate have in common.

  • 13. Re: iCal birthdays showing up twice?
    mconahan Level 1 Level 1 (0 points)

    Click the Calendars button at the top of the calendar window or chose Calendars from the Window menu. This shows a list of sources for the holidays, birthdays, etc. I unchecked US Holidays under "Other" -  it's still checked under "iCloud" - and my duplicate holidays went away.

  • 14. Re: iCal birthdays showing up twice?
    Georgine Cheavens Level 1 Level 1 (5 points)

    Thank-you. The birthdays etc on my calendar were duplicating up to 20 + times, leaving no room for other items. Now there is only one copy of each. Yeah!!