Skip navigation

Sync iCal iCloud and Google Calendars - In 12 Steps

73267 Views 17 Replies Latest reply: Mar 6, 2014 1:54 PM by GGItaly RSS
1 2 Previous Next
rubenpg Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 31, 2012 11:25 AM

I needed to have iCal and Google Calendars in the my iPhone and be synched.

 

from your iPhone

1. Create your iCloud account. ( Settings | iCloud ).

2. Add your iCloud account to your iPhone ( Settings | iCloud ).

3. Turn On Calendars ( Settings | iCloud | {iCloud Account} )

4. Add your Google Account ( Settings | Mail Contacts, Calendar | Add Account... | Gmail )

5. Turn On Calendars ( Settings | Mail Contacts, Calendar | {Gmail Account} )

6. Select the calendars you want to Sync here and save the changes. https://www.google.com/calendar/iphoneselect

 

from your Macbook

7. Open iCal Preferences

8. Click Accounts Tab

9. Add your iCloud Account

10. Add your Google Account

11. Select Google Account and click delegation.

12. Select the Calendars you want to sync.

 

This does not sync iCloud, this enable you to have all calendars in Google and iCal in your devices.

 

Hope this helps someone.

iPhone 4S, Mac OS X (10.7.4)
  • gooseontheloose Level 1 Level 1 (0 points)

    thank you for adding that link. for me it was "syn ical icloud and google calendars-in two easy steps"

  • crankboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2012 10:14 PM (in response to rubenpg)

    Thanks for this.  I have one question.  When I do this my main google calendar shows up under a heading titled "Google" in the side bar. All the others show up under a heading titled "delegates" and each delegate is a drop down menu.  For instance I have a calendar labeled pets. Pets has an arrow to the left of it I click the gray box and arrow points down and shows a "sub calendar" if you will labeled pets with a yellow box(the color of the calendar).  What's with having a drop down for each calendar with the same calendar under neither it?  Mind you only one event shows up but it seems redundant. Is there anyway to get rid of this?

  • Pim Versteeg Level 1 Level 1 (15 points)

    Hi,

     

    I must be missing something, when I follow the script step by step it goes wrong towards the end, when I open iCal preferences>accounts>gmail account, under "delegates" i get nothing to choose from, only an empty box

     

    what am I doing wrong?

     

    thanks

     

    Pim

  • Ringo De Smet Level 1 Level 1 (85 points)

    Pim,

     

    That's normal. You first have to configure Google Sync for any of your additional Google calendars. Follow the instructions from the article Set up Google Sync with iOS Calendar. When done, then go back to the Delegates section in the iCal/Calendar preferences

     

    Ringo

  • Pim Versteeg Level 1 Level 1 (15 points)

    Ringo,

     

    Sure, but this creates 1-way syncing, Google Calendar(s)>>iCal

    I was looking for 2-way syncing where iCal>>Google Calendar is very important for me

     

    thanks

     

    Pim

  • Ringo De Smet Level 1 Level 1 (85 points)

    Pim,

     

    Once the setup is in place in iCal, you can add any events to these calendars and these are pushed to Google automatically. Isn't that the 2-way sync you need?

     

    Or did you mean 2-way sync between iCloud Calenders and Google Calendars? I can't see a reason to need this, but I doubt this setup works.

     

    Ringo

  • bonafidebob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2012 2:08 PM (in response to crankboy)

    I have the same experience with the delegate calendars, each calender is nested within itself under a "Delegates" category, and I've just lived with it.  Checking either checkbox works.

     

    However, in the last week I've had a new problem:  intermittently all of my extra calendars *also* are appearing under the Gmail category (I named the CalDAV connection to Google Calendars "Gmail"), where on the Personal calendar used to appear.  The calendars that show up here are *nearly* the same ones that show up in the Delegates list in the prefs panel: all of my own calendars are listed, but some calendars shared with me are not.

     

    The problem I'm experiencing is that these new calendars show up checked by default.  So suddenly my calendar is cluttered with many events, and I get reminder messages appearing for old events.  Typically I uncheck them.

     

    A few minutes later (at the next sync?) these calendars all disappear from the Gmail list.  The delegate list remains.

     

    I can reproduce this on demand: quitting Calendar and launching it again makes the set of calendars show up again.  It takes a long time to sync all the events in all of these calendars, "updating..." shows in the title while this is happening.  Once done, if I force a refersh (command-R) the additional calendars disappear again.

     

    Calendar version 6.0 (1645), MacOS version 10.8.2.

  • water su Level 1 Level 1 (0 points)

    hi bonafidebob,

    i have the same problem in calendars' disappearing and duplicating.

    after searching all day long, i might have a work around for you.

     

    1. open this url on mac https://www.google.com/calendar/syncselect

    2. "uncheck" all those calendars and save it

    3. add your google calendar on iCal

    4. select those calendars you need in ical setting>account>your google account>delegate

     

    then they should be stable as usual.

    at lease it works for me for now.

     

    hope this helpful.

     

    P.S. i thought that those calendars might disappear from my i phone. but for now they are still there. so, i think if anyone have problem on iPhone after this fix, maybe you should check out this page for further setting.

    https://m.google.com/sync/settings/iconfig/device

    should open this url on your iPhone/iPad. the settings used to be separated.

  • fmelgar02 Level 1 Level 1 (0 points)

    Ringo - please help.  I'm following your instructions to Set up Google Sync with iOS Calendar, but when I go to http://m.google.com page be it on my mac or iphone 5, I do not see the Sync button nor a sign in button.  What am I missing something?  Thank you

  • alfieebooyh Level 1 Level 1 (0 points)

    I have managed to get my google calender to my iPhone & iPad, but my gmail calender don't show up in icloud calender at icloud.com (using Windows). How can I get gmail calender to my icloud calender?

  • spwatx Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 12:28 PM (in response to rubenpg)

    Thanks so much for the great, detailed post!  I'm having troubles getting this to work and I'm wondering if my os is too old.  Can you do this with Snow Leopard (10.6.8)?  I'm trying to pull my ical into my Google Calendars so I can get to it on my ipad and android phone by just subscribing to my Google calendar.  I don't actually use Google Calendars, it would just be the "middle man" to get my ical on all devices.

     

    Seems as though the Snow Leopard doesn't work with iCloud.

  • kthrynileen Level 1 Level 1 (0 points)

    Thanks Ringo - I was also having calendar syncing issues and when I deselected the calendar sync to iCloud, all of my missing calendar events repopulated on my iPhone.

  • D.I. Kempff Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 25, 2013 12:37 AM (in response to rubenpg)

    Sorry this is not working for me. The google calender is still not showing up in iPhone after sync.

     

    Not sure about step 6: Only have the calender option on.

     

    On iMac click on Google CalDAV I can not choose the calender. Choose change and get a server error?

     

    What is going wrong can anybody tell me?

  • Dhonny Level 1 Level 1 (0 points)

    Guys!

     

    I have a major problem as regards the syncing problem between iCal with Gcal and iCloud. I need to know how to sync my iCal from my Macbook with ICLOUD AND GOOGLE CALENDAR. I managet to sync iCal with ICLOUD OR GOOGLE CALENDAR, but not both at the same time. What I need is when I put an event on iCal, it shows up in all my Apple devices AND my Samsung.

     

    Does somebody know how to do that?


    I thank you in advance!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.