Skip navigation

iMovie not seeing Aperture Video Clips

2500 Views 9 Replies Latest reply: Nov 26, 2012 9:37 PM by Lindberg RSS
Lindberg Calculating status...
Currently Being Moderated
Jul 13, 2012 11:07 AM

My Aperture Library is located in an external hard disk.  When I try to access the movie clips in the library from iMovie '11, under Event Library, it somehow shows the library is located in my local hard disk.  Although it shows up in the wrong place, I can still see the video clips inside.  But the problem is somehow missing quite a lot of clips.  I've tried a few things already:


- made sure all the originals are consolidated in Aperture (3.3.1).

- made share previews always available in Aperture.

- repair the permission in Aperture.

- delete the imovie plist and restart imovie.

- delete the imovie thumdnails and ilifeshared from the Aperture library.


But still cannot solve the problem.  I have tried deleting the imovie thumbnails a few times and let iMovie regenerates those files.  My Aperture library is about 300G.  So, it takes a while to process.  But it seems that each time gives me different results.  Say, this time I see some clips missing.  If I do it again, I will see some of those missing ones, but some other clips will go missing.


Is this a problem when I put the both the Aperture and iMovie libraries on the external drive?  Please help.  Thank you!

iMovie '11, Mac OS X (10.7.4)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.