Skip navigation

Mac OS X Lion WiFi issues

114537 Views 262 Replies Latest reply: Oct 29, 2013 7:15 AM by chirodoody RSS
  • fritshof Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 26, 2012 4:25 PM (in response to Shannon Coffey1)

    Well, I hope for you this solution will stick, but I really don't believe in it. I'm interested in your report after a significant length of time, 6 hours is not enough to convince me. BTW: I'm not comfortable with the idea of deleting the entire SystemConfiguration folder. There's a lot more in there than only network-things. And what do you want me to do with the copy you advise me to make of this folder? Could you be a little more specific?

    Regards,

    F.

  • otterfish Calculating status...
    Currently Being Moderated
    May 26, 2012 7:25 PM (in response to Ethanace)

    Not sure if any of you had the same problem as me with 5GHz Wi-Fi in Lion but my problem was 802.11d which disables certain channels based on the first beacon the Wi-Fi sees when the Mac wakes up.

     

    I needed to set the 5GHz channel on my Airport Extreme to a channel that is supported in all domains like 36 or 40. More info here: http://jeff-with-a-g.blogspot.com.au/2012/04/5ghz-wifi-on-your-mac-got-you-down. html

  • Shannon Coffey1 Level 1 Level 1 (70 points)
    Currently Being Moderated
    May 26, 2012 8:05 PM (in response to fritshof)

    I will provide another message with my experience after a few days. The SystemConfiguration folder has system information that I certainly don't know what is in there. But, I knew from exerience with other preference folders, that the system would remake that folder with the appropriate system information if I got rid of the old one. Assuming for the present that it has fixed my problem, it probably means that the old SystemConfiguration folder had some corrupted files in it and by renaming it or even eliminating it caused the system to remake the folder with valid files and thus fixed the wifi problem. Many system like problems can be traced to corrupt preference files and folders. I have replaced other preference folders, at the suggestion of discussion threads and found them to fix other problems in some cases and not in others. In no case have I had the deletion of a preference file cause me a problem. None the less, saving the old one has been my method of being able to bring it back in case something bad happened, which has never been the case for me. Now that the system is behaving and I have not experienced any bad effects, I have since deleted the older renamed file.

  • chjanson Calculating status...
    Currently Being Moderated
    May 27, 2012 11:33 AM (in response to Shannon Coffey1)

    The posts the latest days are very interesting and I will try the adviced remedies. Can anyone confirm please that it is possible to turn off and then turn on again the Wifi, i.e. by menu command clicking "Turn-Wifi-on" ? On my macbook pro it is impossible to turn on again, unless I restart machine. So this is one way of disabling the Wifi.

    Carl

  • coops213 Calculating status...
    Currently Being Moderated
    Jun 20, 2012 4:53 AM (in response to Ethanace)

    I struggled with this problem ever since installing Lion on a late 2010 MacBook Air. None of the solutions I'd read about had worked, and I reckon I probably tried them all at least once!

     

    Lately it seemed the problem was getting worse. It would more often than not struggle to even find the wifi. When it did router pings would often be around 1500ms with 50% dropped packets.

     

    In the end I bit the bullet and performed a clean install of Lion after wiping the drive. It was relatively painless and I haven't had a problem since.

  • BernRuelas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 10:44 AM (in response to ThaOne)

    This is the fix: This worked like a charm. Actually all I did was move /Library/Preferances/SystemConfiguration to the desktop, rebooted and viola!

    Thanks ThaOne!

    -Bern

  • mgoitein Calculating status...
    Currently Being Moderated
    Jul 29, 2012 6:50 PM (in response to Ethanace)

    Hey Everyone-

    System rebooted from deep sleep, and nothing would work to be able to turn Wifi back on.

    Tried literally everything for an hour, including resetting PRAM and SMC, and repairing permissions, deleting & recreating wifi profiles, etc.

    Only trashing the SystemConfiguration folder did it. And immediately.

    Thanks to everyone for the fix!!!! Most grateful.

  • coops213 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 7:20 PM (in response to coops213)

    Turns out my fix was short lived. After reinstalling the problem crept back after a couple of days. I also remembered I'd been having WiFi issues with my iMac running 10.7, but I'd just reverted to using ethernet instead.

     

    I've since set my wi-fi base station (old apple time capsule) to 5GHz and haven't had a problem for at least a month. No dropouts or anything on both my MacBook air and iMac. The only drawback is some of my other devices can't see the 5GHz network, which just means I've had to set up another access point at 2.4GHz.

     

    So for those of you with 5GHz capable base stations (and a spare to pick up your 2.4GHz devices) it looks like this one works.

  • mtpettyp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2012 9:04 PM (in response to Ethanace)
  • PDiggy Calculating status...
    Currently Being Moderated
    Aug 11, 2012 12:37 AM (in response to Ethanace)

    Haven't read this whole thread, so I don't know if all of these have already been suggested, but....

     

    All Things Apple just posted a few things to try, for both Lion and Mountain Lion.  The main ones:

     

    Fix #1: Add a New Network Location and Renew DHCP

    Fix #2: Change MTU Size to prevent Dropped Connections


    I'd add one more important step from their additional suggestions:

    Try changing the channel of the router you are connected to - especially if there are other wifi networks withing range of you that might be causing interference.  And in another thread on this topic, folks have had some success by updating the router's firmware.

     

    For those last two, consult your router's manual. For the first two, instructions are here:

     

    http://allthingsapple.me/got-os-x-mountain-lion-wifi-problems-heres-the-solution /

  • Augend Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 22, 2012 4:10 PM (in response to Ethanace)

    I COULD RESOLVE IT FOR MYSELF.

     

    One year ago I had the same problem. This was related to my ISP ( I had wifi connection with continually disconnections and I could successfully ping yahoo.com) .

    Go to a coffee shop , airport or library with WIFI and check if your problem resolves. If so, find out which ISP they are using and just change to that one.

    Since last year I have not had even one drop down.

    I know someone may say " This is not our responsibility to change our ISP and Apple should care about this issue, " but I prefered to stop complaining and just changing my ISP and now I have no problem with my wifi.

  • AhaAby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2012 4:27 PM (in response to Augend)

    Thank you Augend. I am in my college's library and it seems it works fine!

    I think I should change my ISP

     

    THANKS!

  • Dagge3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2012 12:58 PM (in response to Ethanace)

    I am experiencing the same problems as many posters have described in this thread. I don't have a solution but I know how the problem was vreated (for me).

     

    My problem is that an hour ago it became impossible to connect to internet via WiFi. I am running Lion on a MacBook Pro (early 2008). In the network preference pane I have a button with "Turn WiFi On" and sometimes a  item from Wi-Fi in the menu bar. Clicking "Turn WiFi On" does not help - nothing happens. Presently, after a number of restarts, the Wi-Fi icon in the menu bar just says "No Hardware Installed".

     

    In my case I run Apple Hardware Test - and after that WiFi stopped working.

     

    Background: WiFi was working fine on my MacBook. I was going to make a clean install of Mountain Lion so I created a bootable backup on an external drive.

     

    When the backup was done I booted from the external disk. WiFi worked.

     

    I restarted the MacBook from the internal HD and WiFi worked fine.

     

    I decided to run Apple Hardware Test (from the CD that came with the computer). I run the extended test which took a bit over one hour.

     

    I booted the MacBook from the internal HD - WiFi was not working, so I connected with an ethernet cable.

     

    Then I did a couple of restarts, and tried some tips from this thread  - nothing helped.

     

    Then I decided to boot from the external HD, which was unchanged since when it was running WiFi perfectly. Now WiFi does not work.

     

    So I am pretty certain that Apple Hardware Test did something harmful to the WiFi hardware.

     

    It would be interesting to hear if others have similar experiances and on what Mac models

  • subhasfromlondon Calculating status...
    Currently Being Moderated
    Sep 2, 2012 2:07 PM (in response to Dagge3)

    Lion - network issues. I tried everything in this forum and even spoke to apple, who have acknowledged the problem and the only solution they could offer was wait for a further update. Tried changing channel etc no joy.

     

    Well I gave up and started using the apple remote wifi adapter, and hooked in via Ethernet. Worked fine. But coin coincidentally, I just moved house and virgin ( my ISP) changed the router, and guess what everything was back to normal. So do check the make and model of the router !

     

    Best of luck.

  • Dagge3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2012 4:36 PM (in response to Dagge3)

    When the wifi card is completely dead it could be a real hardware problem as this video shows -

    http://www.youtube.com/watch?v=UsSIUs7jzQc&feature=youtube_gdata_player

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.