Skip navigation

Mountain Lion - Airplay, no audio

63813 Views 44 Replies Latest reply: Nov 20, 2013 11:41 PM by effgen RSS
  • effgen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2012 1:44 AM (in response to ashlieie)

    I went to router settings, done so by entering 192.168.0.1 in safari, then user name and password. You should find yours at the back of your router(address might b different) then went into SuperHub settings, in wifi tab mine was set to 5GHz, changed it to 2.4, saved changes, restarted osx, and it made a trick. But sometimes after i turned air mirroring off, sound stays. You have to quit vlc completely.

    Also after qutting airplay, image on mac becomes not that great, colors are not sharp, dont know why yet..to get it back to normal i have to restart mac. I think apple need to look into it. Hopefully it will help

  • macamat Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2012 1:32 PM (in response to Scooley84)

    I had the same problem, mid-2011 Macbook Air, Gen 3 Apple TV. My router is an 02 Wireless 2 (in the UK) which does not allow you to change the band.

     

    Luckily for me the Apple TV is right near the router so I just plugged it in through an ethernet cable instead, which worked.

  • slostorm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2012 10:29 AM (in response to Scooley84)

    I have 2nd gen AppleTV (720p) and a Mid-2011 Macbook Air running on an Airport Extreme. The AppleTV is connected by ethernet.

     

    I was able to do AIrPlay mirroring with video AND audio, but if I tried to do audio only, the screen would blink momentarily and then it would blink off and wouldn't work.

     

    I switched the Airport Extreme to 5G and now it works. This isn't a permanent solution for me because I have older devices that need the other freq.

  • falconphysics Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 14, 2012 2:22 PM (in response to Scooley84)

    I had the same problem. AppleTV 3rd generation Early 2011 MacBookPro 13 inch.

     

    I could see my AppleTV in my audio devices, but could not select it as an output. However, I was able to use Soundflower as the output feeding to the AppleTV to get sound to work.

     

    I was on a Meru network. I have no idea what frequency the routers use.

  • aeronp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 12:02 PM (in response to Scooley84)

    Has anyone had the same problem and fixed it using a BT Home Hub 3 router?

     

    Thanks

  • Frollino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2012 2:59 PM (in response to aeronp)

    Just restarted WiFi on my macbook and it resolved the issue!

     

    I had a similar problem today when I powered on my windows machine, the time capsule backups and file sharing started to be very slow, then powered off the windows machine, restarted wifi on mac, and speed went back to normal.

  • ctusjackbauer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2012 5:20 PM (in response to Scooley84)

    Mid 2011 macbook air, 3rd gen apple tv.

     

    if i option click sound, and select apple tv ... it works maybe 50% of the time. As well, I've found restarting my computer resolves the issue.

  • w1nt3rmut3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 1:50 AM (in response to ctusjackbauer)

    Mid 2011 MacBook Air, 2nd gen AppleTV. Video AirPlay works everytime, but audio (either with video or on its own) works maybe 25% of the time at best. Restarting the AppleTV and/or the laptop helps, but the problem comes back pretty quickly.

     

    A feature of the problem is that when I try to select the AppleTV as the sound output device it's briefly visually selected while I hold down the mouse and then immediately flicks back to the internal speakers.

     

    My AppleTV is connected over WiFi, while my MacBook is connected via Ethernet so I don't *think* this is necessarily a problem only related to the devices being on different wireless frequencies. I just tried connecting my AppleTV to the 2.4GHz network and it didn't help at all. It could definitly be a problem relating to routers in general though. I'm on a Cisco LinkSys E3200. More discussions:

     

    https://discussions.apple.com/message/19599923#19599923

    https://discussions.apple.com/message/17179183#17179183

     

    Basically audio AirPlay on Mountain Lion is flakey as **** and Apple need to fix it.

  • bjdku Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2012 1:35 PM (in response to Scooley84)

    It isn't a wifi issue between 2.4 and 5 GHZ.  I have an last gen Airport Extreme base station and a 3rd gen apple TV and a 2011 Macbook Pro.  They are all on the same WiFi frequency and I see this issue sometimes.

     

    I found this elsewhere on the internet.  Worked perfectly. 

     

    This is an issue with Core Audio on OS X getting caught in some sort of resource availability loop with Apple TV. If you restart Core Audio on OS X and make sure there are no other iOS or OS X devices requesting access to the ATV, then it'll fix this issue. To restart Core Audio you can either:


    Method 1:

    1) Open Activity Monitor (control + space then start typing "activity monitor")

    2) Find the process coreaudiod

    3) Select and quit


    Method 2:

    1) Open terminal

    2) type command: sudo killall coreaudiod

    3) enter admin password and confirm


    OS X will cycle Core Audio on and off and voila- your audio streaming will work again.


    There's no way to prevent this issue right now. It's a Mountain Lion bug, I think because I can swap control between my iPhone and iPad without any issues like this coming up.

  • smes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2012 6:50 PM (in response to BeenJaminRocks)

    BeenJaminRocks, Thanks for sending me down this path. Choosing either 2.4 GHz or 5GHz worked for me.

     

    Click on

    BeenJaminRocks wrote:

     

    Click on the AirPort status icon in the menu bar For available networks.

    Mine shows AirPort Extreme and AirPort Extreme 5GHz.

     

    You may not have the 5GHz option it needs to be setup in AirPort Utility.

    Go to Utilities, AirPort Utility, Click on the Airport Extreme then edit.

    Click on the Wireless tab then Wireless Options.

    If 5GHz is not checked then you do not have 5GHz enabled.

    Untitled.png

    I would not suggest enabling it if is is not because using the 5GHz Network is when my sound did not work.

    the AirPort status icon in the menu bar For available networks.

    Mine shows AirPort Extreme and AirPort Extreme 5GHz.

     

    You may not have the 5GHz option it needs to be setup in AirPort Utility.

    Go to Utilities, AirPort Utility, Click on the Airport Extreme then edit.

    Click on the Wireless tab then Wireless Options.

    If 5GHz is not checked then you do not have 5GHz enabled.

  • grp2c Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 10:53 PM (in response to Frollino)

    Restarting wifi worked for me.

  • Airsculpture Level 4 Level 4 (1,320 points)
    Currently Being Moderated
    Nov 24, 2012 6:59 AM (in response to bjdku)

    I am not connected by wifi at all, all ethernet connections and I had this exact issue. I followed the instructions for core audio and hey presto back working. But yes, last week working, this work not, but this did fix it ftb.

  • hiddenmuse Level 3 Level 3 (970 points)
    Currently Being Moderated
    Dec 1, 2012 12:21 PM (in response to Scooley84)

    How do I check which band the AppleTV is connected to and change it if need be? I went through all the menus on it and don't see anything about 2.5 vs 5 Ghz. I'm using a TimeCapsule as my router, fwiw.

  • w1nt3rmut3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 3:20 AM (in response to hiddenmuse)

    Hey, you should try bjdku's solution above. Kill the coreaudiod process. That's what works for me when AirPlay stops working.

     

    I think the wireless network frequency is possibly a red herring ... but if you want to test it here's an answer to your question. There's no option on the ATV to switch between wireless frequencies directly, instead you need to connect it to either a 2.5 or 5Ghz WiFi network. Some routers broadcast both frequencies under the same network name, others broadcast seperately. I'm not sure about the TimeCapsule. You should dig into your router's options/menus and try and understand which frequency your router is using and if you can tweak the settings etc.

  • Sven W Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2012 6:14 AM (in response to w1nt3rmut3)

    Well, I don't even have the "coreaudiod" in my Activity Monitor (in Swedish here)

    MacBook Air -12, 10.8.2. But it exist on my MacPro. Strange...

    Skärmavbild 2012-12-10 kl. 14.58.04.png

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.