Skip navigation

I TimeMachine'd my MacBook Pro into my new MacBook Air, and I lost the AppStore

832 Views 3 Replies Latest reply: Sep 4, 2012 12:13 AM by HACKINT0SH RSS
LauraBerenice Calculating status...
Currently Being Moderated
Sep 3, 2012 5:05 PM

The AppStore icon had a white "do not enter" type of sign on top and wouldn't open. It said the file/program/app was boken or corrupted. I ran the system updates (none for the Os, but still I tried), and nothing.

 

So before asking I googled a lot, and someone suggested to take the AppStore icon, take it to the trash, empty trash and then try to download the 10.6 Combo Update directly from the Apple website. I did just that, but since my OS is currently at 10.6.8 it wouldn't let me install that particular update. I googled again and read about downloading the OS 10.6.8 update, that it fixed some AppStore problems and it probably included the AppStore there. Tried that, and again, nothing. Still no AppStore installed.

 

Long story short, my App Store broke, I erased it and need to download it again. Help?

MacBook Air, Mac OS X (10.6.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.