Skip navigation

MacBook Pro loses access to 1 memory slot upon shutdown or reboot in OS X 10.8.1

7917 Views 36 Replies Latest reply: Feb 14, 2014 1:44 PM by iveney RSS
1 2 3 Previous Next
s.j.richardson Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 3, 2012 10:12 AM

I have had 4GB of RAM in my mid-2009 13-inch MacBook Pro since a few weeks after purchasing it in 2009.  Until a couple of weeks ago, this machine has been running OS X 10.6.8 with no RAM issues.  I wanted to wait for 10.8.1 before doing a clean install of Mountain Lion on this MacBook  So, the day that 10.8.1 was released to the App Store I immediately purchased and downloaded the new OS.  I then performed a clean install of the OS, got all my software setup, and all was right with my MacBook.

 

However, over the next week I noticed upon startup or reboot of the machine everything felt sluggish. I opened the activity monitor and clicked on the system memory tab, it showed 2GB.  I immediately clicked on the About This Mac button to see how much RAM was installed, it showed only one 2GB stick installed (the other memory slot was empty).  The next option I chose was to restart the computer.  Upon startup it still only showed one 2GB stick.  Next, I shutdown the computer, opened the back cover, and proceeded to remove both 2GB sticks of memory. I blew out the slots with compressed air, swapped the positions of each stick and reseated the memory.

 

I started up the computer and to my pleasant surprise both memory slots were recognizing 2GB each (4GB total). I thought this had permanently resolved the issue, but unfortunately after every shutdown or reboot my MacBook (without fail) loses access to the second memory slot, unless I remove and reseat the memory. 

 

This problem did not start until after installing 10.8.1.  I have tried countless SMC and PRAM resets.  Please help.

MacBook Pro, OS X Mountain Lion (10.8.1), 13-inch, Mid 2009, 4GB RAM, 500GB
  • drjingles31 Level 1 Level 1 (0 points)

    So it continues to do even after you have physically made sure the ram placement is ok? I am having the same exact problem as you.  I have a mid 2010 MBP with 4gb with only 2 showing up after sleep, restart unless I do the ram reset while booting.

  • D.I. Johnson Level 3 Level 3 (815 points)

    Hi.

     

    Yes, I have an idea.

     

    It maybe that the RAM you currently have installed is somehow faulty.  It may have been faulty from day one, and perhaps there are certain things in the now OS that make it less tolerant of any RAM faults that might exist.

     

    If you still have the original RAM that came with the machine, I suggest removing the upgrade and reinstalling the oem modules.  See if that helps. If the symptoms disappear, it is an indication that the upgrade(s) is/are the problem.  If you bought from a reputable retailer, many manufacturers stand behind their product with lifetime warranties.

     

    Bueller

  • Shootist007 Level 6 Level 6 (16,640 points)

    I suspect the one RAM slot is going bad. It is making intermittent contact with the Logic board. This can happen from age and heat/cool cycling over time and poor parts assembly. Contrary to what most people think Apple computers are not built any better then any other brand. They do not use any better parts and are not assembled any better then any other.

     

    The only way to full fix this issue is to more then likely replace the Logic board which in the end you'd be better off just buying a New Computer.

  • William Lloyd Level 6 Level 6 (19,205 points)

    It's also possible that the RAM itself is bad.  Is it 3rd party RAM?

  • D.I. Johnson Level 3 Level 3 (815 points)

    This is a good point, and after carefully rereading your original post, I believe Shootist007's evaluation may be more likely. Especially inlight of the fact that after swapping the RAM modules, the same memory slot is failing to register with the OS.

     

  • Shootist007 Level 6 Level 6 (16,640 points)

    Just a coincidence and or the heat generated in the RAM and the slot with the install of the New OS just made it show up now. With the install of a new OS there is a lot of reading and writing to and from the RAM to the HDD. More then in any normal operations.

     

    If you made a Time Machine backup from just before you did the upgrade to Mt Lion you could always make a second partition on your drive, or use an external, and restore that TM backup so you can boot to Lion and check to see it the RAM shows up all the time.

     

    EDIT:

     

    Yes do a clean install of SL and check.

  • drjingles31 Level 1 Level 1 (0 points)

    This didn't happen to me until I upgraded back to Lion the second time. I went from Lion back to a clean install of Snow Leopard back to Lion and then I had the problem with it not waking from sleep. The first instance with Lion I had no problems. So I decided to go back and do another install of Snow Leopard and the problem stayed with me. I am now on 10.8.1 and the problem remains the same.

     

    I have, kind of, solved the sleep problems by putting hibernatemode at 25. This has allowed me to wake the computer up without a hard reset, but when I do wake it up it makes that hard drive spinning noise twice, almost as if it is waking up twice. Then, back to 2gb unless I reset the ram. I am going to take the case off tomorrow and just make sure everything is ok in there, but other than that I am just hoping it's not the logic board as my computer is a few years old now. I may also just throw a 4gb into the one thats working.

     

    Memtest has found no problems either, both with 2gb and 4gb showing.

     

    Thanks for the help everyone, this is really driving me nuts and answers are hard to come by.

  • Shootist007 Level 6 Level 6 (16,640 points)

    Sorry I have no idea about your waking problems but I don't think it is related in any way to the OPs problem.

     

    Simple fact is RAM is hardware. It is either good or bad, it either shows up or it doesn't. There is No software involved with the detection of the amount of RAM in the system. The Hardware in the system is recorded by and reported to the OS by the firmware and the System Management Controller. No operating system or change in it will change the state of whether or not the hardware is recorded and reported.

     

    So that leaves the SMC which I guess could go bad in some way. But then if it did the only way to fix it would be to change out the Logic board. The same for a bad RAM slot and or bad slot to Logic board connection.

  • drjingles31 Level 1 Level 1 (0 points)

    Thanks for the quick respone. I have been trolling the internet for days with this problem. I have found a few similare threads that detail this and in one of them someone is claiming apple replaced the logic board and the ram and the problem persisted.

     

    https://discussions.apple.com/message/11276081#11276081

     

    It seems to be a reoccuring problem with this generation of 2009-10 macbooks.

  • Shootist007 Level 6 Level 6 (16,640 points)

    Simple tests.

     

    1) Take an external and make multiple partitions on it. Install all version of OS X that you have access to and will lrun on your model Mac each in there own partition on the external. Run all of them one after the other then boot back into the OS on the internal. Does all the RAM show in one and not the other?

     

    2) When the system is reporting only RAM from one slot run the Apple Hardware Test, either from DVD disc supplied with the system or from over the internet. That will take all inbstalled versions of OS X out of the picture.

     

    As to the person that stated Apple change both RAM and Logic board and the problem continued. Apple probably changed one and not the other. Or that person is flat out lying. ( Oh I forgot no one lies on the Internet).

     

    By the way I am a Hot 17 year old looking for Love. And I have a Bridge I'd like to sell to someone.

  • drjingles31 Level 1 Level 1 (0 points)

    I thought he might be lying, or apple for that matter, so I took it with a grain of salt. I will continue the hunt tomorrow as I need my computer for some work tonight.

  • Shootist007 Level 6 Level 6 (16,640 points)

    drjingles31 wrote:

     

    I thought he might be lying, or apple for that matter, so I took it with a grain of salt. I will continue the hunt tomorrow as I need my computer for some work tonight.

    Are you by chance interested in the Bridge? Ha Ha

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.