Skip navigation

Managing a Snow Leopard (10.6) Server from Mountain Lion (10.8)

2101 Views 7 Replies Latest reply: Nov 19, 2012 7:15 AM by MrHoffman RSS
l008com Level 1 Level 1 (35 points)
Currently Being Moderated
Sep 4, 2012 3:14 AM

I just upgraded my Mac Pro from 10.6 (client) to 10.8. It's not nearly as bad as the ugprade to Lion (which I reverted after a month). But one big problem is that my Server Admin tools no longer work. Neither the 10.6 nor the 10.7 Server Admin tools will run on Lion. They're like PPC apps in the way they won't even launch. Is there any way to get these apps to run? I was reading an Apple tech doc about this, and that page implies that the only way to adminster my server is to screen share, meaning you can't user Server Admin 10.6 <-> 10.8. If course, even using screen sharing is a problem since 10.8 doesn't seem able to connect to a 10.6 Server's VPN.

 

This is a real pinch I'm in here. As a temporary work-around, I can run a copy of 10.6 in a virtual machine. But booting that VM every time I need to poke around in Server Admin is a TERRRRRRRRIBLE way to work.

  • MrHoffman Level 6 Level 6 (11,700 points)

    This has been the case for many releases.   Apple expects folks to stay current, and isn't afraid to (quickly) remove support for the older stuff.

     

    You'll find various previous discussions of the rather limited range of versions that the server tools will support, as an example.  In general, you'll want to (need to) use the same version and (at most, and in general) you'll get the span of the last few point-updates of the previous version and the first few of the following version with the server tools.  (This can involve the usual upgrades and replacing hardware on a schedule, too, and particularly if Apple maintains their recent release cadence.)

     

    The usual choices here are to upgrade the 10.6.8 box (or to replace and migrate and retire it), or use screen sharing (into the server, or into a 10.6 box and the tools from there), or yes, use Bootcamp or a VM guest.   Of these, Apple would likely prefer the clients and servers be updated to (more) current, or replaced.

  • Jeff Kelleher Level 4 Level 4 (3,015 points)

    I know it's no real help, but here's the kb article related to all this.

    http://support.apple.com/kb/HT1822

    If my memory serves me, server tool compatability has not been totally consistent. Some 10.x versions have worked with others, and some have not.

    I agree that it's a hassle.

  • Dave Hauss Level 1 Level 1 (75 points)

    This is not good.. I have 2 teachers who manage their own labs using WORKGROUP MANAGER.  I now have to teach them to use screen sharing (VNC:) to remote into the actual server since our server is 10.6.8 and the NEW iMacs are 10.8 (replacing older 10.6 imacs).  Why does apple do this and does anyone have a good workaround?

  • MrHoffman Level 6 Level 6 (11,700 points)

    This is a user forum, so you won't get official answers here.

     

    I suspect you already know the answer to your question.

     

    Apple is just not going to keep older software versions around.  They were one of the first vendors (if not the first)  to discontinue floppy drives on Mac systems, they're now discontinuing DVD drives on newer systems, and Mountain Lion does not support mid-vintage Apple hardware systems.

     

    If you need to run on older OS X or OS X Server releases for longer intervals or in mixed environments — and for whatever reason — then OS X Server is not your platform.   There are other vendors which provide longer support windows, RHEL or Scientific Linux or such might be worth a look, and Windows Server has a long support horizon.

     

    But if you want or need to use OS X Server, then you'll either want to budget for and stay (somewhat) more current, or you'll be work with Screen Sharing / RDP / VNC and within (or around) the limits of what Apple supports.

     

    Or the shorter version: I feel your pain.

  • CarloCarlo Level 1 Level 1 (10 points)

    Hello everyone, I was wondering if I can manage my 10.6.8 server using Workgroup Manager 10.8

    Official word from Apple is "You can also use Workgroup Manager 10.8 on Mountain Lion to connect to Lion Server"

    It sounds like it can connect and browse users/computers/groups just fine but before making any change on the server I thought asking first

    Thank you for your help

    Carlo

  • MrHoffman Level 6 Level 6 (11,700 points)

    10.6.8 cannot be managed from a 10.8 OS X installation.  

     

    The article that you cited (HT1822) states "To administer Mac OS X Server v10.6, use the Server Admin Tools 10.6 on Mac OS X v10.6. You should match the version numbers of the server, tools, and admin workstation as closely as possible; for example, use Server Admin Tools version 10.6.8 on Mac OS X v10.6.8 to administer Mac OS X Server v10.6.8.

     

    You may also use the Server Admin Tools 10.7 on OS X Lion to administer Mac OS X Server v10.6."

     

    In the typical best case — and AFAIK, this isn't a documented certainty — you can usually manage OS X Server across adjacent releases; from 10.7 to 10.6, from 10.8 to 10.7, etc.  There have been cases where you're limited to managing just the last few point releases of a series, too.  I've not encountered a case where the tools were supported for and will work (reliably) across more than one adjacent release.

     

    The usual choices here are to upgrade the 10.6.8 box (or to replace and migrate and retire it), or use screen sharing (into the server, or into a 10.6 box and the tools from there), or yes, use Bootcamp or a VM guest.   And again, Apple would likely prefer the clients and servers be updated to (more) current, or replaced.

     

    If you want to or need to run older software releases and for whatever reason(s) that might be — and with a requirement for longer available support and related offerings or longer "service" lifetimes for the software — then RHEL and Windows Server can be better choices.  Apple is not in that business.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.